summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-29 11:46:16 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-29 11:46:16 +0000
commitfc8b24c2bfaace5e3990052990ddaf419528718e (patch)
tree12b4674b1e5b00802ad3d46d3ab9df985f7e6183 /sci-chemistry/gabedit
parentTry to fix: bug 442228 - sci-mathematics/cvc3-2.4.1 - QA Notice: //usr/lib/pk... (diff)
downloadgentoo-2-fc8b24c2bfaace5e3990052990ddaf419528718e.tar.gz
gentoo-2-fc8b24c2bfaace5e3990052990ddaf419528718e.tar.bz2
gentoo-2-fc8b24c2bfaace5e3990052990ddaf419528718e.zip
sci-chemistry/gabedit: Version Bump, #444155
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/gabedit')
-rw-r--r--sci-chemistry/gabedit/ChangeLog7
-rw-r--r--sci-chemistry/gabedit/gabedit-2.4.5.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/sci-chemistry/gabedit/ChangeLog b/sci-chemistry/gabedit/ChangeLog
index 348951acf9cc..ef3be090b1a3 100644
--- a/sci-chemistry/gabedit/ChangeLog
+++ b/sci-chemistry/gabedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/gabedit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.17 2012/07/02 09:07:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.18 2012/11/29 11:46:16 jlec Exp $
+
+*gabedit-2.4.5 (29 Nov 2012)
+
+ 29 Nov 2012; Justin Lecher <jlec@gentoo.org> +gabedit-2.4.5.ebuild:
+ Version Bump, #444155
*gabedit-2.4.3 (02 Jul 2012)
diff --git a/sci-chemistry/gabedit/gabedit-2.4.5.ebuild b/sci-chemistry/gabedit/gabedit-2.4.5.ebuild
new file mode 100644
index 000000000000..26ed1a5fb2e1
--- /dev/null
+++ b/sci-chemistry/gabedit/gabedit-2.4.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.4.5.ebuild,v 1.1 2012/11/29 11:46:16 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs versionator
+
+MY_PN=${PN/g/G}
+MY_PV=$(delete_all_version_separators)
+MY_P="${MY_PN}Src${MY_PV}"
+
+DESCRIPTION="GUI for computational chemistry packages"
+HOMEPAGE="http://gabedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/gl2ps
+ x11-libs/pango
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i "/rmdir tmp/d" "${S}"/Makefile || die
+ sed \
+ -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
+ -i "${S}/Config.h" || die
+ sed -e 's:-g::g' -i Makefile || die
+ cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
+
+ if use openmp && tc-has-openmp; then
+ cat <<- EOF >> "${S}/CONFIG"
+ OMPLIB=-fopenmp
+ OMPCFLAGS=-DENABLE_OMP -fopenmp
+ EOF
+ fi
+ echo "COMMONCFLAGS = ${CFLAGS} -DENABLE_DEPRECATED \$(OMPCFLAGS) \$(DRAWGEOMGL)" >> CONFIG
+
+ tc-export CC
+}
+
+src_compile() {
+ emake clean
+ emake external_gl2ps=1
+}
+
+src_install() {
+ local size
+ dobin ${PN}
+ dodoc ChangeLog
+ dohtml -r html/*
+ for size in 16 24 32 48; do
+ doicon -s ${size} icons/Gabedit${size}.*
+ done
+}