summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-04 07:29:39 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-04 07:29:39 +0000
commit8daf6519fcd0f5d7ecc9465539d63fd10c0f7267 (patch)
tree1bc9ad913fb248b14e07382a22dec0c9b9d3c37d /sci-chemistry/gabedit/gabedit-2.3.6.ebuild
parentFix encoding in ChangeLog (diff)
downloadgentoo-2-8daf6519fcd0f5d7ecc9465539d63fd10c0f7267.tar.gz
gentoo-2-8daf6519fcd0f5d7ecc9465539d63fd10c0f7267.tar.bz2
gentoo-2-8daf6519fcd0f5d7ecc9465539d63fd10c0f7267.zip
Version Bump, provided by Max
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gabedit/gabedit-2.3.6.ebuild')
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.6.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-chemistry/gabedit/gabedit-2.3.6.ebuild b/sci-chemistry/gabedit/gabedit-2.3.6.ebuild
new file mode 100644
index 000000000000..8da7b3930eee
--- /dev/null
+++ b/sci-chemistry/gabedit/gabedit-2.3.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.6.ebuild,v 1.1 2011/03/04 07:29:39 jlec Exp $
+
+EAPI=2
+
+inherit toolchain-funcs versionator
+
+MY_PN=${PN/g/G}
+MY_PV=$(delete_all_version_separators)
+MY_P="${MY_PN}Src${MY_PV}"
+
+DESCRIPTION="GUI for computational chemistry packages"
+HOMEPAGE="http://gabedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/GabeditDevloppment/${MY_PN}${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ x11-libs/gtkglext
+ x11-libs/gl2ps
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i "/rmdir tmp/d" "${S}"/Makefile
+ sed -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
+ -i "${S}/Config.h" || die
+ cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
+
+ if use openmp && tc-has-openmp; then
+ cat <<- EOF >> "${S}/CONFIG"
+ OMPLIB=-L/usr/$(get_libdir) -lgomp
+ OMPCFLAGS=-DENABLE_OMP -fopenmp
+ EOF
+ fi
+ echo "COMMONCFLAGS = ${CFLAGS} -DENABLE_DEPRECATED \$(OMPCFLAGS) \$(DRAWGEOMGL)" >> CONFIG
+}
+
+src_compile() {
+ emake external_gl2ps=1 || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc ChangeLog || die
+}