summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 13:29:53 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 13:29:53 +0000
commitd54e599208aa20de886c67360032a332e5c6912d (patch)
tree1964953495403ae96d93866203c23f6f83456ecd /sci-chemistry/cns
parentha-propser is gone, remove the mask (diff)
downloadgentoo-2-d54e599208aa20de886c67360032a332e5c6912d.tar.gz
gentoo-2-d54e599208aa20de886c67360032a332e5c6912d.tar.bz2
gentoo-2-d54e599208aa20de886c67360032a332e5c6912d.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/cns')
-rw-r--r--sci-chemistry/cns/ChangeLog6
-rw-r--r--sci-chemistry/cns/cns-1.1.ebuild18
-rw-r--r--sci-chemistry/cns/cns-1.2.1-r5.ebuild17
-rw-r--r--sci-chemistry/cns/cns-1.2.1.ebuild15
-rw-r--r--sci-chemistry/cns/cns-1.3_p3.ebuild15
5 files changed, 34 insertions, 37 deletions
diff --git a/sci-chemistry/cns/ChangeLog b/sci-chemistry/cns/ChangeLog
index 86133f204859..33e1904c41ce 100644
--- a/sci-chemistry/cns/ChangeLog
+++ b/sci-chemistry/cns/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/cns
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.30 2010/11/25 13:35:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/ChangeLog,v 1.31 2010/12/16 13:29:53 jlec Exp $
+
+ 16 Dec 2010; Justin Lecher <jlec@gentoo.org> cns-1.1.ebuild,
+ cns-1.2.1.ebuild, cns-1.2.1-r5.ebuild, cns-1.3_p3.ebuild:
+ Removal of fortran.eclass, #348851
*cns-1.3_p3 (25 Nov 2010)
diff --git a/sci-chemistry/cns/cns-1.1.ebuild b/sci-chemistry/cns/cns-1.1.ebuild
index 126e3b3eb8ff..3625a77956f7 100644
--- a/sci-chemistry/cns/cns-1.1.ebuild
+++ b/sci-chemistry/cns/cns-1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.1.ebuild,v 1.6 2010/02/06 21:49:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.1.ebuild,v 1.7 2010/12/16 13:29:53 jlec Exp $
-inherit eutils fortran toolchain-funcs
+inherit eutils toolchain-funcs
MY_PN="${PN}_solve"
MY_P="${MY_PN}_${PV}"
@@ -12,16 +12,18 @@ HOMEPAGE="http://cns.csb.yale.edu/"
SRC_URI="${MY_P}_basic_inputs.tar.gz
${MY_P}_data.tar.gz
test? ( ${MY_P}_test.tar.gz )"
-RESTRICT="fetch"
+
LICENSE="cns"
SLOT="0"
KEYWORDS="ppc x86"
IUSE="test"
+
RDEPEND="app-shells/tcsh"
DEPEND="${RDEPEND}"
+
S="${WORKDIR}/${MY_P}"
-FORTRAN="g77 gfortran"
+RESTRICT="fetch"
pkg_nofetch() {
einfo "Fill out the form at http://cns.csb.yale.edu/cns_request/"
@@ -47,15 +49,15 @@ src_unpack() {
src_compile() {
local GLOBALS
- if [[ ${FORTRANC} = g77 ]]; then
+ if [[ $(tc-getFC) = g77 ]]; then
GLOBALS="-fno-globals"
fi
# make install really means build, since it's expected to be used in-place
emake \
CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
+ F77=$(tc-getFC) \
+ LD=$(tc-getFC) \
CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
F77OPT="${FFLAGS:- -O2} \$(CNS_MALIGN_I86)" \
F77STD="${GLOBALS}" \
diff --git a/sci-chemistry/cns/cns-1.2.1-r5.ebuild b/sci-chemistry/cns/cns-1.2.1-r5.ebuild
index 7ad2f4c09452..64f14807747c 100644
--- a/sci-chemistry/cns/cns-1.2.1-r5.ebuild
+++ b/sci-chemistry/cns/cns-1.2.1-r5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r5.ebuild,v 1.3 2010/11/18 17:05:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1-r5.ebuild,v 1.4 2010/12/16 13:29:53 jlec Exp $
EAPI="3"
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
+inherit eutils toolchain-funcs versionator flag-o-matic
MY_PN="${PN}_solve"
MY_PV="$(delete_version_separator 2)"
@@ -26,8 +26,6 @@ DEPEND="${RDEPEND}"
RESTRICT="fetch"
S="${WORKDIR}/${MY_P}"
-FORTRAN="gfortran ifc"
-
pkg_nofetch() {
elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
use aria && elog "and http://aria.pasteur.fr/"
@@ -37,7 +35,6 @@ pkg_nofetch() {
}
pkg_setup() {
- fortran_pkg_setup
tc-has-openmp
}
@@ -56,7 +53,7 @@ src_prepare() {
fi
# the code uses Intel-compiler-specific directives
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ $(tc-getFC) == gfortran ]]; then
epatch "${FILESDIR}"/${PV}-allow-gcc-openmp.patch
use openmp && \
OMPLIB="-lgomp" && append-flags -fopenmp
@@ -96,22 +93,22 @@ src_prepare() {
src_compile() {
local GLOBALS
local MALIGN
- if [[ ${FORTRANC} = g77 ]]; then
+ if [[ $(tc-getFC) = g77 ]]; then
GLOBALS="-fno-globals"
MALIGN='\$(CNS_MALIGN_I86)'
fi
# Set up the compiler to use
pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
+ ln -s Makefile.header Makefile.header.$(tc-getFC) || die
popd 2>/dev/null
# make install really means build, since it's expected to be used in-place
# -j1 doesn't mean we do no respect MAKEOPTS!
emake -j1 \
CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
+ F77=$(tc-getFC) \
+ LD=$(tc-getFC) \
CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
LDFLAGS="${LDFLAGS}" \
F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
diff --git a/sci-chemistry/cns/cns-1.2.1.ebuild b/sci-chemistry/cns/cns-1.2.1.ebuild
index d1c8c4b27e92..cc78fb1b61e6 100644
--- a/sci-chemistry/cns/cns-1.2.1.ebuild
+++ b/sci-chemistry/cns/cns-1.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1.ebuild,v 1.7 2010/11/17 13:14:53 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.2.1.ebuild,v 1.8 2010/12/16 13:29:53 jlec Exp $
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
+inherit eutils toolchain-funcs versionator flag-o-matic
MY_PN="${PN}_solve"
MY_PV="$(delete_version_separator 2)"
@@ -21,8 +21,6 @@ RDEPEND="app-shells/tcsh"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-FORTRAN="g77 gfortran"
-
pkg_nofetch() {
elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
elog "and place these files:"
@@ -31,7 +29,6 @@ pkg_nofetch() {
}
pkg_setup() {
- fortran_pkg_setup
tc-has-openmp
}
@@ -64,21 +61,21 @@ src_unpack() {
src_compile() {
local GLOBALS
local MALIGN=
- if [[ ${FORTRANC} = g77 ]]; then
+ if [[ $(tc-getFC) = g77 ]]; then
GLOBALS="-fno-globals"
MALIGN='\$(CNS_MALIGN_I86)'
fi
# Set up the compiler to use
pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
+ ln -s Makefile.header Makefile.header.$(tc-getFC) || die
popd 2>/dev/null
# make install really means build, since it's expected to be used in-place
emake \
CC="$(tc-getCC)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
+ F77=$(tc-getFC) \
+ LD=$(tc-getFC) \
CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
LDFLAGS="${LDFLAGS}" \
F77OPT="${FFLAGS:- -O2} ${MALIGN}" \
diff --git a/sci-chemistry/cns/cns-1.3_p3.ebuild b/sci-chemistry/cns/cns-1.3_p3.ebuild
index 4f32d74963d6..d511d92da5e7 100644
--- a/sci-chemistry/cns/cns-1.3_p3.ebuild
+++ b/sci-chemistry/cns/cns-1.3_p3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.3_p3.ebuild,v 1.1 2010/11/25 13:35:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cns/cns-1.3_p3.ebuild,v 1.2 2010/12/16 13:29:53 jlec Exp $
EAPI="3"
-inherit eutils fortran toolchain-funcs versionator flag-o-matic
+inherit eutils toolchain-funcs versionator flag-o-matic
MY_PN="${PN}_solve"
MY_PV="$(delete_version_separator 2)"
@@ -26,8 +26,6 @@ DEPEND="${RDEPEND}"
RESTRICT="fetch"
S="${WORKDIR}/${MY_P/p3}"
-FORTRAN="gfortran ifc"
-
pkg_nofetch() {
elog "Fill out the form at http://cns.csb.yale.edu/cns_request/"
use aria && elog "and http://aria.pasteur.fr/"
@@ -37,7 +35,6 @@ pkg_nofetch() {
}
pkg_setup() {
- fortran_pkg_setup
tc-has-openmp
}
@@ -57,7 +54,7 @@ src_prepare() {
fi
# the code uses Intel-compiler-specific directives
- if [[ ${FORTRANC} == gfortran ]]; then
+ if [[ $(tc-getFC) == gfortran ]]; then
use openmp && \
OMPLIB="-lgomp" && append-flags -fopenmp
COMP="gfortran"
@@ -106,7 +103,7 @@ src_compile() {
# Set up the compiler to use
pushd instlib/machine/unsupported/g77-unix 2>/dev/null
- ln -s Makefile.header Makefile.header.${FORTRANC} || die
+ ln -s Makefile.header Makefile.header.$(tc-getFC) || die
popd 2>/dev/null
# make install really means build, since it's expected to be used in-place
@@ -114,8 +111,8 @@ src_compile() {
emake -j1 \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
- F77="${FORTRANC}" \
- LD="${FORTRANC}" \
+ F77=$(tc-getFC) \
+ LD=$(tc-getFC) \
CCFLAGS="${CFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
CXXFLAGS="${CXXFLAGS} -DCNS_ARCH_TYPE_\$(CNS_ARCH_TYPE) \$(EXT_CCFLAGS)" \
LDFLAGS="${LDFLAGS}" \