summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-18 21:47:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-18 21:47:20 +0000
commitc09955adf831d060d9f0d39b72de9a3016a2c9b3 (patch)
tree94c557b2658be245802bab0b4ee5f2195dd0015a /sci-chemistry/ccpn
parentMissing X-XFCE-Module-Path entry in quicklauncher.desktop wrt #301524. (diff)
downloadgentoo-2-c09955adf831d060d9f0d39b72de9a3016a2c9b3.tar.gz
gentoo-2-c09955adf831d060d9f0d39b72de9a3016a2c9b3.tar.bz2
gentoo-2-c09955adf831d060d9f0d39b72de9a3016a2c9b3.zip
Version Bump and cleaned up old ones
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog10
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild179
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.3.1.ebuild (renamed from sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild)8
-rw-r--r--sci-chemistry/ccpn/files/2.1.3_1-dynamics.patch13
-rw-r--r--sci-chemistry/ccpn/files/2.1.3_1-parallel.patch25
5 files changed, 52 insertions, 183 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index de61ed403acd..e87af19827bb 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/ccpn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.6 2010/02/17 20:59:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.7 2010/02/18 21:47:20 jlec Exp $
+
+*ccpn-2.1.3.1 (18 Feb 2010)
+
+ 18 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/2.1.3_1-dynamics.patch, -ccpn-2.1.2.1_p100204.ebuild,
+ +ccpn-2.1.3.1.ebuild, +files/2.1.3_1-parallel.patch,
+ -ccpn-2.1.2.1_p100213.ebuild:
+ Version bump and old ones removed
*ccpn-2.1.3 (17 Feb 2010)
diff --git a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild b/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild
deleted file mode 100644
index 83dd491e9cb8..000000000000
--- a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild,v 1.2 2010/02/13 21:07:17 jlec Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_USE_WITH="ssl tk"
-
-inherit eutils portability python toolchain-funcs versionator
-
-PATCHSET="${PV##*_p}"
-MY_PN="${PN}mr"
-MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
-
-DESCRIPTION="The Collaborative Computing Project for NMR"
-SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${MY_PN}/analysis${MY_PV}.tar.gz"
- [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentooexperimental.org/~jlec/distfiles/ccpn-update-${PATCHSET}.patch.bz2"
-HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
-
-SLOT="0"
-LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86"
-IUSE="+opengl"
-
-RDEPEND="
- dev-lang/tk
- dev-python/numpy
- dev-tcltk/tix
- opengl? ( virtual/glut )"
-DEPEND="${RDEPEND}"
-RESTRICT_PYTHON_ABIS="2.4 3.*"
-
-RESTRICT="mirror"
-S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
-
-src_prepare() {
- [[ -n ${PATCHSET} ]] && \
- epatch "${WORKDIR}"/ccpn-update-${PATCHSET}.patch
-
- epatch "${FILESDIR}"/${MY_PV}-parallel.patch
-
- local tk_ver
- local myconf
-
- tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
-
- if use opengl; then
- GLUT_NEED_INIT="-DNEED_GLUT_INIT"
- IGNORE_GL_FLAG=""
- GL_FLAG="-DUSE_GL_FALSE"
- GL_DIR="${EPREFIX}/usr"
- GL_LIB="-lglut -lGLU -lGL"
- GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
- GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
-
- else
- IGNORE_GL_FLAG="-DIGNORE_GL"
- GL_FLAG="-DUSE_GL_FALSE"
- fi
-
- GLUT_NOT_IN_GL=""
- GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
-
- python_copy_sources --no-link
-
- preparation() {
- sed \
- -e "s:^\(CC =\).*:\1 $(tc-getCC):g" \
- -e "s:^\(OPT_FLAG =\).*:\1 ${CFLAGS}:g" \
- -e "s:^\(LINK_FLAGS =.*\):\1 ${LDFLAGS}:g" \
- -e "s:^\(IGNORE_GL_FLAG =\).*:\1 ${IGNORE_GL_FLAG}:g" \
- -e "s:^\(GL_FLAG =\).*:\1 ${GL_FLAG}:g" \
- -e "s:^\(GLUT_NEED_INIT =\).*:\1 ${GLUT_NEED_INIT}:g" \
- -e "s:^\(GLUT_NOT_IN_GL =\).*:\1:g" \
- -e "s:^\(X11_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
- -e "s:^\(TCL_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
- -e "s:^\(TK_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
- -e "s:^\(PYTHON_INCLUDE_FLAGS =\).*:\1 -I\$(PYTHON_DIR)/include/python$(python_get_version):g" \
- -e "s:^\(PYTHON_LIB =\).*:\1 -lpython$(python_get_version):g" \
- -e "s:^\(GL_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
- c/environment_default.txt > c/environment.txt
- }
- python_execute_function -s preparation
-}
-
-src_compile() {
- building() {
- emake -C c all links
- }
- python_execute_function -s building
-}
-
-src_install() {
- local libdir
- local tkver
-
- libdir=$(get_libdir)
- tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
-
- for wrapper in analysis dangle dataShifter eci formatConverter pipe2azara; do
- sed -e "s:gentoo_sitedir:${EPREFIX}/$(python_get_sitedir -f):g" \
- -e "s:gentoolibdir:${EPREFIX}/usr/${libdir}:g" \
- -e "s:gentootk:${EPREFIX}/usr/${libdir}/tk${tkver}:g" \
- -e "s:gentootcl:${EPREFIX}/usr/${libdir}/tclk${tkver}:g" \
- -e "s:gentoopython:${EPREFIX}/usr/bin/python:g" \
- "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
- dobin "${T}"/${wrapper} || die "Failed to install ${wrapper}"
- done
-
- installation() {
- local in_path
- local files
-
- in_path=$(python_get_sitedir)/${PN}
-
- for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
- sed \
- -e 's:#from __future__:from __future__:g' \
- -i ${i}
- done
-
- insinto ${in_path}
-
- dodir ${in_path}/c
-
- ebegin "Installing main files"
- doins -r data model python || die "main files installation failed"
- eend
-
- dohtml -r doc/* || die
- dosym ../../../../share/doc/${PF}/html ${in_path}/doc || die
-
- einfo "Adjusting permissions"
-
- files="ccpnmr/c/ContourFile.so
- ccpnmr/c/ContourLevels.so
- ccpnmr/c/ContourStyle.so
- ccpnmr/c/PeakList.so
- ccpnmr/c/SliceFile.so
- ccpnmr/c/WinPeakList.so
- ccpnmr/c/AtomCoordList.so
- ccpnmr/c/AtomCoord.so
- ccpnmr/c/Bacus.so
- ccpnmr/c/CloudUtil.so
- ccpnmr/c/DistConstraintList.so
- ccpnmr/c/DistConstraint.so
- ccpnmr/c/DistForce.so
- ccpnmr/c/Dynamics.so
- ccpnmr/c/Midge.so
- ccp/c/StructAtom.so
- ccp/c/StructBond.so
- ccp/c/StructStructure.so
- ccp/c/StructUtil.so
- memops/c/BlockFile.so
- memops/c/FitMethod.so
- memops/c/GlHandler.so
- memops/c/MemCache.so
- memops/c/PdfHandler.so
- memops/c/PsHandler.so
- memops/c/ShapeFile.so
- memops/c/StoreFile.so
- memops/c/StoreHandler.so
- memops/c/TkHandler.so"
-
- for FILE in ${files}; do
- fperms 755 ${in_path}/python/${FILE}
- done
- }
- python_execute_function -s installation
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}
diff --git a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild b/sci-chemistry/ccpn/ccpn-2.1.3.1.ebuild
index 29bd3d233655..d688af9dfc66 100644
--- a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild,v 1.4 2010/02/13 21:07:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.3.1.ebuild,v 1.1 2010/02/18 21:47:20 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -9,7 +9,7 @@ PYTHON_USE_WITH="ssl tk"
inherit eutils portability python toolchain-funcs versionator
-PATCHSET="${PV##*_p}"
+#PATCHSET="${PV##*_p}"
MY_PN="${PN}mr"
MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
@@ -20,7 +20,7 @@ HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
SLOT="0"
LICENSE="|| ( CCPN LGPL-2.1 )"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="+opengl"
RDEPEND="
@@ -39,6 +39,7 @@ src_prepare() {
epatch "${WORKDIR}"/ccpn-update-${PATCHSET}.patch
epatch "${FILESDIR}"/${MY_PV}-parallel.patch
+ epatch "${FILESDIR}"/${MY_PV}-dynamics.patch
local tk_ver
local myconf
@@ -66,6 +67,7 @@ src_prepare() {
preparation() {
sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
-e "s:^\(CC =\).*:\1 $(tc-getCC):g" \
-e "s:^\(OPT_FLAG =\).*:\1 ${CFLAGS}:g" \
-e "s:^\(LINK_FLAGS =.*\):\1 ${LDFLAGS}:g" \
diff --git a/sci-chemistry/ccpn/files/2.1.3_1-dynamics.patch b/sci-chemistry/ccpn/files/2.1.3_1-dynamics.patch
new file mode 100644
index 000000000000..4462a8443f94
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.1.3_1-dynamics.patch
@@ -0,0 +1,13 @@
+diff --git a/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs b/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
+index 8f56168..4490407 100755
+--- a/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
++++ b/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
+@@ -5,7 +5,7 @@ ln -s ../../../c/ccpnmr/analysis/ContourFile.so ContourFile.so
+ ln -s ../../../c/ccpnmr/analysis/ContourLevels.so ContourLevels.so
+ ln -s ../../../c/ccpnmr/analysis/ContourStyle.so ContourStyle.so
+ ln -s ../../../c/ccpnmr/analysis/PeakCluster.so PeakCluster.so
+-ln -s ../../../c/ccpnmr/analysis/PeakClusterList.so PeakClusterList.so
++#ln -s ../../../c/ccpnmr/analysis/PeakClusterList.so PeakClusterList.so
+ ln -s ../../../c/ccpnmr/analysis/PeakList.so PeakList.so
+ ln -s ../../../c/ccpnmr/analysis/SliceFile.so SliceFile.so
+ ln -s ../../../c/ccpnmr/analysis/WinPeakList.so WinPeakList.so
diff --git a/sci-chemistry/ccpn/files/2.1.3_1-parallel.patch b/sci-chemistry/ccpn/files/2.1.3_1-parallel.patch
new file mode 100644
index 000000000000..b1dd4d2f264f
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.1.3_1-parallel.patch
@@ -0,0 +1,25 @@
+diff --git a/ccpnmr2.1/c/Makefile b/ccpnmr2.1/c/Makefile
+index 9fa8500..7a1a186 100644
+--- a/ccpnmr2.1/c/Makefile
++++ b/ccpnmr2.1/c/Makefile
+@@ -7,16 +7,16 @@ compile: global structure analysis clouds dynamics
+ global:
+ cd memops/global && $(MAKE)
+
+-structure:
++structure: global
+ cd ccp/structure && $(MAKE)
+
+-analysis:
++analysis: global
+ cd ccpnmr/analysis && $(MAKE)
+
+-clouds:
++clouds: global
+ cd ccpnmr/clouds && $(MAKE)
+
+-dynamics:
++dynamics: global
+ cd ccpnmr/dynamics && $(MAKE)
+
+ clean: global_clean structure_clean analysis_clean clouds_clean dynamics_clean