summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 21:07:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 21:07:22 +0000
commit8f0103655bf85aae690805d2092d9c2cc5ae3d48 (patch)
tree1c2344f6e16c5002960557b5eb30c12278d9dad6 /sci-chemistry/ccpn
parentUpdating Guillaume's mail (diff)
downloadgentoo-2-8f0103655bf85aae690805d2092d9c2cc5ae3d48.tar.gz
gentoo-2-8f0103655bf85aae690805d2092d9c2cc5ae3d48.tar.bz2
gentoo-2-8f0103655bf85aae690805d2092d9c2cc5ae3d48.zip
Fixed parallel build problems, bug 304959
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog7
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild4
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild4
-rw-r--r--sci-chemistry/ccpn/files/2.1.2_1-parallel.patch21
4 files changed, 33 insertions, 3 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index dbebed62202a..5f11fd61afad 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/ccpn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.3 2010/02/13 16:30:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.4 2010/02/13 21:07:17 jlec Exp $
+
+ 13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/2.1.2_1-parallel.patch, ccpn-2.1.2.1_p100204.ebuild,
+ ccpn-2.1.2.1_p100213.ebuild:
+ Fixed parallel build problems, bug 304959
*ccpn-2.1.2.1_p100213 (13 Feb 2010)
diff --git a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild b/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild
index fe792dfdcc3c..29bd3d233655 100644
--- a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild,v 1.3 2010/02/07 01:34:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100204.ebuild,v 1.4 2010/02/13 21:07:17 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -38,6 +38,8 @@ src_prepare() {
[[ -n ${PATCHSET} ]] && \
epatch "${WORKDIR}"/ccpn-update-${PATCHSET}.patch
+ epatch "${FILESDIR}"/${MY_PV}-parallel.patch
+
local tk_ver
local myconf
diff --git a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild b/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild
index e4f80f2513af..83dd491e9cb8 100644
--- a/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild,v 1.1 2010/02/13 16:30:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.2.1_p100213.ebuild,v 1.2 2010/02/13 21:07:17 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2:2.5"
@@ -38,6 +38,8 @@ src_prepare() {
[[ -n ${PATCHSET} ]] && \
epatch "${WORKDIR}"/ccpn-update-${PATCHSET}.patch
+ epatch "${FILESDIR}"/${MY_PV}-parallel.patch
+
local tk_ver
local myconf
diff --git a/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch b/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch
new file mode 100644
index 000000000000..3b1917d581f6
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch
@@ -0,0 +1,21 @@
+diff --git a/ccpnmr2.1/c/Makefile b/ccpnmr2.1/c/Makefile
+index 2208c06..71a87c9 100644
+--- a/ccpnmr2.1/c/Makefile
++++ b/ccpnmr2.1/c/Makefile
+@@ -7,13 +7,13 @@ compile: global structure analysis clouds
+ global:
+ cd memops/global && $(MAKE)
+
+-structure:
++structure: global
+ cd ccp/structure && $(MAKE)
+
+-analysis:
++analysis: global
+ cd ccpnmr/analysis && $(MAKE)
+
+-clouds:
++clouds: global
+ cd ccpnmr/clouds && $(MAKE)
+
+ clean: global_clean structure_clean analysis_clean clouds_clean