summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-21 13:37:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-21 13:37:00 +0000
commit4f080a8038c45581eee07779e8b944d2b4dd342e (patch)
tree876a62c9a5c7b0bd5bf01730155dbec8b22c1f5a /sci-chemistry/ccpn
parentUnmask xcb USE flag on mips (diff)
downloadgentoo-2-4f080a8038c45581eee07779e8b944d2b4dd342e.tar.gz
gentoo-2-4f080a8038c45581eee07779e8b944d2b4dd342e.tar.bz2
gentoo-2-4f080a8038c45581eee07779e8b944d2b4dd342e.zip
Last version suffers from some leftovers on my system
(Portage version: 2.2_rc84/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog4
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.5_p100921-r1.ebuild (renamed from sci-chemistry/ccpn/ccpn-2.1.5_p100921.ebuild)22
2 files changed, 15 insertions, 11 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index 5dcfb210f15a..3927c265efb3 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sci-chemistry/ccpn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.33 2010/09/21 13:11:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.34 2010/09/21 13:37:00 jlec Exp $
*ccpn-2.1.5_p100921 (21 Sep 2010)
*ccpn-2.1.3.1_p100806 (21 Sep 2010)
@@ -9,7 +9,7 @@
-ccpn-2.1.2.1_p100216.ebuild, -ccpn-2.1.3.1_p100519.ebuild,
-ccpn-2.1.3.1_p100607.ebuild, -ccpn-2.1.3.1_p100628.ebuild,
-ccpn-2.1.3.1_p100713.ebuild, +ccpn-2.1.3.1_p100806.ebuild,
- +ccpn-2.1.5_p100921.ebuild, +files/depositionFileImporter,
+ +ccpn-2.1.5_p100921-r1.ebuild, +files/depositionFileImporter,
+files/extendNmr:
Version Bump, splitted sci-libs/ccpn-data out, removed old
diff --git a/sci-chemistry/ccpn/ccpn-2.1.5_p100921.ebuild b/sci-chemistry/ccpn/ccpn-2.1.5_p100921-r1.ebuild
index 4da316a88732..162105e74a3d 100644
--- a/sci-chemistry/ccpn/ccpn-2.1.5_p100921.ebuild
+++ b/sci-chemistry/ccpn/ccpn-2.1.5_p100921-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.5_p100921.ebuild,v 1.1 2010/09/21 13:11:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.5_p100921-r1.ebuild,v 1.1 2010/09/21 13:37:00 jlec Exp $
EAPI="3"
@@ -14,6 +14,7 @@ inherit eutils portability python toolchain-funcs versionator
PATCHSET="${PV##*_p}"
MY_PN="${PN}mr"
MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
+MY_MAJOR="$(get_version_component_range 1-3)"
DESCRIPTION="The Collaborative Computing Project for NMR"
SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${MY_PN}/analysis${MY_PV}.tar.gz"
@@ -29,7 +30,7 @@ RDEPEND="
dev-lang/tk[threads]
>=dev-python/numpy-1.4
>=dev-tcltk/tix-8.4.3
- =sci-libs/ccpn-data-2.1.5*
+ =sci-libs/ccpn-data-"${MY_MAJOR}"*
x11-libs/libXext
x11-libs/libX11
opengl? ( media-libs/freeglut )"
@@ -108,11 +109,11 @@ src_install() {
tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
for wrapper in analysis dangle dataShifter depositionFileImporter extendNmr eci formatConverter pipe2azara; do
- sed -e "s:gentoo_sitedir:${EPREFIX}/$(python_get_sitedir -f):g" \
- -e "s:gentoolibdir:${EPREFIX}/usr/${libdir}:g" \
- -e "s:gentootk:${EPREFIX}/usr/${libdir}/tk${tkver}:g" \
- -e "s:gentootcl:${EPREFIX}/usr/${libdir}/tclk${tkver}:g" \
- -e "s:gentoopython:${EPREFIX}/usr/bin/python:g" \
+ sed -e "s:gentoo_sitedir:${EROOT}$(python_get_sitedir -f):g" \
+ -e "s:gentoolibdir:${EROOT}usr/${libdir}:g" \
+ -e "s:gentootk:${EROOT}usr/${libdir}/tk${tkver}:g" \
+ -e "s:gentootcl:${EROOT}usr/${libdir}/tclk${tkver}:g" \
+ -e "s:gentoopython:${EROOT}usr/bin/python:g" \
"${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
dobin "${T}"/${wrapper} || die "Failed to install ${wrapper}"
done
@@ -141,11 +142,14 @@ src_install() {
doins -r python || die "main files installation failed"
eend
- dosym ../../../..//share/doc/ccpn-data-${PV}/html ${in_path}/doc || die
+ dosym ../../../..//share/doc/ccpn-data-${MY_MAJOR}/html ${in_path}/doc || die
for i in ${pydocs}; do
- dosym /usr/share/doc/ccpn-data-${PV}/html/${i} ${in_path}/${i}
+ dosym /usr/share/doc/ccpn-data-${MY_MAJOR}/html/${i} ${in_path}/${i}
done
+ dosym /usr/share/ccpn/data ${in_path}/data
+ dosym /usr/share/ccpn/model ${in_path}/model
+
einfo "Adjusting permissions"
files="