summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-13 07:36:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-13 07:36:22 +0000
commit499fa340e172faf1b47bdbed435e97921d6e0094 (patch)
treeb66368339db15791c4828f3cff9549986f44f498 /sci-chemistry/ccpn
parentFix description (bug #325495) and correct URL for adding components (bug #325... (diff)
downloadgentoo-2-499fa340e172faf1b47bdbed435e97921d6e0094.tar.gz
gentoo-2-499fa340e172faf1b47bdbed435e97921d6e0094.tar.bz2
gentoo-2-499fa340e172faf1b47bdbed435e97921d6e0094.zip
Python patches and fix for implicit declaration (gone upstream)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ccpn')
-rw-r--r--sci-chemistry/ccpn/ChangeLog10
-rw-r--r--sci-chemistry/ccpn/ccpn-2.1.3.1_p100713.ebuild187
-rw-r--r--sci-chemistry/ccpn/files/2.1.2_1-parallel.patch21
-rw-r--r--sci-chemistry/ccpn/files/2.1.3-dynamics.patch22
-rw-r--r--sci-chemistry/ccpn/files/2.1.3-parallel.patch52
-rw-r--r--sci-chemistry/ccpn/files/2.1.3_1-impl-dec.patch72
6 files changed, 268 insertions, 96 deletions
diff --git a/sci-chemistry/ccpn/ChangeLog b/sci-chemistry/ccpn/ChangeLog
index 1d06cc69f964..7b64dc98ba9d 100644
--- a/sci-chemistry/ccpn/ChangeLog
+++ b/sci-chemistry/ccpn/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-chemistry/ccpn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.30 2010/06/28 06:27:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ChangeLog,v 1.31 2010/07/13 07:36:22 jlec Exp $
+
+*ccpn-2.1.3.1_p100713 (13 Jul 2010)
+
+ 13 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ -files/2.1.2_1-parallel.patch, +ccpn-2.1.3.1_p100713.ebuild,
+ -files/2.1.3-dynamics.patch, -files/2.1.3-parallel.patch,
+ +files/2.1.3_1-impl-dec.patch:
+ Python patches and fix for implicit declaration (gone upstream)
*ccpn-2.1.3.1_p100628 (28 Jun 2010)
diff --git a/sci-chemistry/ccpn/ccpn-2.1.3.1_p100713.ebuild b/sci-chemistry/ccpn/ccpn-2.1.3.1_p100713.ebuild
new file mode 100644
index 000000000000..39a62fb9c250
--- /dev/null
+++ b/sci-chemistry/ccpn/ccpn-2.1.3.1_p100713.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ccpn/ccpn-2.1.3.1_p100713.ebuild,v 1.1 2010/07/13 07:36:22 jlec Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_USE_WITH="ssl tk"
+
+inherit eutils portability python toolchain-funcs versionator
+
+PATCHSET="${PV##*_p}"
+MY_PN="${PN}mr"
+MY_PV="$(replace_version_separator 3 _ ${PV%%_p*})"
+
+DESCRIPTION="The Collaborative Computing Project for NMR"
+SRC_URI="http://www.bio.cam.ac.uk/ccpn/download/${MY_PN}/analysis${MY_PV}.tar.gz"
+ [[ -n ${PATCHSET} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/distfiles/ccpn-update-${PATCHSET}.patch.bz2"
+HOMEPAGE="http://www.ccpn.ac.uk/ccpn"
+
+SLOT="0"
+LICENSE="|| ( CCPN LGPL-2.1 )"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+opengl"
+
+RDEPEND="
+ dev-lang/tk
+ dev-python/numpy
+ dev-tcltk/tix
+ x11-libs/libXext
+ x11-libs/libX11
+ opengl? ( virtual/glut )"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+RESTRICT="mirror"
+S="${WORKDIR}"/${MY_PN}/${MY_PN}$(get_version_component_range 1-2 ${PV})
+
+src_prepare() {
+ [[ -n ${PATCHSET} ]] && \
+ epatch "${WORKDIR}"/ccpn-update-${PATCHSET}.patch
+
+ epatch "${FILESDIR}"/${MY_PV}-parallel.patch
+ epatch "${FILESDIR}"/${MY_PV}-dynamics.patch
+ epatch "${FILESDIR}"/${MY_PV}-impl-dec.patch
+
+ local tk_ver
+ local myconf
+
+ tk_ver="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
+
+ if use opengl; then
+ GLUT_NEED_INIT="-DNEED_GLUT_INIT"
+ IGNORE_GL_FLAG=""
+ GL_FLAG="-DUSE_GL_FALSE"
+ GL_DIR="${EPREFIX}/usr"
+ GL_LIB="-lglut -lGLU -lGL"
+ GL_INCLUDE_FLAGS="-I\$(GL_DIR)/include"
+ GL_LIB_FLAGS="-L\$(GL_DIR)/$(get_libdir)"
+
+ else
+ IGNORE_GL_FLAG="-DIGNORE_GL"
+ GL_FLAG="-DUSE_GL_FALSE"
+ fi
+
+ GLUT_NOT_IN_GL=""
+ GLUT_FLAG="\$(GLUT_NEED_INIT) \$(GLUT_NOT_IN_GL)"
+
+ python_copy_sources
+
+ preparation() {
+ sed \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ -e "s:^\(CC =\).*:\1 $(tc-getCC):g" \
+ -e "s:^\(OPT_FLAG =\).*:\1 ${CFLAGS}:g" \
+ -e "s:^\(LINK_FLAGS =.*\):\1 ${LDFLAGS}:g" \
+ -e "s:^\(IGNORE_GL_FLAG =\).*:\1 ${IGNORE_GL_FLAG}:g" \
+ -e "s:^\(GL_FLAG =\).*:\1 ${GL_FLAG}:g" \
+ -e "s:^\(GL_DIR =\).*:\1 ${GL_DIR}:g" \
+ -e "s:^\(GL_LIB =\).*:\1 ${GL_LIB}:g" \
+ -e "s:^\(GL_LIB_FLAGS =\).*:\1 ${GL_LIB_FLAGS}:g" \
+ -e "s:^\(GL_INCLUDE_FLAGS =\).*:\1 ${GL_INCLUDE_FLAGS}:g" \
+ -e "s:^\(GLUT_NEED_INIT =\).*:\1 ${GLUT_NEED_INIT}:g" \
+ -e "s:^\(GLUT_NOT_IN_GL =\).*:\1:g" \
+ -e "s:^\(X11_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
+ -e "s:^\(TCL_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
+ -e "s:^\(TK_LIB_FLAGS =\).*:\1 -L${EPREFIX}/usr/$(get_libdir):g" \
+ -e "s:^\(PYTHON_INCLUDE_FLAGS =\).*:\1 -I\$(PYTHON_DIR)/include/python$(python_get_version):g" \
+ -e "s:^\(PYTHON_LIB =\).*:\1 -lpython$(python_get_version):g" \
+ c/environment_default.txt > c/environment.txt
+ }
+ python_execute_function -s preparation
+}
+
+src_compile() {
+ building() {
+ emake -C c all links
+ }
+ python_execute_function -s building
+}
+
+src_install() {
+ local libdir
+ local tkver
+
+ libdir=$(get_libdir)
+ tkver=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
+
+ for wrapper in analysis dangle dataShifter eci formatConverter pipe2azara; do
+ sed -e "s:gentoo_sitedir:${EPREFIX}/$(python_get_sitedir -f):g" \
+ -e "s:gentoolibdir:${EPREFIX}/usr/${libdir}:g" \
+ -e "s:gentootk:${EPREFIX}/usr/${libdir}/tk${tkver}:g" \
+ -e "s:gentootcl:${EPREFIX}/usr/${libdir}/tclk${tkver}:g" \
+ -e "s:gentoopython:${EPREFIX}/usr/bin/python:g" \
+ "${FILESDIR}"/${wrapper} > "${T}"/${wrapper} || die "Fail fix ${wrapper}"
+ dobin "${T}"/${wrapper} || die "Failed to install ${wrapper}"
+ done
+
+ installation() {
+ local in_path
+ local files
+
+ in_path=$(python_get_sitedir)/${PN}
+
+ for i in python/memops/format/compatibility/{Converters,part2/Converters2}.py; do
+ sed \
+ -e 's:#from __future__:from __future__:g' \
+ -i ${i}
+ done
+
+ insinto ${in_path}
+
+ dodir ${in_path}/c
+
+ ebegin "Installing main files"
+ doins -r data model python || die "main files installation failed"
+ eend
+
+ dohtml -r doc/* || die
+ dosym ../../../../share/doc/${PF}/html ${in_path}/doc || die
+
+ einfo "Adjusting permissions"
+
+ files="ccpnmr/c/ContourFile.so
+ ccpnmr/c/ContourLevels.so
+ ccpnmr/c/ContourStyle.so
+ ccpnmr/c/PeakList.so
+ ccpnmr/c/SliceFile.so
+ ccpnmr/c/WinPeakList.so
+ ccpnmr/c/AtomCoordList.so
+ ccpnmr/c/AtomCoord.so
+ ccpnmr/c/Bacus.so
+ ccpnmr/c/CloudUtil.so
+ ccpnmr/c/DistConstraintList.so
+ ccpnmr/c/DistConstraint.so
+ ccpnmr/c/DistForce.so
+ ccpnmr/c/Dynamics.so
+ ccpnmr/c/Midge.so
+ ccp/c/StructAtom.so
+ ccp/c/StructBond.so
+ ccp/c/StructStructure.so
+ ccp/c/StructUtil.so
+ memops/c/BlockFile.so
+ memops/c/FitMethod.so
+ memops/c/GlHandler.so
+ memops/c/MemCache.so
+ memops/c/PdfHandler.so
+ memops/c/PsHandler.so
+ memops/c/ShapeFile.so
+ memops/c/StoreFile.so
+ memops/c/StoreHandler.so
+ memops/c/TkHandler.so"
+
+ for FILE in ${files}; do
+ fperms 755 ${in_path}/python/${FILE}
+ done
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}
diff --git a/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch b/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch
deleted file mode 100644
index 3b1917d581f6..000000000000
--- a/sci-chemistry/ccpn/files/2.1.2_1-parallel.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/ccpnmr2.1/c/Makefile b/ccpnmr2.1/c/Makefile
-index 2208c06..71a87c9 100644
---- a/ccpnmr2.1/c/Makefile
-+++ b/ccpnmr2.1/c/Makefile
-@@ -7,13 +7,13 @@ compile: global structure analysis clouds
- global:
- cd memops/global && $(MAKE)
-
--structure:
-+structure: global
- cd ccp/structure && $(MAKE)
-
--analysis:
-+analysis: global
- cd ccpnmr/analysis && $(MAKE)
-
--clouds:
-+clouds: global
- cd ccpnmr/clouds && $(MAKE)
-
- clean: global_clean structure_clean analysis_clean clouds_clean
diff --git a/sci-chemistry/ccpn/files/2.1.3-dynamics.patch b/sci-chemistry/ccpn/files/2.1.3-dynamics.patch
deleted file mode 100644
index 89c36d4d3e8f..000000000000
--- a/sci-chemistry/ccpn/files/2.1.3-dynamics.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs b/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
-index 8f56168..093bbe8 100755
---- a/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
-+++ b/ccpnmr2.1/python/ccpnmr/c/linkSharedObjs
-@@ -5,7 +5,6 @@ ln -s ../../../c/ccpnmr/analysis/ContourFile.so ContourFile.so
- ln -s ../../../c/ccpnmr/analysis/ContourLevels.so ContourLevels.so
- ln -s ../../../c/ccpnmr/analysis/ContourStyle.so ContourStyle.so
- ln -s ../../../c/ccpnmr/analysis/PeakCluster.so PeakCluster.so
--ln -s ../../../c/ccpnmr/analysis/PeakClusterList.so PeakClusterList.so
- ln -s ../../../c/ccpnmr/analysis/PeakList.so PeakList.so
- ln -s ../../../c/ccpnmr/analysis/SliceFile.so SliceFile.so
- ln -s ../../../c/ccpnmr/analysis/WinPeakList.so WinPeakList.so
-@@ -18,9 +17,3 @@ ln -s ../../../c/ccpnmr/clouds/DistForce.so .
- ln -s ../../../c/ccpnmr/clouds/Dynamics.so .
- ln -s ../../../c/ccpnmr/clouds/Midge.so .
- ln -s ../../../c/ccpnmr/clouds/Bacus.so .
--ln -s ../../../c/ccpnmr/dynamics/DyAtomCoord.so .
--ln -s ../../../c/ccpnmr/dynamics/DyAtomCoordList.so .
--ln -s ../../../c/ccpnmr/dynamics/DyDistConstraint.so .
--ln -s ../../../c/ccpnmr/dynamics/DyDistConstraintList.so .
--ln -s ../../../c/ccpnmr/dynamics/DyDistForce.so .
--ln -s ../../../c/ccpnmr/dynamics/DyDynamics.so .
diff --git a/sci-chemistry/ccpn/files/2.1.3-parallel.patch b/sci-chemistry/ccpn/files/2.1.3-parallel.patch
deleted file mode 100644
index 83ee505fa6fc..000000000000
--- a/sci-chemistry/ccpn/files/2.1.3-parallel.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/ccpnmr2.1/c/Makefile b/ccpnmr2.1/c/Makefile
-index 9fa8500..a99a677 100644
---- a/ccpnmr2.1/c/Makefile
-+++ b/ccpnmr2.1/c/Makefile
-@@ -2,23 +2,20 @@ include environment.txt
-
- all: compile
-
--compile: global structure analysis clouds dynamics
-+compile: global structure analysis clouds
-
- global:
- cd memops/global && $(MAKE)
-
--structure:
-+structure: global
- cd ccp/structure && $(MAKE)
-
--analysis:
-+analysis: global
- cd ccpnmr/analysis && $(MAKE)
-
--clouds:
-+clouds: global
- cd ccpnmr/clouds && $(MAKE)
-
--dynamics:
-- cd ccpnmr/dynamics && $(MAKE)
--
- clean: global_clean structure_clean analysis_clean clouds_clean dynamics_clean
-
- global_clean:
-@@ -33,9 +30,6 @@ analysis_clean:
- clouds_clean:
- cd ccpnmr/clouds && $(MAKE) clean
-
--dynamics_clean:
-- cd ccpnmr/dynamics && $(MAKE) clean
--
- realclean: global_realclean structure_realclean analysis_realclean clouds_realclean dynamics_realclean
-
- global_realclean:
-@@ -50,9 +44,6 @@ analysis_realclean:
- clouds_realclean:
- cd ccpnmr/clouds && $(MAKE) realclean
-
--dynamics_realclean:
-- cd ccpnmr/dynamics && $(MAKE) realclean
--
- links: memops_links ccp_links ccpnmr_links
-
- memops_links:
diff --git a/sci-chemistry/ccpn/files/2.1.3_1-impl-dec.patch b/sci-chemistry/ccpn/files/2.1.3_1-impl-dec.patch
new file mode 100644
index 000000000000..a89503208956
--- /dev/null
+++ b/sci-chemistry/ccpn/files/2.1.3_1-impl-dec.patch
@@ -0,0 +1,72 @@
+diff --git a/ccpnmr2.1/c/ccpnmr/analysis/py_slice_file.c b/ccpnmr2.1/c/ccpnmr/analysis/py_slice_file.c
+index 451b32a..2f37c34 100644
+--- a/ccpnmr2.1/c/ccpnmr/analysis/py_slice_file.c
++++ b/ccpnmr2.1/c/ccpnmr/analysis/py_slice_file.c
+@@ -46,6 +46,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+ ===========================REFERENCE END===============================
+ */
+ #include "py_slice_file.h"
++#include "utility.h"
+
+ #include "py_block_file.h"
+ #include "py_draw_handler.h"
+diff --git a/ccpnmr2.1/c/memops/global/gl_handler.c b/ccpnmr2.1/c/memops/global/gl_handler.c
+index 48a6a34..278134f 100644
+--- a/ccpnmr2.1/c/memops/global/gl_handler.c
++++ b/ccpnmr2.1/c/memops/global/gl_handler.c
+@@ -46,6 +46,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+ ===========================REFERENCE END===============================
+ */
+ #include "gl_handler.h"
++#include "utility.h"
+
+ #ifndef IGNORE_GL
+
+diff --git a/ccpnmr2.1/c/memops/global/py_block_file.c b/ccpnmr2.1/c/memops/global/py_block_file.c
+index 0d3f863..2f2b0f4 100644
+--- a/ccpnmr2.1/c/memops/global/py_block_file.c
++++ b/ccpnmr2.1/c/memops/global/py_block_file.c
+@@ -49,6 +49,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+
+ #include "py_mem_cache.h"
+ #include "python_util.h"
++#include "utility.h"
+
+ static PyObject *ErrorObject; /* locally-raised exception */
+
+diff --git a/ccpnmr2.1/c/memops/global/py_draw_handler.c b/ccpnmr2.1/c/memops/global/py_draw_handler.c
+index 0d354d1..1d0ec59 100644
+--- a/ccpnmr2.1/c/memops/global/py_draw_handler.c
++++ b/ccpnmr2.1/c/memops/global/py_draw_handler.c
+@@ -46,6 +46,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+ ===========================REFERENCE END===============================
+ */
+ #include "py_draw_handler.h"
++#include "utility.h"
+
+ #ifndef IGNORE_GL
+ #include "py_gl_handler.h"
+diff --git a/ccpnmr2.1/c/memops/global/py_shape_file.c b/ccpnmr2.1/c/memops/global/py_shape_file.c
+index 32673f5..0e62683 100644
+--- a/ccpnmr2.1/c/memops/global/py_shape_file.c
++++ b/ccpnmr2.1/c/memops/global/py_shape_file.c
+@@ -46,6 +46,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+ ===========================REFERENCE END===============================
+ */
+ #include "py_shape_file.h"
++#include "utility.h"
+
+ #include "py_mem_cache.h"
+ #include "python_util.h"
+diff --git a/ccpnmr2.1/c/memops/global/py_store_file.c b/ccpnmr2.1/c/memops/global/py_store_file.c
+index 6a66a8c..8fa5973 100644
+--- a/ccpnmr2.1/c/memops/global/py_store_file.c
++++ b/ccpnmr2.1/c/memops/global/py_store_file.c
+@@ -46,6 +46,7 @@ Development of a Software Pipeline. Proteins 59, 687 - 696.
+ ===========================REFERENCE END===============================
+ */
+ #include "py_store_file.h"
++#include "utility.h"
+
+ #include "python_util.h"
+