summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-24 11:39:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-24 11:39:36 +0000
commit4fe65a1c38d8727159be388f6520081d4ef6c4d0 (patch)
tree6ba9dd8e244eee1facb9b73edc4adaf8cba35da8 /sci-chemistry/burrow-owl
parentDisabling python, as some dependency are not found. (diff)
downloadgentoo-2-4fe65a1c38d8727159be388f6520081d4ef6c4d0.tar.gz
gentoo-2-4fe65a1c38d8727159be388f6520081d4ef6c4d0.tar.bz2
gentoo-2-4fe65a1c38d8727159be388f6520081d4ef6c4d0.zip
Version Bump and removal of old, #252634
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/burrow-owl')
-rw-r--r--sci-chemistry/burrow-owl/ChangeLog11
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild42
-rw-r--r--sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild43
-rw-r--r--sci-chemistry/burrow-owl/files/1.4-include.patch12
-rw-r--r--sci-chemistry/burrow-owl/files/burrow-owl-1.2-make-script-dir.patch13
5 files changed, 64 insertions, 57 deletions
diff --git a/sci-chemistry/burrow-owl/ChangeLog b/sci-chemistry/burrow-owl/ChangeLog
index d25ab1da590b..e779b06fc85f 100644
--- a/sci-chemistry/burrow-owl/ChangeLog
+++ b/sci-chemistry/burrow-owl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/burrow-owl
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.1 2007/06/06 23:32:33 dberkholz Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/ChangeLog,v 1.2 2010/06/24 11:39:36 jlec Exp $
+
+*burrow-owl-1.4 (24 Jun 2010)
+
+ 24 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/1.4-include.patch,
+ -burrow-owl-1.2.ebuild, -files/burrow-owl-1.2-make-script-dir.patch,
+ +burrow-owl-1.4.ebuild:
+ Version Bump and removal of old, #252634
*burrow-owl-1.2 (06 Jun 2007)
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild
deleted file mode 100644
index e55a929bf0e8..000000000000
--- a/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.2.ebuild,v 1.1 2007/06/06 23:32:33 dberkholz Exp $
-
-inherit eutils autotools
-
-SRC_PN="${PN/-owl}"
-SRC_P="${SRC_PN}-${PV}"
-DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
-HOMEPAGE="http://burrow-owl.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${SRC_P}.tar.gz
- examples? ( mirror://sourceforge/${PN}/${SRC_PN}-demos.tar )"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="examples"
-RDEPEND="=x11-libs/gtk+-2*
- dev-scheme/guile-gnome-platform"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-S="${WORKDIR}/${SRC_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-make-script-dir.patch
- rm -rf guile-gnome
- eautoreconf
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use examples; then
- pushd "${WORKDIR}"/burrow-demos
- docinto demonstration
- dodoc * || die "dodoc demo failed"
- cd data
- docinto demonstration/data
- dodoc * || die "dodoc data failed"
- popd
- fi
-}
diff --git a/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild b/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild
new file mode 100644
index 000000000000..2d8f4c79582e
--- /dev/null
+++ b/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/burrow-owl/burrow-owl-1.4.ebuild,v 1.1 2010/06/24 11:39:36 jlec Exp $
+
+EAPI="2"
+
+inherit base
+
+DESCRIPTION="Visualize multidimensional nuclear magnetic resonance (NMR) spectra"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="examples? ( mirror://sourceforge/${PN}/burrow-demos.tar )
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-scheme/guile-gnome-platform
+ >=dev-scheme/guile-cairo-1.4
+ >=sci-libs/starparse-1.0
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-util/indent
+ dev-util/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-include.patch
+ )
+
+src_install() {
+ base_src_install
+ if use examples; then
+ pushd "${WORKDIR}"/burrow-demos
+ docinto demonstration
+ dodoc * || die "dodoc demo failed"
+ cd data
+ docinto demonstration/data
+ dodoc * || die "dodoc data failed"
+ popd
+ fi
+}
diff --git a/sci-chemistry/burrow-owl/files/1.4-include.patch b/sci-chemistry/burrow-owl/files/1.4-include.patch
new file mode 100644
index 000000000000..3dc4cbdf8000
--- /dev/null
+++ b/sci-chemistry/burrow-owl/files/1.4-include.patch
@@ -0,0 +1,12 @@
+diff --git a/src/gw/spectrum-spec.scm b/src/gw/spectrum-spec.scm
+index 253464c..605796c 100644
+--- a/src/gw/spectrum-spec.scm
++++ b/src/gw/spectrum-spec.scm
+@@ -30,6 +30,7 @@
+ "#include <painter_gdk.h>\n"
+ "#include <burrow/nih.h>\n"
+ "#include <hosbackingsim.h>\n"
++ "#include <guile-cairo/guile-cairo-smob-types.h>\n"
+ "\n"))
+
+ ; couple of disabled sources
diff --git a/sci-chemistry/burrow-owl/files/burrow-owl-1.2-make-script-dir.patch b/sci-chemistry/burrow-owl/files/burrow-owl-1.2-make-script-dir.patch
deleted file mode 100644
index 5d76a6f22d3e..000000000000
--- a/sci-chemistry/burrow-owl/files/burrow-owl-1.2-make-script-dir.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.am.orig 2007-04-19 01:48:53.000000000 -0700
-+++ Makefile.am 2007-04-19 02:03:39.000000000 -0700
-@@ -13,8 +13,8 @@
- ## abilities
- script_DATA =
- install-data-hook:
-- chmod +w $(scriptdir)
-- $(INSTALL) $(srcdir)/scripts/* $(scriptdir)
-+ chmod +w $(DESTDIR)$(scriptdir)
-+ $(INSTALL) $(srcdir)/scripts/* $(DESTDIR)$(scriptdir)
-
- uninstall-hook:
- rm -rf $(scriptdir)/*