summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-28 13:37:10 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-28 13:37:10 +0000
commit71c06bcd5e268b61f523b446939643321c9fa120 (patch)
tree85027db98b63e1cb2b343197c6d43187804cbd9f /sci-chemistry/balbes
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #308011 (diff)
downloadgentoo-2-71c06bcd5e268b61f523b446939643321c9fa120.tar.gz
gentoo-2-71c06bcd5e268b61f523b446939643321c9fa120.tar.bz2
gentoo-2-71c06bcd5e268b61f523b446939643321c9fa120.zip
New ebuild #309105
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/balbes')
-rw-r--r--sci-chemistry/balbes/ChangeLog11
-rw-r--r--sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild63
-rw-r--r--sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch91
-rw-r--r--sci-chemistry/balbes/metadata.xml17
4 files changed, 182 insertions, 0 deletions
diff --git a/sci-chemistry/balbes/ChangeLog b/sci-chemistry/balbes/ChangeLog
new file mode 100644
index 000000000000..e55d12500d01
--- /dev/null
+++ b/sci-chemistry/balbes/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/balbes
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/ChangeLog,v 1.1 2010/03/28 13:37:10 jlec Exp $
+
+*balbes-1.0.0_p100317 (28 Mar 2010)
+
+ 28 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/1.0.0_p100317-ldflags.patch, +balbes-1.0.0_p100317.ebuild,
+ +metadata.xml:
+ New ebuild #309105
+
diff --git a/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild b/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild
new file mode 100644
index 000000000000..2af860d6906c
--- /dev/null
+++ b/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/balbes/balbes-1.0.0_p100317.ebuild,v 1.1 2010/03/28 13:37:10 jlec Exp $
+
+EAPI="3"
+
+FORTRAN="gfortran ifort"
+CCP4VER="6.1.3"
+PYTHON_DEPEND="2"
+
+inherit eutils fortran python
+
+DESCRIPTION="Automated molecular replacement (MR) pipeline"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~fei/balbes/index.html"
+SRC_URI="
+ mirror://gentoo/${P}.tar.gz
+ ftp://ftp.ccp4.ac.uk/ccp4/${CCP4VER}/ccp4-${CCP4VER}-core-src.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="ccp4"
+IUSE=""
+
+COMMON_DEPEND="sci-libs/ccp4-libs"
+RDEPEND="
+ ${COMMON_DEPEND}
+ ~sci-libs/balbes-db-${CCP4VER}
+ !<=sci-chemistry/ccp4-apps-6.1.3-r1"
+DEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}"/src
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ tar xvzf "${DISTDIR}"/ccp4-${CCP4VER}-core-src.tar.gz ccp4-${CCP4VER}/share/balbes/BALBES_0.0.1/bin_py/balbes
+ python_convert_shebangs 2 "${WORKDIR}"/ccp4-${CCP4VER}/share/balbes/BALBES_0.0.1/bin_py/balbes
+}
+
+src_prepare() {
+ mkdir "${WORKDIR}"/bin || die
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
+
+src_compile() {
+ # incomplete targets:
+ # dimer_search_db domain_search_db domain align3
+ targets="search_db get_structure_db manage_db search_dm dom2ch
+ save_si get_pdb_list_db update_db
+ update_dom_db bl2mtz check_file_db fobs2cif sol_check
+ get_trns p2s check_cell alt_sg
+ align cell_list create_bins
+ get_pdb_list_db get_ch get_nm get_mod"
+ emake \
+ BLANC_FORT="${FORTRANC} ${FFLAGS}" \
+ ${targets} || die
+}
+
+src_install() {
+ dobin \
+ "${WORKDIR}"/bin/* \
+ "${WORKDIR}"/ccp4-${CCP4VER}/share/balbes/BALBES_0.0.1/bin_py/balbes \
+ || die
+}
diff --git a/sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch b/sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch
new file mode 100644
index 000000000000..e1d09b7f3c33
--- /dev/null
+++ b/sci-chemistry/balbes/files/1.0.0_p100317-ldflags.patch
@@ -0,0 +1,91 @@
+diff --git a/makefile b/makefile
+index baaceb5..139037e 100755
+--- a/makefile
++++ b/makefile
+@@ -201,58 +201,58 @@ save_seg_id.o: save_seg_id.f
+ $(BLANC_FORT) -c save_seg_id.f
+
+ sdb_l: $(OBJDB_S)
+- $(BLANC_FORT) -o ../bin/search_DB $(OBJDB_S)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/search_DB $(OBJDB_S)
+ tdb_l: $(OBJDB_T)
+- $(BLANC_FORT) -o ../bin/get_structure_DB $(OBJDB_T)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_structure_DB $(OBJDB_T)
+ mdb_l: $(OBJDB_M)
+- $(BLANC_FORT) -o ../bin/manage_DB $(OBJDB_M)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/manage_DB $(OBJDB_M)
+ mdm_l: $(OBJDB_MD)
+- $(BLANC_FORT) -o ../bin/search_DOM $(OBJDB_MD)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/search_DOM $(OBJDB_MD)
+ d2c_l: $(OBJDB_A)
+- $(BLANC_FORT) -o ../bin/domain2chain $(OBJDB_A)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/domain2chain $(OBJDB_A)
+ upd_l: $(OBJDB_U)
+- $(BLANC_FORT) -o ../bin/update_DB $(OBJDB_U)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/update_DB $(OBJDB_U)
+ dom_l: $(OBJDB_V)
+- $(BLANC_FORT) -o ../bin/update_domain_DB $(OBJDB_V)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/update_domain_DB $(OBJDB_V)
+ ddb_l: $(OBJDB_D)
+- $(BLANC_FORT) -o ../bin/dimer_search $(OBJDB_D)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/dimer_search $(OBJDB_D)
+ dmdb_l: $(OBJDB_N)
+- $(BLANC_FORT) -o ../bin/domain_search $(OBJDB_N)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/domain_search $(OBJDB_N)
+ gdb_l: $(OBJDB_G)
+- $(BLANC_FORT) -o ../bin/get_pdb_list $(OBJDB_G)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_pdb_list $(OBJDB_G)
+ b2m_l: blanc2mtz.o libutils.o
+- $(BLANC_FORT) -o ../bin/blanc2mtz blanc2mtz.o libutils.o $(CLIB)/libccp4f.a $(CLIB)/libccp4c.a
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/blanc2mtz blanc2mtz.o libutils.o -lccp4f -lccp4c
+ f2c_l: f2cif.o libutils.o
+- $(BLANC_FORT) -o ../bin/f2cif f2cif.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/f2cif f2cif.o libutils.o
+ chf_l: check_file_DB.o libutils.o
+- $(BLANC_FORT) -o ../bin/check_file_DB check_file_DB.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/check_file_DB check_file_DB.o libutils.o
+ chc_l: check_cell_sg.o libutils.o
+- $(BLANC_FORT) -o ../bin/check_cell_sg check_cell_sg.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/check_cell_sg check_cell_sg.o libutils.o
+ asl_l: alt_sg_list.o libutils.o
+- $(BLANC_FORT) -o ../bin/alt_sg_list alt_sg_list.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/alt_sg_list alt_sg_list.o libutils.o
+ sc_l: $(OBJDB_C)
+- $(BLANC_FORT) -o ../bin/solution_check $(OBJDB_C)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/solution_check $(OBJDB_C)
+ gt_l: $(OBJDB_R)
+- $(BLANC_FORT) -o ../bin/get_trans $(OBJDB_R)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_trans $(OBJDB_R)
+ dmn_l: domain.o libutils.o
+- $(BLANC_FORT) -o ../bin/domain domain.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/domain domain.o libutils.o
+ pack: pdb_pack.o libutils.o
+- $(BLANC_FORT) -o ../bin/pdb_pack pdb_pack.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/pdb_pack pdb_pack.o libutils.o
+ p2s_l: $(OBJDB_P)
+- $(BLANC_FORT) -o ../bin/pdb2s $(OBJDB_P)
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/pdb2s $(OBJDB_P)
+ aln_l: align_DB.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/align_DB align_DB.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/align_DB align_DB.o DB_subr.o libutils.o
+ aln3_l: align_DB_new.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/align_DB_new align_DB_new.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/align_DB_new align_DB_new.o DB_subr.o libutils.o
+ cell_l: create_cell_list.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/create_cell_list create_cell_list.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/create_cell_list create_cell_list.o DB_subr.o libutils.o
+ getch_l: get_chain.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/get_chain get_chain.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_chain get_chain.o DB_subr.o libutils.o
+ getnmr_l: get_nmr.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/get_nmr get_nmr.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_nmr get_nmr.o DB_subr.o libutils.o
+ getmod_l: get_model.o libutils.o
+- $(BLANC_FORT) -o ../bin/get_model get_model.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/get_model get_model.o libutils.o
+ crb_l: create_binaries.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/create_binaries create_binaries.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/create_binaries create_binaries.o DB_subr.o libutils.o
+ save_si_l: save_seg_id.o DB_subr.o libutils.o
+- $(BLANC_FORT) -o ../bin/save_seg_id save_seg_id.o DB_subr.o libutils.o
++ $(BLANC_FORT) ${LDFLAGS} -o ../bin/save_seg_id save_seg_id.o DB_subr.o libutils.o
diff --git a/sci-chemistry/balbes/metadata.xml b/sci-chemistry/balbes/metadata.xml
new file mode 100644
index 000000000000..e1c959f9fd3a
--- /dev/null
+++ b/sci-chemistry/balbes/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+ BALBES is a system for solving protein structures using x-ray
+ crystalographic data. Molecular Replacement(MR) is its core
+ scientific method. BALBES aims to integrate all components,
+ necessary for finding a solution structure by MR, into one system.
+ It consists of a database, scientific programs and a python
+ pipeline. The system is automated so that it needs no user's
+ intervention when running complicated combination of jobs such
+ as model searching, molecular replacement and refinement.
+</longdescription>
+</pkgmetadata>