summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-13 07:10:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-13 07:10:24 +0000
commitede6d4b0622873ff68a4a339438f1d50c4b5929d (patch)
treefc1ea69baca64fccc1102eb0946790aaf744498a /sci-chemistry/azara
parent13 Dec 2010; Zac Medico <zmedico@gentoo.org> +portage-2.2.0_alpha8.ebuild: (diff)
downloadgentoo-2-ede6d4b0622873ff68a4a339438f1d50c4b5929d.tar.gz
gentoo-2-ede6d4b0622873ff68a4a339438f1d50c4b5929d.tar.bz2
gentoo-2-ede6d4b0622873ff68a4a339438f1d50c4b5929d.zip
You should not use with helpers; More fixes for 64bit
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/azara')
-rw-r--r--sci-chemistry/azara/ChangeLog8
-rw-r--r--sci-chemistry/azara/azara-2.8-r4.ebuild (renamed from sci-chemistry/azara/azara-2.8-r3.ebuild)4
-rw-r--r--sci-chemistry/azara/files/2.8-64bit.patch38
3 files changed, 43 insertions, 7 deletions
diff --git a/sci-chemistry/azara/ChangeLog b/sci-chemistry/azara/ChangeLog
index 67d19b793764..da4dba5baef1 100644
--- a/sci-chemistry/azara/ChangeLog
+++ b/sci-chemistry/azara/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/azara
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.7 2010/12/12 18:14:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/ChangeLog,v 1.8 2010/12/13 07:10:24 jlec Exp $
+
+*azara-2.8-r4 (13 Dec 2010)
+
+ 13 Dec 2010; Justin Lecher <jlec@gentoo.org> -azara-2.8-r3.ebuild,
+ +azara-2.8-r4.ebuild, files/2.8-64bit.patch:
+ You should not use with helpers; More fixes for 64bit
*azara-2.8-r3 (12 Dec 2010)
diff --git a/sci-chemistry/azara/azara-2.8-r3.ebuild b/sci-chemistry/azara/azara-2.8-r4.ebuild
index 82625a2822a8..1ef5fdbdfcdd 100644
--- a/sci-chemistry/azara/azara-2.8-r3.ebuild
+++ b/sci-chemistry/azara/azara-2.8-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.8-r3.ebuild,v 1.1 2010/12/12 18:14:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/azara/azara-2.8-r4.ebuild,v 1.1 2010/12/13 07:10:24 jlec Exp $
EAPI="3"
@@ -79,7 +79,7 @@ src_install() {
dohtml -r html/* || die
installation() {
- insinto "${EPREFIX}/$(python_get_sitedir)"
+ insinto $(python_get_sitedir)
doins lib/DataRows.so || die
}
use python && python_execute_function installation
diff --git a/sci-chemistry/azara/files/2.8-64bit.patch b/sci-chemistry/azara/files/2.8-64bit.patch
index a2f804c41498..c65e075c1d30 100644
--- a/sci-chemistry/azara/files/2.8-64bit.patch
+++ b/sci-chemistry/azara/files/2.8-64bit.patch
@@ -1,5 +1,5 @@
diff --git a/global/par.c b/global/par.c
-index ac87c88..1d171de 100644
+index ac87c88..fecfe35 100644
--- a/global/par.c
+++ b/global/par.c
@@ -562,9 +562,9 @@ static Status get_varian_header(FILE *fp, String error_msg)
@@ -32,7 +32,7 @@ index ac87c88..1d171de 100644
short status;
FILE *fp;
-@@ -605,12 +605,14 @@ static Status check_varian_header(String error_msg)
+@@ -605,17 +605,19 @@ static Status check_varian_header(String error_msg)
FCLOSE(fp);
/* numbers in parentheses are offsets into header */
@@ -43,9 +43,9 @@ index ac87c88..1d171de 100644
- tbytes = get_varian_long(16); /* number of bytes per trace */
- /*bbytes = get_varian_long(20);*/ /* number of bytes per block */
+ nblocks = get_varian_int(0); /* number of blocks in file */
-+ printf("nblocks = %ld\n", nblocks);
++ printf("nblocks = %d\n", nblocks);
+ ntraces = get_varian_int(4); /* number of traces per block */
-+ printf("ntraces = %ld\n", ntraces);
++ printf("ntraces = %d\n", ntraces);
+ np = get_varian_int(8); /* number of elements per trace */
+ ebytes = get_varian_int(12); /* number of bytes per element */
+ tbytes = get_varian_int(16); /* number of bytes per trace */
@@ -53,3 +53,33 @@ index ac87c88..1d171de 100644
/* short starting at 24 is software version */
status = get_varian_short(26); /* status of whole file */
/* long starting at 28 is number of block headers */
+
+- if (ntraces != 1L)
++ if (ntraces != 1)
+ RETURN_ERROR_MSG("can only process Varian data with #traces = 1");
+
+ if (np != npoints[0])
+@@ -646,12 +648,12 @@ static Status check_varian_header(String error_msg)
+
+ if (integer)
+ {
+- if (ebytes == 2L)
++ if (ebytes == 2)
+ {
+ if (status & (1<<2))
+ RETURN_ERROR_MSG("Varian header has inconsistent byte information");
+ }
+- else if (ebytes == 4L)
++ else if (ebytes == 4)
+ {
+ if (!(status & (1<<2)))
+ RETURN_ERROR_MSG("Varian header has inconsistent byte information");
+@@ -666,7 +668,7 @@ static Status check_varian_header(String error_msg)
+ }
+ else /* !integer, i.e. floating point */
+ {
+- if (ebytes != 4L)
++ if (ebytes != 4)
+ RETURN_ERROR_MSG("Varian header has inconsistent byte information");
+ }
+