summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-18 11:43:46 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-18 11:43:46 +0000
commit74975d8382bce4a08b01d7bdb8cba6e5143741c4 (patch)
tree0959d86911a1dff0bb70d15e67c2115838eb96e0 /sci-chemistry/autodock_vina/files
parentWith USE=test, depend on app-emacs/htmlize. Fixes bug 320361. (diff)
downloadgentoo-2-74975d8382bce4a08b01d7bdb8cba6e5143741c4.tar.gz
gentoo-2-74975d8382bce4a08b01d7bdb8cba6e5143741c4.tar.bz2
gentoo-2-74975d8382bce4a08b01d7bdb8cba6e5143741c4.zip
Initial addition of sci-chemistry/autodock_vina
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/autodock_vina/files')
-rw-r--r--sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
new file mode 100644
index 000000000000..5b24b4cbc488
--- /dev/null
+++ b/sci-chemistry/autodock_vina/files/1.1.1-gentoo.patch
@@ -0,0 +1,49 @@
+diff --git a/build/linux/debug/Makefile b/build/linux/debug/Makefile
+index d2c2d3b..d1f02e5 100644
+--- a/build/linux/debug/Makefile
++++ b/build/linux/debug/Makefile
+@@ -1,6 +1,6 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+-C_PLATFORM=-static-libgcc -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/bin/g++
+ C_OPTIONS= -g
+ BOOST_LIB_VERSION=
+diff --git a/build/linux/release/Makefile b/build/linux/release/Makefile
+index bfbcc1e..c9fd630 100644
+--- a/build/linux/release/Makefile
++++ b/build/linux/release/Makefile
+@@ -1,6 +1,6 @@
+ BASE=/usr/local
+ BOOST_VERSION=1_41
+-C_PLATFORM=-static-libgcc -pthread
++C_PLATFORM=-pthread
+ GPP=/usr/bin/g++
+ C_OPTIONS= -O3 -DNDEBUG
+ BOOST_LIB_VERSION=
+diff --git a/build/makefile_common b/build/makefile_common
+index 885935c..4d5eb0f 100644
+--- a/build/makefile_common
++++ b/build/makefile_common
+@@ -1,16 +1,16 @@
+-BOOST_INCLUDE = $(BASE)/include/boost-${BOOST_VERSION}
++BOOST_INCLUDE = $(BASE)/include/boost
+
+ LIBOBJ = cache.o coords.o current_weights.o everything.o grid.o szv_grid.o manifold.o model.o monte_carlo.o mutate.o my_pid.o naive_non_cache.o non_cache.o parallel_mc.o parse_pdbqt.o pdb.o quasi_newton.o quaternion.o random.o ssd.o terms.o weighted_terms.o
+ MAINOBJ = main.o
+ SPLITOBJ = split.o
+
+-INCFLAGS = -I $(BOOST_INCLUDE)
++INCFLAGS = -I$(BOOST_INCLUDE)
+
+ CC = ${GPP} ${C_PLATFORM} -ansi -pedantic -Wno-long-long ${C_OPTIONS} $(INCFLAGS)
+
+-LDFLAGS = -L$(BASE)/lib -L.
++LDFLAGS += -L.
+
+-LIBS = -l boost_system${BOOST_LIB_VERSION} -l boost_thread${BOOST_LIB_VERSION} -l boost_serialization${BOOST_LIB_VERSION} -l boost_filesystem${BOOST_LIB_VERSION} -l boost_program_options${BOOST_LIB_VERSION}#-l pthread
++LIBS = -lboost_system -lboost_thread -lboost_serialization -lboost_filesystem -lboost_program_options -lpthread
+
+ .SUFFIXES: .cpp .o
+