summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 01:28:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-02-07 01:28:53 +0000
commitca3601a850134230227c2740b8da7f8b8b26ff8d (patch)
tree93ff93b0606b0b7f890072ba41c36bd45be6482e /sci-chemistry/aria
parentUse PYTHON_DEPEND instead of NEED_PYTHON. Simplify code in pkg_postinst(). (diff)
downloadgentoo-2-ca3601a850134230227c2740b8da7f8b8b26ff8d.tar.gz
gentoo-2-ca3601a850134230227c2740b8da7f8b8b26ff8d.tar.bz2
gentoo-2-ca3601a850134230227c2740b8da7f8b8b26ff8d.zip
Fix dependencies. Simplify installation.
(Portage version: 15325-svn/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/aria')
-rw-r--r--sci-chemistry/aria/aria-2.2_p2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sci-chemistry/aria/aria-2.2_p2.ebuild b/sci-chemistry/aria/aria-2.2_p2.ebuild
index d3f16a96de4d..c4686e42b01f 100644
--- a/sci-chemistry/aria/aria-2.2_p2.ebuild
+++ b/sci-chemistry/aria/aria-2.2_p2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/aria/aria-2.2_p2.ebuild,v 1.1 2010/02/06 21:50:40 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/aria/aria-2.2_p2.ebuild,v 1.2 2010/02/07 01:28:53 arfrever Exp $
EAPI="3"
-
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
PYTHON_USE_WITH="tk"
@@ -28,7 +28,7 @@ RDEPEND="
>=dev-python/scientificpython-2.7.3
>=sci-chemistry/ccpn-2.0.5
>=dev-tcltk/tix-8.1.4"
-DEPEND="${RDEPENED}"
+DEPEND="${RDEPEND}"
RESTRICT_PYTHON_ABIS="3.*"
RESTRICT="fetch"
@@ -39,7 +39,6 @@ src_prepare() {
epatch "${FILESDIR}"/sa_ls_cool2.patch
epatch "${FILESDIR}"/${PV}-numpy.patch
epatch "${FILESDIR}"/${PV}-test.patch
- python_copy_sources --no-link
}
pkg_nofetch(){
@@ -53,7 +52,7 @@ src_test(){
export PYTHONPATH=.:${CCPNMR_TOP_DIR}/ccpn/python
$(PYTHON) check.py || die
}
- python_execute_function -s test
+ python_execute_function test
}
src_install(){
@@ -63,7 +62,7 @@ src_install(){
insinto "$(python_get_sitedir)/${PN}"/cns
doins -r cns/{protocols,toppar,src/helplib} || die "failed to install cns part"
}
- python_execute_function -s installation
+ python_execute_function installation
if use examples; then
insinto /usr/share/${P}/