summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:41:13 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:41:13 +0000
commit8e824014faf6f44b3ab25851aa55b01facccb0ca (patch)
treefa7c804e38d9c7664004eb19d91b8a8dc61240bf /sci-chemistry/apbs
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-8e824014faf6f44b3ab25851aa55b01facccb0ca.tar.gz
gentoo-2-8e824014faf6f44b3ab25851aa55b01facccb0ca.tar.bz2
gentoo-2-8e824014faf6f44b3ab25851aa55b01facccb0ca.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog6
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild7
-rw-r--r--sci-chemistry/apbs/apbs-1.3-r1.ebuild5
-rw-r--r--sci-chemistry/apbs/apbs-1.3.ebuild5
4 files changed, 15 insertions, 8 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index c46749d87ef7..d4a72b5752bd 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.46 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.47 2011/06/21 08:41:13 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> apbs-1.2.1b-r4.ebuild,
+ apbs-1.3.ebuild, apbs-1.3-r1.ebuild:
+ Added fortran-2.eclass support
16 Apr 2011; Justin Lecher <jlec@gentoo.org> apbs-1.3.ebuild,
apbs-1.3-r1.ebuild:
diff --git a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
index 1e8a5af64d69..52723ffd9f78 100644
--- a/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
+++ b/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.9 2010/12/16 08:55:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b-r4.ebuild,v 1.10 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
}
diff --git a/sci-chemistry/apbs/apbs-1.3-r1.ebuild b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
index 0bb9066cd862..a18c4459275e 100644
--- a/sci-chemistry/apbs/apbs-1.3-r1.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.3 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3-r1.ebuild,v 1.4 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -36,6 +36,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
if use mpi && use python; then
einfo "mpi and python support are incompatible"
diff --git a/sci-chemistry/apbs/apbs-1.3.ebuild b/sci-chemistry/apbs/apbs-1.3.ebuild
index 97ac9f5fdf3f..cb0f92b7bee9 100644
--- a/sci-chemistry/apbs/apbs-1.3.ebuild
+++ b/sci-chemistry/apbs/apbs-1.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.5 2011/04/16 07:54:07 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.3.ebuild,v 1.6 2011/06/21 08:41:13 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit autotools eutils flag-o-matic python toolchain-funcs versionator
+inherit autotools eutils fortran-2 flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-3)
MY_P="${PN}-${MY_PV}"
@@ -36,6 +36,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}"/"${MY_P}-source"
pkg_setup() {
+ fortran-2_pkg_setup
use python && python_set_active_version 2
if use mpi && use python; then
einfo "mpi and python support are incompatible"