summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-12-04 04:09:16 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-12-04 04:09:16 +0000
commit000c1285ffc81ae9b762343113898d82cce58de5 (patch)
tree53078bf7ce6bf423ab4c6ecd6671425e137e0cfe /sci-chemistry/apbs
parentVersion bump (fixes #246255). (diff)
downloadgentoo-2-000c1285ffc81ae9b762343113898d82cce58de5.tar.gz
gentoo-2-000c1285ffc81ae9b762343113898d82cce58de5.tar.bz2
gentoo-2-000c1285ffc81ae9b762343113898d82cce58de5.zip
Version bump and fixed compilation with autoconf 2.64 (fixes bug #294453 and #295537).
(Portage version: 2.1.7.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/apbs')
-rw-r--r--sci-chemistry/apbs/ChangeLog9
-rw-r--r--sci-chemistry/apbs/apbs-1.2.1b.ebuild97
-rw-r--r--sci-chemistry/apbs/files/apbs-1.2.1b-autoconf-2.64.patch23
3 files changed, 128 insertions, 1 deletions
diff --git a/sci-chemistry/apbs/ChangeLog b/sci-chemistry/apbs/ChangeLog
index 5f38dafade0a..de779bafa61a 100644
--- a/sci-chemistry/apbs/ChangeLog
+++ b/sci-chemistry/apbs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/apbs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.22 2009/11/03 05:30:06 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/ChangeLog,v 1.23 2009/12/04 04:09:15 markusle Exp $
+
+*apbs-1.2.1b (04 Dec 2009)
+
+ 04 Dec 2009; Markus Dittrich <markusle@gentoo.org> +apbs-1.2.1b.ebuild,
+ +files/apbs-1.2.1b-autoconf-2.64.patch:
+ Version bump and fixed compilation with autoconf 2.64 (fixes bug
+ #294453 and #295537).
*apbs-1.2.0 (03 Nov 2009)
diff --git a/sci-chemistry/apbs/apbs-1.2.1b.ebuild b/sci-chemistry/apbs/apbs-1.2.1b.ebuild
new file mode 100644
index 000000000000..09247ced7d14
--- /dev/null
+++ b/sci-chemistry/apbs/apbs-1.2.1b.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/apbs/apbs-1.2.1b.ebuild,v 1.1 2009/12/04 04:09:15 markusle Exp $
+
+EAPI="2"
+
+inherit eutils fortran autotools python versionator flag-o-matic
+
+MY_PV=$(get_version_component_range 1-3)
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}"/"${MY_P}-source"
+
+DESCRIPTION=" Software for evaluating the electrostatic properties of nanoscale biomolecular systems"
+LICENSE="BSD"
+HOMEPAGE="http://apbs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
+
+SLOT="0"
+IUSE="arpack blas doc mpi python openmp"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="dev-libs/maloc[mpi=]
+ blas? ( virtual/blas )
+ python? ( dev-lang/python )
+ sys-libs/readline
+ arpack? ( sci-libs/arpack )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+FORTRAN="g77 gfortran ifc"
+
+src_prepare() {
+ python_version
+
+ epatch "${FILESDIR}"/${PN}-1.2.0-install-fix.patch
+ epatch "${FILESDIR}"/${PN}-1.2.0-contrib.patch
+ epatch "${FILESDIR}"/${PN}-1.2.0-link.patch
+ epatch "${FILESDIR}"/${P}-autoconf-2.64.patch
+ sed "s:GENTOO_PKG_NAME:${PN}:g" \
+ -i Makefile.am || die "Cannot correct package name"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="--docdir=/usr/share/doc/${PF}"
+ use blas && myconf="${myconf} --with-blas=-lblas"
+ use arpack && myconf="${myconf} --with-arpack=/usr/$(get_libdir)"
+
+ # check which mpi version is installed and tell configure
+ if use mpi; then
+ export CC="/usr/bin/mpicc"
+ export F77="/usr/bin/mpif77"
+
+ if has_version sys-cluster/mpich; then
+ myconf="${myconf} --with-mpich=/usr"
+ elif has_version sys-cluster/mpich2; then
+ myconf="${myconf} --with-mpich2=/usr"
+ elif has_version sys-cluster/lam-mpi; then
+ myconf="${myconf} --with-lam=/usr"
+ elif has_version sys-cluster/openmpi; then
+ myconf="${myconf} --with-openmpi=/usr"
+ fi
+ fi || die "Failed to select proper mpi implementation"
+
+ # apbs' configure's openmp detection is broken; we'll
+ # work around this until it is fixed
+ if use openmp; then
+ append-flags -fopenmp
+ else
+ myconf="${myconf} --disable-openmp"
+ fi
+
+ econf $(use_enable python) \
+ --disable-maloc-rebuild \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 || die "make failed"
+}
+
+src_test() {
+ cd examples && make test \
+ || die "Tests failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install \
+ || die "make install failed"
+
+ dodoc AUTHORS INSTALL README NEWS ChangeLog \
+ || die "Failed to install docs"
+
+ if use doc; then
+ dohtml -r doc/* || die "Failed to install html docs"
+ fi
+}
diff --git a/sci-chemistry/apbs/files/apbs-1.2.1b-autoconf-2.64.patch b/sci-chemistry/apbs/files/apbs-1.2.1b-autoconf-2.64.patch
new file mode 100644
index 000000000000..ab7015126f9b
--- /dev/null
+++ b/sci-chemistry/apbs/files/apbs-1.2.1b-autoconf-2.64.patch
@@ -0,0 +1,23 @@
+diff -Naur apbs-1.2.1-source/acinclude.m4 apbs-1.2.1-source.new/acinclude.m4
+--- apbs-1.2.1-source/acinclude.m4 2009-12-01 09:20:23.000000000 -0500
++++ apbs-1.2.1-source.new/acinclude.m4 2009-12-03 22:56:47.000000000 -0500
+@@ -54,14 +54,11 @@
+ AC_LANG_C
+ ac_save_LIBS="$LIBS"
+ LIBS="mangle-func.o $LIBS"
+-AC_TRY_LINK(,foobar();,
+- ac_f77_mangle_type=lowercase,
+- AC_TRY_LINK(,foobar_();,
+- ac_f77_mangle_type=lowercase-underscore,
+- AC_TRY_LINK(,FOOBAR();,
+- ac_f77_mangle_type=uppercase,
+- AC_TRY_LINK(,FOOBAR_();,
+- ac_f77_mangle_type=uppercase-underscore))))
++AC_TRY_LINK(,foobar();,ac_f77_mangle_type=lowercase)
++AC_TRY_LINK(,foobar_();,ac_f77_mangle_type=lowercase-underscore)
++AC_TRY_LINK(,FOOBAR();,ac_f77_mangle_type=uppercase)
++AC_TRY_LINK(,FOOBAR_();,ac_f77_mangle_type=uppercase-underscore)
++
+ LIBS="$ac_save_LIBS"
+ AC_LANG_RESTORE
+ AC_MSG_RESULT($ac_f77_mangle_type)