summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-17 23:58:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-17 23:58:16 +0000
commitf1a0c96392edc4b53c7c4175e78dfdc36d74c52c (patch)
tree601fbaf0301713aad8b433baf4911696fe914e5b /sci-calculators
parentFix patch with absolute paths. (diff)
downloadgentoo-2-f1a0c96392edc4b53c7c4175e78dfdc36d74c52c.tar.gz
gentoo-2-f1a0c96392edc4b53c7c4175e78dfdc36d74c52c.tar.bz2
gentoo-2-f1a0c96392edc4b53c7c4175e78dfdc36d74c52c.zip
Import to the main tree from the science overlay and version bump with translation fixes
(Portage version: 2.2_rc14/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/speedcrunch/ChangeLog16
-rw-r--r--sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch11
-rw-r--r--sci-calculators/speedcrunch/metadata.xml8
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild50
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-calculators/speedcrunch/ChangeLog b/sci-calculators/speedcrunch/ChangeLog
new file mode 100644
index 000000000000..f5927c1f9be1
--- /dev/null
+++ b/sci-calculators/speedcrunch/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for sci-calculators/speedcrunch
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/ChangeLog,v 1.1 2008/11/17 23:58:15 bicatali Exp $
+
+*speedcrunch-0.10.1 (18 Nov 2008)
+
+ 18 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/speedcrunch-0.10.1-iconname.patch, +metadata.xml,
+ +speedcrunch-0.10.1.ebuild:
+ Import to the main tree from the science overlay and version bump with
+ translation fixes
+
+ 02 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/speedcrunch-0.10-fix-icon-name.patch, +speedcrunch-0.10.ebuild:
+ Initial import, see bug #78113
+
diff --git a/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch b/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch
new file mode 100644
index 000000000000..3e716e869114
--- /dev/null
+++ b/sci-calculators/speedcrunch/files/speedcrunch-0.10.1-iconname.patch
@@ -0,0 +1,11 @@
+--- src/gui/aboutbox.cpp.orig 2008-11-17 20:12:32.000000000 +0000
++++ src/gui/aboutbox.cpp 2008-11-17 20:12:50.000000000 +0000
+@@ -209,7 +209,7 @@
+ infoLabel->setOpenExternalLinks( true );
+
+ QLabel * iconLabel = new QLabel( this );
+- iconLabel->setPixmap( QPixmap( ":/crunch.png" ) );
++ iconLabel->setPixmap( QPixmap( ":/speedcrunch.png" ) );
+ iconLabel->setAlignment( Qt::AlignVCenter | Qt::AlignRight );
+
+ MarqueeText * marqueeText = new MarqueeText( this );
diff --git a/sci-calculators/speedcrunch/metadata.xml b/sci-calculators/speedcrunch/metadata.xml
new file mode 100644
index 000000000000..7d82487a2ee7
--- /dev/null
+++ b/sci-calculators/speedcrunch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ A fast and usable calculator for power users.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
new file mode 100644
index 000000000000..43ec49f57bc9
--- /dev/null
+++ b/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.10.1.ebuild,v 1.1 2008/11/17 23:58:15 bicatali Exp $
+
+EAPI=1
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A fast and usable calculator for power users"
+HOMEPAGE="http://speedcrunch.org/"
+SRC_URI="http://speedcrunch.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="|| ( >=x11-libs/qt-4.2:4 x11-libs/qt-gui:4 )"
+
+LANGS="ca cs de en es es_AR eu fi fr he id it nb nl no pl
+ pt pt_BR ro ru sv tr zh_CN"
+for lang in ${LANGS}; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+S="${WORKDIR}/${P}/src"
+
+src_unpack( ) {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-iconname.patch
+ # regenerate translations
+ lrelease speedcrunch.pro || die
+ for lang in ${LANGS}; do
+ if ! use linguas_${lang}; then
+ sed -i -e "s:i18n/${lang}\.qm::" Translations.cmake || die
+ sed -i -e "s:books/${lang}::" CMakeLists.txt || die
+ fi
+ done
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd ..
+ dodoc ChangeLog ChangeLog.floatnum HACKING.txt LISEZMOI README TRANSLATORS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf || die
+ fi
+}