summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-03 15:49:55 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-03 15:49:55 +0000
commit8469448e52358e1a33de8946ebb0b9825a6eb8db (patch)
tree68bffb6f243a038a2ac072e2d00394af9e1d9dba /sci-calculators
parentLink with libm wrt bug #246727 (diff)
downloadgentoo-2-8469448e52358e1a33de8946ebb0b9825a6eb8db.tar.gz
gentoo-2-8469448e52358e1a33de8946ebb0b9825a6eb8db.tar.bz2
gentoo-2-8469448e52358e1a33de8946ebb0b9825a6eb8db.zip
Initial import from sunrise, thanks to Christian Helbling and all contributors in bug #112985
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tiemu/ChangeLog19
-rw-r--r--sci-calculators/tiemu/files/tiemu-3.02-gcc43.patch10
-rw-r--r--sci-calculators/tiemu/metadata.xml12
-rw-r--r--sci-calculators/tiemu/tiemu-3.02.ebuild59
4 files changed, 100 insertions, 0 deletions
diff --git a/sci-calculators/tiemu/ChangeLog b/sci-calculators/tiemu/ChangeLog
new file mode 100644
index 000000000000..526a5b3768b0
--- /dev/null
+++ b/sci-calculators/tiemu/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for sci-calculators/tiemu
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/ChangeLog,v 1.1 2009/02/03 15:49:54 bicatali Exp $
+
+*tiemu-3.02 (03 Feb 2009)
+
+ 03 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/tiemu-3.02-gcc43.patch, +metadata.xml, +tiemu-3.02.ebuild:
+ Initial import from sunrise, thanks to Christian Helbling and all
+ contributors in bug #112985
+
+ 18 Jan 2008; (Tommy[D]) tommy100@gmx.de tiemu-3.02.ebuild:
+ Drop eutils.eclass
+
+ 17 Jan 2008; Christian Helbling <helch@gmx.ch> +metadata.xml,
+ +tiemu-3.02.ebuild:
+ Version bump and transfer upstream's renaming (was sci-calculators/tiemu3).
+ Bug is still #112985.
+
diff --git a/sci-calculators/tiemu/files/tiemu-3.02-gcc43.patch b/sci-calculators/tiemu/files/tiemu-3.02-gcc43.patch
new file mode 100644
index 000000000000..341fff99ad35
--- /dev/null
+++ b/sci-calculators/tiemu/files/tiemu-3.02-gcc43.patch
@@ -0,0 +1,10 @@
+--- src/ipc/dcop/dcop.cpp~ 2007-12-14 21:28:08.000000000 +0000
++++ src/ipc/dcop/dcop.cpp 2009-02-03 14:25:32.225109255 +0000
+@@ -18,6 +18,7 @@
+ */
+
+ #include <cstdlib>
++#include <cstring>
+ #include <glib.h>
+ #include <gtk/gtk.h>
+ #include <dcopobject.h>
diff --git a/sci-calculators/tiemu/metadata.xml b/sci-calculators/tiemu/metadata.xml
new file mode 100644
index 000000000000..3f72a1c51b7d
--- /dev/null
+++ b/sci-calculators/tiemu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ This project aims to develop a fast emulator for the
+ TI89(titanium), 92(+), and V200PLT calculators. This emulator
+ started on the Jonas Minnberg's (X)Tiger emulator which is
+ based on UAE (the Universal Amiga Emulator). It was deeply
+ reworked and improved thus it's very different now.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-calculators/tiemu/tiemu-3.02.ebuild b/sci-calculators/tiemu/tiemu-3.02.ebuild
new file mode 100644
index 000000000000..5069e2cea218
--- /dev/null
+++ b/sci-calculators/tiemu/tiemu-3.02.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tiemu/tiemu-3.02.ebuild,v 1.1 2009/02/03 15:49:54 bicatali Exp $
+
+EAPI=2
+inherit eutils kde-functions
+
+DESCRIPTION="Texas Instruments hand-helds emulator"
+HOMEPAGE="http://lpg.ticalc.org/prj_tiemu/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus kde nls sdl threads xinerama"
+
+RDEPEND="sci-libs/libticables2
+ sci-libs/libticalcs2
+ sci-libs/libtifiles2
+ sci-libs/libticonv
+ >=gnome-base/libglade-2.4.0
+ >=x11-libs/gtk+-2.6.0
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ kde? ( kde-base/kdelibs:3.5 )
+ nls? ( virtual/libintl )
+ sdl? ( media-libs/libsdl )
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_configure() {
+ use kde && set-kdedir 3
+ econf \
+ --disable-rpath \
+ --disable-debugger \
+ --disable-gdb \
+ $(use_enable nls) \
+ $(use_enable sdl sound) \
+ $(use_enable threads) \
+ $(use_enable threads threading) \
+ $(use_with dbus) \
+ $(use_with kde) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
+ dodoc AUTHORS NEWS README README.linux RELEASE THANKS TODO *.txt
+ make_desktop_entry tiemu "TiEmu Calculator" \
+ /usr/share/tiemu/pixmaps/icon.xpm
+}