summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 12:01:38 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 12:01:38 +0000
commit555a19d183f4c62b9b792c1ef4b1206c43e61430 (patch)
treee304f609a996198b7930bf59b4cc9cc54746907e /sci-calculators
parentStable for amd64 wrt bug #499308 (diff)
downloadgentoo-2-555a19d183f4c62b9b792c1ef4b1206c43e61430.tar.gz
gentoo-2-555a19d183f4c62b9b792c1ef4b1206c43e61430.tar.bz2
gentoo-2-555a19d183f4c62b9b792c1ef4b1206c43e61430.zip
handle langs, #500266 thanks Nikoli for the patch; use ninja
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/speedcrunch/ChangeLog8
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild49
-rw-r--r--sci-calculators/speedcrunch/speedcrunch-0.11.ebuild27
3 files changed, 56 insertions, 28 deletions
diff --git a/sci-calculators/speedcrunch/ChangeLog b/sci-calculators/speedcrunch/ChangeLog
index 2aaa3e0f8147..af96d9b95321 100644
--- a/sci-calculators/speedcrunch/ChangeLog
+++ b/sci-calculators/speedcrunch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/speedcrunch
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/ChangeLog,v 1.6 2014/02/04 00:26:07 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/ChangeLog,v 1.7 2014/02/04 12:01:38 jlec Exp $
+
+*speedcrunch-0.11-r1 (04 Feb 2014)
+
+ 04 Feb 2014; Justin Lecher <jlec@gentoo.org> +speedcrunch-0.11-r1.ebuild,
+ -speedcrunch-0.11.ebuild:
+ handle langs, #500266 thanks Nikoli for the patch; use ninja
*speedcrunch-0.11 (04 Feb 2014)
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild
new file mode 100644
index 000000000000..330f2fb76b37
--- /dev/null
+++ b/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.11-r1.ebuild,v 1.1 2014/02/04 12:01:38 jlec Exp $
+
+EAPI=5
+
+PLOCALES="ca_ES cs_CZ de_DE en_GB en_US es_AR es_ES et_EE eu_ES fi_FI
+ fr_FR he_IL hu_HU id_ID it_IT ja_JP ko_KR lv_LV nb_NO nl_NL pl_PL pt_BR
+ pt_PT ro_RO ru_RU sv_SE vi_VN zh_CN"
+
+CMAKE_MAKEFILE_GENERATOR=ninja
+
+inherit cmake-utils l10n
+
+DESCRIPTION="Fast and usable calculator for power users"
+HOMEPAGE="http://speedcrunch.org/"
+SRC_URI="https://github.com/${PN}/SpeedCrunch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/SpeedCrunch-${PV}/src"
+
+src_prepare() {
+ my_rm_loc() {
+ rm "resources/locale/${1}.qm" || die
+ sed -i resources/speedcrunch.qrc \
+ -e "s|<file>locale/${1}.qm</file>||" || die
+ sed -i gui/mainwindow.cpp \
+ -e "s|map.insert(QString::fromUtf8(\".*, QLatin1String(\"${1}\"));||" || die
+ }
+
+ l10n_find_plocales_changes 'resources/locale' '' '.qm'
+ l10n_for_each_disabled_locale_do my_rm_loc
+
+ cmake-utils_src_prepare
+}
+
+src_install() {
+ cmake-utils_src_install
+ cd .. || die
+ doicon -s scalable gfx/speedcrunch.svg
+ use doc && dodoc doc/*.pdf
+}
diff --git a/sci-calculators/speedcrunch/speedcrunch-0.11.ebuild b/sci-calculators/speedcrunch/speedcrunch-0.11.ebuild
deleted file mode 100644
index 5bb3144771f1..000000000000
--- a/sci-calculators/speedcrunch/speedcrunch-0.11.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/speedcrunch/speedcrunch-0.11.ebuild,v 1.1 2014/02/04 00:26:07 bicatali Exp $
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="Fast and usable calculator for power users"
-HOMEPAGE="http://speedcrunch.org/"
-SRC_URI="https://github.com/${PN}/SpeedCrunch/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="dev-qt/qtgui:4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/SpeedCrunch-${PV}/src"
-
-src_install() {
- cmake-utils_src_install
- cd ..
- use doc && dodoc doc/*.pdf
-}