summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-03 15:52:59 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-03 15:52:59 +0000
commit52f4ca5a0f82fe5eb1fff6454167610cff719ef5 (patch)
treea3ee4b6396b6696ff102d4c399f84436bb4f03fd /sci-calculators
parentInitial import from sunrise, thanks to Christian Helbling and all contributor... (diff)
downloadgentoo-2-52f4ca5a0f82fe5eb1fff6454167610cff719ef5.tar.gz
gentoo-2-52f4ca5a0f82fe5eb1fff6454167610cff719ef5.tar.bz2
gentoo-2-52f4ca5a0f82fe5eb1fff6454167610cff719ef5.zip
Initial import from sunrise, thanks to Christian Helbling and all contributors in bug #146028
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tilp2/ChangeLog33
-rw-r--r--sci-calculators/tilp2/metadata.xml11
-rw-r--r--sci-calculators/tilp2/tilp2-1.11.ebuild50
3 files changed, 94 insertions, 0 deletions
diff --git a/sci-calculators/tilp2/ChangeLog b/sci-calculators/tilp2/ChangeLog
new file mode 100644
index 000000000000..f86e9a8d11ff
--- /dev/null
+++ b/sci-calculators/tilp2/ChangeLog
@@ -0,0 +1,33 @@
+# ChangeLog for sci-calculators/tilp2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/ChangeLog,v 1.1 2009/02/03 15:52:59 bicatali Exp $
+
+*tilp2-1.11 (03 Feb 2009)
+
+ 03 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +tilp2-1.11.ebuild:
+ Initial import from sunrise, thanks to Christian Helbling and all
+ contributors in bug #146028
+
+ 03 May 2008; Christian Helbling <helch@gmx.ch> -tilp2-1.10.ebuild,
+ +tilp2-1.11.ebuild:
+ version bump
+
+ 18 Jan 2008; Christian Helbling <helch@gmx.ch> tilp2-1.10.ebuild:
+ changing SRC_URI back to sf mirrors
+
+ 17 Jan 2008; Christian Helbling <helch@gmx.ch> -tilp2-1.07.ebuild,
+ +tilp2-1.10.ebuild:
+ Version bump
+
+ 22 Sep 2007; Christian Helbling <helch@gmx.ch> -tilp2-1.03.ebuild,
+ +tilp2-1.07.ebuild:
+ version bump
+
+ 15 Jun 2007; Ali Polatel (hawking) <polatel@gmail.com> tilp2-1.03.ebuild:
+ removed trailing blank line
+
+ 15 Jun 2007; Christian Helbling <helch@gmx.ch> +tilp2-1.03.ebuild,
+ +metadata.xml:
+ New ebuild for bug 109220 thanks to Henning Schild
+
diff --git a/sci-calculators/tilp2/metadata.xml b/sci-calculators/tilp2/metadata.xml
new file mode 100644
index 000000000000..16c5f62032f5
--- /dev/null
+++ b/sci-calculators/tilp2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ TiLP is a linking program for Texas Instruments' graphing
+ calculators. It can handle any TI calculator (from TI73 to V200) with
+ any link cable. TiLP has all the functions of a linking program and
+ more.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-calculators/tilp2/tilp2-1.11.ebuild b/sci-calculators/tilp2/tilp2-1.11.ebuild
new file mode 100644
index 000000000000..cb9cc8ad84ec
--- /dev/null
+++ b/sci-calculators/tilp2/tilp2-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/tilp2-1.11.ebuild,v 1.1 2009/02/03 15:52:59 bicatali Exp $
+
+EAPI="2"
+inherit eutils kde-functions
+
+DESCRIPTION="Communication program for Texas Instruments calculators "
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
+SRC_URI="mirror://sourceforge/tilp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde nls threads xinerama"
+
+RDEPEND="sci-libs/libticalcs2
+ sci-libs/libticables2
+ sci-libs/libtifiles2
+ sci-libs/libticonv
+ !sci-calculators/tilp
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/glib-2.6.0
+ >=gnome-base/libglade-2
+ kde? ( kde-base/kdelibs:3.5 )
+ nls? ( virtual/libintl )
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ use kde && set-kdedir 3
+ econf \
+ --disable-rpath \
+ $(use_enable threads) \
+ $(use_enable threads threading) \
+ $(use_with kde) \
+ $(use_with xinerama)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ rm -f "${D}"usr/share/tiemu/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES}
+ dodoc README AUTHORS ChangeLog RELEASE TODO *.txt
+ make_desktop_entry tilp "TILP2 TI Linker" \
+ /usr/share/tilp2/pixmaps/icon.xpm
+}