summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-07-02 03:58:36 +0000
committerJeroen Roovers <jer@gentoo.org>2012-07-02 03:58:36 +0000
commit080f1633e482e696804903389e8fd06a3a394df8 (patch)
tree6697fbd08b60306fa4a9b7f46a79179b099a7fc9 /sci-calculators
parentVersion bump, bug #407161. Remove old. (diff)
downloadgentoo-2-080f1633e482e696804903389e8fd06a3a394df8.tar.gz
gentoo-2-080f1633e482e696804903389e8fd06a3a394df8.tar.bz2
gentoo-2-080f1633e482e696804903389e8fd06a3a394df8.zip
Version bump.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/ChangeLog8
-rw-r--r--sci-calculators/units/files/units-2.00-gentoo.patch17
-rw-r--r--sci-calculators/units/units-2.00.ebuild30
3 files changed, 54 insertions, 1 deletions
diff --git a/sci-calculators/units/ChangeLog b/sci-calculators/units/ChangeLog
index 3c1d6f69f19a..55d0239df640 100644
--- a/sci-calculators/units/ChangeLog
+++ b/sci-calculators/units/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/units
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.32 2012/03/26 11:55:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.33 2012/07/02 03:58:36 jer Exp $
+
+*units-2.00 (02 Jul 2012)
+
+ 02 Jul 2012; Jeroen Roovers <jer@gentoo.org> +units-2.00.ebuild,
+ +files/units-2.00-gentoo.patch:
+ Version bump.
*units-1.88-r1 (26 Mar 2012)
diff --git a/sci-calculators/units/files/units-2.00-gentoo.patch b/sci-calculators/units/files/units-2.00-gentoo.patch
new file mode 100644
index 000000000000..5c30db93ffb0
--- /dev/null
+++ b/sci-calculators/units/files/units-2.00-gentoo.patch
@@ -0,0 +1,17 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -84,10 +84,10 @@
+ sed -e "s:outfile = 'currency.units':outfile='@UDAT@currency.units':" units_cur > units_cur_inst
+
+ install-support: definitions.units currency.units units_cur_inst
+- $(srcdir)/mkinstalldirs @UDAT@ $(DESTDIR)$(bindir)
+- $(INSTALL_DATA) $(srcdir)/definitions.units @UDAT@definitions.units
+- $(INSTALL_DATA) $(srcdir)/currency.units @UDAT@currency.units
+- $(INSTALL_DATA) $(srcdir)/locale.map @UDAT@locale.map
++ $(srcdir)/mkinstalldirs $(DESTDIR)@UDAT@ $(DESTDIR)$(bindir)
++ $(INSTALL_DATA) $(srcdir)/definitions.units $(DESTDIR)@UDAT@definitions.units
++ $(INSTALL_DATA) $(srcdir)/currency.units $(DESTDIR)@UDAT@currency.units
++ $(INSTALL_DATA) $(srcdir)/locale.map $(DESTDIR)@UDAT@locale.map
+ $(INSTALL_PROGRAM) units_cur_inst $(DESTDIR)$(bindir)/`echo units_cur|sed '$(transform)'`
+
+ install: units@EXEEXT@ install-doc install-support
diff --git a/sci-calculators/units/units-2.00.ebuild b/sci-calculators/units/units-2.00.ebuild
new file mode 100644
index 000000000000..416a246348fb
--- /dev/null
+++ b/sci-calculators/units/units-2.00.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.00.ebuild,v 1.1 2012/07/02 03:58:36 jer Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="unit conversion program"
+HOMEPAGE="http://www.gnu.org/software/units/units.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ >=sys-libs/readline-4.1-r2
+ >=sys-libs/ncurses-5.2-r3
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README
+}