summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-07-09 17:09:57 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-07-09 17:09:57 +0000
commita5409b91f7ed135d8b770d676a310fa2c1f83fba (patch)
treef9599607fc7cee51d07b795773605f690f0a1a64 /sci-calculators/tilp2
parentRemove old. (diff)
downloadgentoo-2-a5409b91f7ed135d8b770d676a310fa2c1f83fba.tar.gz
gentoo-2-a5409b91f7ed135d8b770d676a310fa2c1f83fba.tar.bz2
gentoo-2-a5409b91f7ed135d8b770d676a310fa2c1f83fba.zip
Version bump
(Portage version: 2.2.01.22120-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-calculators/tilp2')
-rw-r--r--sci-calculators/tilp2/ChangeLog9
-rw-r--r--sci-calculators/tilp2/tilp2-1.17.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/sci-calculators/tilp2/ChangeLog b/sci-calculators/tilp2/ChangeLog
index 9781d2592de7..54c639a47712 100644
--- a/sci-calculators/tilp2/ChangeLog
+++ b/sci-calculators/tilp2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-calculators/tilp2
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/ChangeLog,v 1.10 2012/11/29 12:01:14 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/ChangeLog,v 1.11 2013/07/09 17:09:57 bicatali Exp $
+
+*tilp2-1.17 (09 Jul 2013)
+
+ 09 Jul 2013; Sébastien Fabbro <bicatali@gentoo.org> +tilp2-1.17.ebuild:
+ Version bump
*tilp2-1.16-r1 (29 Nov 2012)
diff --git a/sci-calculators/tilp2/tilp2-1.17.ebuild b/sci-calculators/tilp2/tilp2-1.17.ebuild
new file mode 100644
index 000000000000..db056182ee9b
--- /dev/null
+++ b/sci-calculators/tilp2/tilp2-1.17.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/tilp2/tilp2-1.17.ebuild,v 1.1 2013/07/09 17:09:57 bicatali Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Communication program for Texas Instruments calculators "
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls threads xinerama"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ >=sci-libs/libticalcs2-1.1.8
+ >=sci-libs/libticables2-1.3
+ >=sci-libs/libtifiles2-1.1.6
+ >=sci-libs/libticonv-1.1.4
+ nls? ( virtual/libintl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ # kde seems to be kde3 only
+ local myeconfargs=(
+ --disable-rpath
+ --without-kde
+ $(use_enable nls)
+ $(use_enable threads threading)
+ $(use_with xinerama)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ rm "${ED}"usr/share/${PN}/{Manpage.txt,COPYING,RELEASE,AUTHORS,LICENSES} || die
+}