summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-01-08 15:35:23 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-01-08 15:35:23 +0000
commit836ef207cc40312e82da91f7111c147b510adf01 (patch)
tree793feec675acea1e862c1c7a41af1117aec2593d /sci-calculators/orpie
parentAdd inherit pam. (diff)
downloadgentoo-2-836ef207cc40312e82da91f7111c147b510adf01.tar.gz
gentoo-2-836ef207cc40312e82da91f7111c147b510adf01.tar.bz2
gentoo-2-836ef207cc40312e82da91f7111c147b510adf01.zip
Added patch to allow orpie to be compiled against ocaml-3.09.*. Thanks much to David Brown <gentoo@davidb.org> for the patch. This closes bug #160825.
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'sci-calculators/orpie')
-rw-r--r--sci-calculators/orpie/ChangeLog8
-rw-r--r--sci-calculators/orpie/files/orpie-ocaml-gentoo.patch13
-rw-r--r--sci-calculators/orpie/orpie-1.4.3-r1.ebuild12
3 files changed, 24 insertions, 9 deletions
diff --git a/sci-calculators/orpie/ChangeLog b/sci-calculators/orpie/ChangeLog
index 3199f0b62eee..a346eac43f99 100644
--- a/sci-calculators/orpie/ChangeLog
+++ b/sci-calculators/orpie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/orpie
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/ChangeLog,v 1.6 2007/01/06 22:11:00 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/ChangeLog,v 1.7 2007/01/08 15:35:23 markusle Exp $
+
+ 08 Jan 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/orpie-ocaml-gentoo.patch, orpie-1.4.3-r1.ebuild:
+ Added patch to allow orpie to be compiled against ocaml-3.09.*.
+ Thanks much to David Brown <gentoo@davidb.org> for the patch.
+ This closes bug #160825.
06 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -orpie-1.4.1.ebuild,
-orpie-1.4.3.ebuild:
diff --git a/sci-calculators/orpie/files/orpie-ocaml-gentoo.patch b/sci-calculators/orpie/files/orpie-ocaml-gentoo.patch
new file mode 100644
index 000000000000..856a46c15f06
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-ocaml-gentoo.patch
@@ -0,0 +1,13 @@
+diff -Naur orpie-1.4.3/gsl/mlgsl_error.c orpie-1.4.3-new/gsl/mlgsl_error.c
+--- orpie-1.4.3/gsl/mlgsl_error.c 2005-10-29 22:40:23.000000000 -0400
++++ orpie-1.4.3-new/gsl/mlgsl_error.c 2007-01-08 09:14:35.000000000 -0500
+@@ -43,7 +43,8 @@
+ exn_arg = alloc_small(2, 0);
+ Store_field(exn_arg, 0, Val_int(conv_err_code(gsl_errno)));
+ Store_field(exn_arg, 1, copy_string(ml_gsl_exn_msg));
+- CAMLreturn(raise_with_arg(*ml_gsl_exn, exn_arg));
++ raise_with_arg(*ml_gsl_exn, exn_arg);
++ CAMLreturn0;
+ }
+
+ static void ml_gsl_error_handler(const char *reason, const char *file,
diff --git a/sci-calculators/orpie/orpie-1.4.3-r1.ebuild b/sci-calculators/orpie/orpie-1.4.3-r1.ebuild
index 86dd8a161c33..e76406d8ce74 100644
--- a/sci-calculators/orpie/orpie-1.4.3-r1.ebuild
+++ b/sci-calculators/orpie/orpie-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/orpie-1.4.3-r1.ebuild,v 1.1 2006/11/02 00:10:38 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/orpie/orpie-1.4.3-r1.ebuild,v 1.2 2007/01/08 15:35:23 markusle Exp $
inherit flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="~dev-lang/ocaml-3.08.4
+DEPEND="dev-lang/ocaml
sci-libs/gsl
sys-libs/ncurses"
@@ -21,11 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-quote-down-crash.patch
-}
-
-src_compile() {
- econf || die
- emake || die
+ epatch "${FILESDIR}"/${PN}-ocaml-gentoo.patch
}
src_install() {