summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-02 12:38:52 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-02 12:38:52 +0000
commitf9183edb02039d735834a9ec849ccdc949df0fb9 (patch)
treeffe8f25e499d4ec4d59846dfab18b8446e4ec1b6 /sci-biology
parentVersion bump. (diff)
downloadgentoo-2-f9183edb02039d735834a9ec849ccdc949df0fb9.tar.gz
gentoo-2-f9183edb02039d735834a9ec849ccdc949df0fb9.tar.bz2
gentoo-2-f9183edb02039d735834a9ec849ccdc949df0fb9.zip
sci-biology/rebase: Version BUmp
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/rebase/ChangeLog7
-rw-r--r--sci-biology/rebase/rebase-1311.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index bd25b1ca92ad..5ade90a17b01 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.116 2013/10/08 14:15:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.117 2013/11/02 12:38:52 jlec Exp $
+
+*rebase-1311 (02 Nov 2013)
+
+ 02 Nov 2013; Justin Lecher <jlec@gentoo.org> +rebase-1311.ebuild:
+ Version BUmp
*rebase-1310 (08 Oct 2013)
diff --git a/sci-biology/rebase/rebase-1311.ebuild b/sci-biology/rebase/rebase-1311.ebuild
new file mode 100644
index 000000000000..e1c12534878c
--- /dev/null
+++ b/sci-biology/rebase/rebase-1311.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1311.ebuild,v 1.1 2013/11/02 12:38:52 jlec Exp $
+
+EAPI=5
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="emboss minimal"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup}
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ
+ fi
+}