summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-26 13:01:46 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-26 13:01:46 +0000
commite8f6e845d3521ff66e7c110c6c1c5363b2f35972 (patch)
treed16ce330e5a864c78a0cbad331d978d2d811e85b /sci-biology
parentVersio bump, bug 423995. Thanks to Manuel Rüger (mrueg) <gentoo@rueg.eu>. (diff)
downloadgentoo-2-e8f6e845d3521ff66e7c110c6c1c5363b2f35972.tar.gz
gentoo-2-e8f6e845d3521ff66e7c110c6c1c5363b2f35972.tar.bz2
gentoo-2-e8f6e845d3521ff66e7c110c6c1c5363b2f35972.zip
sci-biology/recon: Respect CFLAGS and CC, #432660
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/recon/ChangeLog10
-rw-r--r--sci-biology/recon/files/recon-1.06-respect.patch24
-rw-r--r--sci-biology/recon/recon-1.06-r2.ebuild39
3 files changed, 71 insertions, 2 deletions
diff --git a/sci-biology/recon/ChangeLog b/sci-biology/recon/ChangeLog
index 618f3a099331..2117774912a5 100644
--- a/sci-biology/recon/ChangeLog
+++ b/sci-biology/recon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/recon
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/recon/ChangeLog,v 1.2 2011/03/10 11:12:46 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/recon/ChangeLog,v 1.3 2012/08/26 13:01:44 jlec Exp $
+
+*recon-1.06-r2 (26 Aug 2012)
+
+ 26 Aug 2012; Justin Lecher <jlec@gentoo.org> +recon-1.06-r2.ebuild,
+ +files/recon-1.06-respect.patch:
+ Respect CFLAGS and CC, #432660
*recon-1.06-r1 (10 Mar 2011)
diff --git a/sci-biology/recon/files/recon-1.06-respect.patch b/sci-biology/recon/files/recon-1.06-respect.patch
new file mode 100644
index 000000000000..a02038d84784
--- /dev/null
+++ b/sci-biology/recon/files/recon-1.06-respect.patch
@@ -0,0 +1,24 @@
+ src/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 36ef59b..e45a0f2 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -13,14 +13,14 @@ MANDIR = $(HOME)/man
+ #SRCDIR = .
+
+ ## your compiler
+-CC = gcc
++CC ?= gcc
+ #CC = cc # for SGI Origin200 compiler#
+
+ ## any special compiler flags you want
+ # -pedantic clashes with -DMEMDEBUG??
+ #
+ #CFLAGS = -g -Wall -pedantic
+-CFLAGS = -O
++CFLAGS ?= -O
+ #CFLAGS = -g
+ #CFLAGS = -TARG:exc_max -64 -Ofast=ip27 #specific SGI Origin200 compiler#
+
diff --git a/sci-biology/recon/recon-1.06-r2.ebuild b/sci-biology/recon/recon-1.06-r2.ebuild
new file mode 100644
index 000000000000..797d294eac73
--- /dev/null
+++ b/sci-biology/recon/recon-1.06-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/recon/recon-1.06-r2.ebuild,v 1.1 2012/08/26 13:01:44 jlec Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automated de novo identification of repeat families from genomic sequences"
+HOMEPAGE="http://selab.janelia.org/recon.html http://www.repeatmasker.org/RepeatModeler.html"
+SRC_URI="http://www.repeatmasker.org/RECON${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/RECON${PV}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-buffer-overflow.patch \
+ "${FILESDIR}"/${P}-respect.patch
+ sed -i 's|$path = "";|$path = "/usr/libexec/'${PN}'";|' scripts/recon.pl || die
+ tc-export CC
+}
+
+src_compile() {
+ emake -C src
+}
+
+src_install() {
+ dobin scripts/*
+ exeinto /usr/libexec/${PN}
+ doexe src/{edgeredef,eledef,eleredef,famdef,imagespread}
+ dodoc 00README
+ insinto /usr/share/${PN}
+ use examples && doins -r Demos
+}