summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-23 10:15:20 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-23 10:15:20 +0000
commitd238167be1f5faf101ee96053034c2f25d6f59a7 (patch)
treed35771253bf69f878059367c43b4294a33131253 /sci-biology
parentVersion bump to stop using deprecated gtkhtml:2, remove old. (diff)
downloadgentoo-2-d238167be1f5faf101ee96053034c2f25d6f59a7.tar.gz
gentoo-2-d238167be1f5faf101ee96053034c2f25d6f59a7.tar.bz2
gentoo-2-d238167be1f5faf101ee96053034c2f25d6f59a7.zip
sci-biology/maq: Add patch for gcc-4.7, #422869
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/maq/ChangeLog8
-rw-r--r--sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch34
-rw-r--r--sci-biology/maq/maq-0.7.1-r1.ebuild7
3 files changed, 44 insertions, 5 deletions
diff --git a/sci-biology/maq/ChangeLog b/sci-biology/maq/ChangeLog
index f7fb93d863a4..dcf780d990e8 100644
--- a/sci-biology/maq/ChangeLog
+++ b/sci-biology/maq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/maq
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/maq/ChangeLog,v 1.9 2011/12/18 19:53:20 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/maq/ChangeLog,v 1.10 2012/06/23 10:15:20 jlec Exp $
+
+ 23 Jun 2012; Justin Lecher <jlec@gentoo.org> maq-0.7.1-r1.ebuild,
+ +files/maq-0.7.1-gcc-4.7.patch:
+ Add patch for gcc-4.7, #422869
18 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> maq-0.7.1-r1.ebuild:
x86 stable wrt bug #393759
diff --git a/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
new file mode 100644
index 000000000000..4b97da89be48
--- /dev/null
+++ b/sci-biology/maq/files/maq-0.7.1-gcc-4.7.patch
@@ -0,0 +1,34 @@
+ stdhash.hh | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/stdhash.hh b/stdhash.hh
+index eaf98af..16cd1a3 100644
+--- a/stdhash.hh
++++ b/stdhash.hh
+@@ -412,7 +412,7 @@ public:
+ inline bool insert(const keytype_t &key) {
+ __lh3_hash_base_class<keytype_t>::rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+ else ++(this->n_size); // then ret == 2
+@@ -493,7 +493,7 @@ public:
+ inline bool insert(const keytype_t &key, const valtype_t &val) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ vals[i] = val;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
+@@ -503,7 +503,7 @@ public:
+ inline bool insert(const keytype_t &key, valtype_t **q) {
+ rehash();
+ hashint_t i;
+- int ret = direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
++ int ret = this->direct_insert_aux(key, this->n_capacity, this->keys, this->flags, &i);
+ *q = vals + i;
+ if (ret == 0) return true;
+ if (ret == 1) { ++(this->n_size); ++(this->n_occupied); }
diff --git a/sci-biology/maq/maq-0.7.1-r1.ebuild b/sci-biology/maq/maq-0.7.1-r1.ebuild
index 0b08ceb49e79..8d07e25f492a 100644
--- a/sci-biology/maq/maq-0.7.1-r1.ebuild
+++ b/sci-biology/maq/maq-0.7.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/maq/maq-0.7.1-r1.ebuild,v 1.5 2011/12/18 19:53:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/maq/maq-0.7.1-r1.ebuild,v 1.6 2012/06/23 10:15:20 jlec Exp $
EAPI=4
@@ -23,7 +23,8 @@ DEPEND="${RDEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-flags.patch \
- "${FILESDIR}"/${P}-bfr-overfl.patch
+ "${FILESDIR}"/${P}-bfr-overfl.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
sed \
-e '/ext_CFLAGS/s:-m64::g' \
-i configure* || die