summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:40:50 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2011-12-26 05:40:50 +0000
commitcd1e1451ef3ca2d6b95889a6d4c8e1ab8f50e6ab (patch)
tree07277cc69cdfab1f4d505419567e9e6bd6de3055 /sci-biology
parentVersion bump (diff)
downloadgentoo-2-cd1e1451ef3ca2d6b95889a6d4c8e1ab8f50e6ab.tar.gz
gentoo-2-cd1e1451ef3ca2d6b95889a6d4c8e1ab8f50e6ab.tar.bz2
gentoo-2-cd1e1451ef3ca2d6b95889a6d4c8e1ab8f50e6ab.zip
Version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/gatk/ChangeLog7
-rw-r--r--sci-biology/gatk/gatk-1.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sci-biology/gatk/ChangeLog b/sci-biology/gatk/ChangeLog
index 2672b2663a32..9e2c8d21f8e6 100644
--- a/sci-biology/gatk/ChangeLog
+++ b/sci-biology/gatk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/gatk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/ChangeLog,v 1.1 2011/10/31 21:18:17 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/ChangeLog,v 1.2 2011/12/26 05:40:50 weaver Exp $
+
+*gatk-1.3 (26 Dec 2011)
+
+ 26 Dec 2011; Andrey Kislyuk <weaver@gentoo.org> +gatk-1.3.ebuild:
+ Version bump
*gatk-9999 (31 Oct 2011)
*gatk-1.2 (31 Oct 2011)
diff --git a/sci-biology/gatk/gatk-1.3.ebuild b/sci-biology/gatk/gatk-1.3.ebuild
new file mode 100644
index 000000000000..43ae46e02d20
--- /dev/null
+++ b/sci-biology/gatk/gatk-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/gatk/gatk-1.3.ebuild,v 1.1 2011/12/26 05:40:50 weaver Exp $
+
+EAPI=4
+
+MY_HASH=9dec377
+
+EGIT_REPO_URI="https://github.com/broadgsa/gatk.git"
+
+EANT_BUILD_TARGET="dist"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+#inherit java-pkg-2 java-ant-2 git
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Genome Analysis Toolkit"
+HOMEPAGE="http://www.broadinstitute.org/gsa/wiki/index.php/The_Genome_Analysis_Toolkit"
+SRC_URI="https://github.com/broadgsa/gatk/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+COMMON_DEPS=""
+DEPEND=">=virtual/jdk-1.6
+ ${COMMON_DEPS}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPS}"
+
+S="${WORKDIR}/broadgsa-gatk-${MY_HASH}"
+
+src_prepare() {
+ sed -i '/property name="ivy.home"/ s|${user.home}|'${WORKDIR}'|' build.xml || die
+ java-pkg-2_src_prepare
+}
+
+src_install() {
+ java-pkg_dojar dist/*.jar
+ java-pkg_dolauncher GenomeAnalysisTK --jar GenomeAnalysisTK.jar
+ java-pkg_dolauncher AnalyzeCovariates --jar AnalyzeCovariates.jar
+}