summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-26 16:03:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-26 16:03:01 +0000
commitb9d2f675943e4aa5b732f7ca5fb4f7d81a9aa4de (patch)
tree8fb7010eceb66f9f88f25380fe358199a7d5c5f8 /sci-biology
parentalpha/ia64/s390/sh/sparc stable wrt #419473 (diff)
downloadgentoo-2-b9d2f675943e4aa5b732f7ca5fb4f7d81a9aa4de.tar.gz
gentoo-2-b9d2f675943e4aa5b732f7ca5fb4f7d81a9aa4de.tar.bz2
gentoo-2-b9d2f675943e4aa5b732f7ca5fb4f7d81a9aa4de.zip
sci-biology/meme: Version Bump; respect CFLAGS, #430774
(Portage version: 2.2.0_alpha122/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/meme/ChangeLog10
-rw-r--r--sci-biology/meme/files/meme-4.8.1-Makefile.am.patch134
-rw-r--r--sci-biology/meme/meme-4.8.1.ebuild79
3 files changed, 221 insertions, 2 deletions
diff --git a/sci-biology/meme/ChangeLog b/sci-biology/meme/ChangeLog
index 32848806c600..1c602f60a71d 100644
--- a/sci-biology/meme/ChangeLog
+++ b/sci-biology/meme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/meme
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.17 2011/03/02 17:41:09 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/ChangeLog,v 1.18 2012/08/26 16:03:01 jlec Exp $
+
+*meme-4.8.1 (26 Aug 2012)
+
+ 26 Aug 2012; Justin Lecher <jlec@gentoo.org> +meme-4.8.1.ebuild,
+ +files/meme-4.8.1-Makefile.am.patch:
+ Version Bump; respect CFLAGS, #430774
02 Mar 2011; Justin Lecher <jlec@gentoo.org> meme-4.3.0.ebuild,
meme-4.3.0-r1.ebuild, meme-4.4.0.ebuild:
diff --git a/sci-biology/meme/files/meme-4.8.1-Makefile.am.patch b/sci-biology/meme/files/meme-4.8.1-Makefile.am.patch
new file mode 100644
index 000000000000..e84006295735
--- /dev/null
+++ b/sci-biology/meme/files/meme-4.8.1-Makefile.am.patch
@@ -0,0 +1,134 @@
+ Makefile.am | 6 +++---
+ doc/Makefile.am | 2 +-
+ doc/examples/Makefile.am | 24 +++++++++++-----------
+ .../Makefile.am | 2 +-
+ doc/examples/sample_opal_scripts/Makefile.am | 2 +-
+ doc/images/Makefile.am | 2 +-
+ scripts/Makefile.am | 2 +-
+ 7 files changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 4a69e34..842e33f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,11 +18,11 @@ ARCHIVE_REVISION:
+ install-data-hook: dbdir
+
+ dbdir:
+- mkdir -p $(MEME_DB)
++ mkdir -p $(DESTDIR)$(MEME_DB)
+
+ install-data-local:
+- mkdir -p $(MEME_LOGS)
+- chmod a+w $(MEME_LOGS)
++ mkdir -p $(DESTDIR)$(MEME_LOGS)
++ chmod a+w $(DESTDIR)$(MEME_LOGS)
+
+ distdir = $(PACKAGE)_$(VERSION)
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index e0d6af9..e7bcb4f 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -202,7 +202,7 @@ COMMON_DOC = \
+ if WEBSITE
+ MEME_DOC_DIR = $(WEBDIR)/doc
+ else
+-MEME_DOC_DIR = $(prefix)/doc
++MEME_DOC_DIR = $(docdir)/html
+ endif
+
+ memedocdir = $(MEME_DOC_DIR)
+diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
+index 12970b5..633492c 100644
+--- a/doc/examples/Makefile.am
++++ b/doc/examples/Makefile.am
+@@ -51,24 +51,24 @@ if WEBSITE
+ exdir = $(WEBDIR)/examples
+ other_exdir = $(WEBDIR)/doc/examples
+ else
+-exdir = $(prefix)/doc/examples
++exdir = $(prefix)/share/meme/examples
+ other_exdir = $(exdir)
+ endif
+
+ ex_DATA = $(EXAMPLES)
+
+ install-data-hook:
+- tar xzvf centrimo_example_output_files.tgz -C $(other_exdir)
+- tar xzvf dreme_example_output_files.tgz -C $(other_exdir)
+- tar xzvf fimo_example_output_files.tgz -C $(other_exdir)
+- tar xzvf glam2_example_output_files.tgz -C $(other_exdir)
+- tar xzvf glam2scan_example_output_files.tgz -C $(other_exdir)
+- tar xzvf mast_example_output_files.tgz -C $(other_exdir)
+- tar xzvf mcast_example_output_files.tgz -C $(other_exdir)
+- tar xzvf meme_example_output_files.tgz -C $(other_exdir)
+- tar xzvf memechip_example_output_files.tgz -C $(other_exdir)
+- tar xzvf spamo_example_output_files.tgz -C $(other_exdir)
+- tar xzvf tomtom_example_output_files.tgz -C $(other_exdir)
++ tar xzvf centrimo_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf dreme_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf fimo_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf glam2_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf glam2scan_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf mast_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf mcast_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf meme_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf memechip_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf spamo_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
++ tar xzvf tomtom_example_output_files.tgz -C $(DESTDIR)/$(other_exdir)
+
+ # If .svnignore file doesn't exist
+ # create an empty one
+diff --git a/doc/examples/compute_prior_dist_example_output_files/Makefile.am b/doc/examples/compute_prior_dist_example_output_files/Makefile.am
+index 747028d..a358f58 100644
+--- a/doc/examples/compute_prior_dist_example_output_files/Makefile.am
++++ b/doc/examples/compute_prior_dist_example_output_files/Makefile.am
+@@ -22,7 +22,7 @@ EXAMPLES = \
+ if WEBSITE
+ exdir = $(WEBDIR)/doc/examples/compute_prior_dist_example_output_files
+ else
+-exdir = $(prefix)/doc/examples/compute_prior_dist_example_output_files
++exdir = $(prefix)/share/meme/examples/compute_prior_dist_example_output_files
+ endif
+
+ ex_DATA = $(EXAMPLES)
+diff --git a/doc/examples/sample_opal_scripts/Makefile.am b/doc/examples/sample_opal_scripts/Makefile.am
+index 3a638b3..30925bb 100644
+--- a/doc/examples/sample_opal_scripts/Makefile.am
++++ b/doc/examples/sample_opal_scripts/Makefile.am
+@@ -18,7 +18,7 @@ EXAMPLES = \
+ if WEBSITE
+ exdir = $(WEBDIR)/doc/examples/sample_opal_scripts
+ else
+-exdir = $(prefix)/doc/examples/sample_opal_scripts
++exdir = $(prefix)/share/meme/examples/sample_opal_scripts
+ endif
+
+ ex_DATA = $(EXAMPLES)
+diff --git a/doc/images/Makefile.am b/doc/images/Makefile.am
+index c879621..a4696cd 100644
+--- a/doc/images/Makefile.am
++++ b/doc/images/Makefile.am
+@@ -28,7 +28,7 @@ MEME_IMAGES = \
+ if WEBSITE
+ memeimgdir = $(WEBDIR)/doc/images
+ else
+-memeimgdir = $(prefix)/doc/images
++memeimgdir = $(docdir)/html/images
+ endif
+
+ memeimg_DATA = $(MEME_IMAGES)
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4143e46..8a5c021 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -8,7 +8,7 @@
+ if WEBSITE
+ MEME_DOC_DIR = $(WEBDIR)/doc
+ else
+-MEME_DOC_DIR = $(prefix)/doc
++MEME_DOC_DIR = $(docdir)
+ endif
+
+ ARCHIVE_REVISION = $(shell cat ../ARCHIVE_REVISION)
diff --git a/sci-biology/meme/meme-4.8.1.ebuild b/sci-biology/meme/meme-4.8.1.ebuild
new file mode 100644
index 000000000000..b143eeba05b8
--- /dev/null
+++ b/sci-biology/meme/meme-4.8.1.ebuild
@@ -0,0 +1,79 @@
+## Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/meme-4.8.1.ebuild,v 1.1 2012/08/26 16:03:01 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit autotools eutils python
+
+DESCRIPTION="The MEME/MAST system - Motif discovery and search"
+HOMEPAGE="http://meme.sdsc.edu/meme"
+SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
+
+LICENSE="meme"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mpi"
+
+DEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ app-shells/tcsh
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+#pkg_setup() {
+ # generate meme group to restrict logging to /var/log/meme
+# enewgroup meme
+# python_pkg_setup
+# python_set_active_version 2
+#}
+
+src_prepare() {
+ sed \
+ -e '/flags/s:-O3::g' \
+ -e '/opt/s:-O::g' \
+ -e '/debug/s:-ggdb::' \
+ -e '/debug/s:-g::' \
+ -e 's:CFLAGS=:CFLAGS+=:g' \
+ -i configure.ac || die
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.am.patch
+ eautoreconf
+}
+
+src_configure() {
+ MY_PREFIX="${ROOT}opt/meme"
+ USE_DISABLE_MPI=""; if ! use mpi; then USE_DISABLE_MPI="--enable-serial"; fi
+ econf \
+ --sysconfdir="${EPREFIX}/etc/meme" \
+ --with-logs="${ROOT}var/log/meme" \
+ $(use_enable debug) \
+ $USE_DISABLE_MPI
+}
+
+src_test() {
+ # bug #297070
+ emake -j1 test || die "Regression tests failed."
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ echo "PATH=/opt/${PN}/bin" > 99${PN}
+ doenvd 99${PN}
+
+ # allow logging only for members of meme group
+ # diropts -m 0770 -g meme -o root
+ diropts -m ugo+rwxt -o root
+ keepdir /var/log/meme
+}
+
+#pkg_postinst() {
+# einfo 'Log files are produced in the "/var/log/meme" directory. Users'
+# einfo 'need to be part of the meme group to use this facility.'
+#}