summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-01 15:41:29 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-01 15:41:29 +0000
commitb58874fe0c168291c181ddb5255631742d3a44f7 (patch)
tree92e810f5419bed53eb907de07abf988b4518c9df /sci-biology
parentFix typo in blocker, spotted by Nick Bowler in bug #428430 (diff)
downloadgentoo-2-b58874fe0c168291c181ddb5255631742d3a44f7.tar.gz
gentoo-2-b58874fe0c168291c181ddb5255631742d3a44f7.tar.bz2
gentoo-2-b58874fe0c168291c181ddb5255631742d3a44f7.zip
sci-biology/tree-puzzle: Mask stupid test, which fails due to precision reached depending on optimization used at compile time, #297646; fix move to EAPI=4, #429354
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tree-puzzle/ChangeLog7
-rw-r--r--sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch14
-rw-r--r--sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild12
3 files changed, 30 insertions, 3 deletions
diff --git a/sci-biology/tree-puzzle/ChangeLog b/sci-biology/tree-puzzle/ChangeLog
index 4c9ef5988c2c..34e72f3c6128 100644
--- a/sci-biology/tree-puzzle/ChangeLog
+++ b/sci-biology/tree-puzzle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/tree-puzzle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.18 2012/05/24 10:28:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/ChangeLog,v 1.19 2012/08/01 15:41:29 jlec Exp $
+
+ 01 Aug 2012; Justin Lecher <jlec@gentoo.org> tree-puzzle-5.2.ebuild,
+ +files/tree-puzzle-impl-dec.patch:
+ Mask stupid test, which fails due to precision reached depending on
+ optimization used at compile time, #297646; fix move to EAPI=4, #429354
24 May 2012; Justin Lecher <jlec@gentoo.org> tree-puzzle-5.2.ebuild:
Corrected dep from sys-cluster/lam-mpi to virtual/mpi, #415765
diff --git a/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch b/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
new file mode 100644
index 000000000000..93b960f5c2b4
--- /dev/null
+++ b/sci-biology/tree-puzzle/files/tree-puzzle-impl-dec.patch
@@ -0,0 +1,14 @@
+ src/sprng/primes-lcg64.c | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/sprng/primes-lcg64.c b/src/sprng/primes-lcg64.c
+index 8e5a7c9..fb04373 100644
+--- a/src/sprng/primes-lcg64.c
++++ b/src/sprng/primes-lcg64.c
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include "primes-lcg64.h"
+ #include "primelist-lcg64.h"
+
diff --git a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
index a567e9c34961..033fd7f49b7c 100644
--- a/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
+++ b/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.13 2012/05/24 10:28:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tree-puzzle/tree-puzzle-5.2.ebuild,v 1.14 2012/08/01 15:41:29 jlec Exp $
EAPI=4
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Maximum likelihood analysis for nucleotide, amino acid, and two-state data"
HOMEPAGE="http://www.tree-puzzle.de"
@@ -18,6 +18,8 @@ IUSE="mpi"
DEPEND="mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
+RESTRICT="test"
+
pkg_setup () {
use mpi && [ $(tc-getCC) = icc ] && die "The parallelized version of tree-puzzle cannot be compiled using icc.
Either disable the \"mpi\" USE flag to compile only the non-parallelized
@@ -25,6 +27,12 @@ pkg_setup () {
}
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-impl-dec.patch
+}
+
+src_configure() {
+ default
+
if ! use mpi; then
sed \
-e 's:bin_PROGRAMS = puzzle$(EXEEXT) ppuzzle:bin_PROGRAMS = puzzle :' \