summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2005-01-02 23:00:56 +0000
committerOlivier Fisette <ribosome@gentoo.org>2005-01-02 23:00:56 +0000
commit6c16617e3e9b1bee9f4f02f4694f8c3733cb68cb (patch)
treec2e88f36821963ac651e41b434711748db107c6a /sci-biology
parentx86 stable + arts dependancy as per bug #76412 (Manifest recommit) (diff)
downloadgentoo-2-6c16617e3e9b1bee9f4f02f4694f8c3733cb68cb.tar.gz
gentoo-2-6c16617e3e9b1bee9f4f02f4694f8c3733cb68cb.tar.bz2
gentoo-2-6c16617e3e9b1bee9f4f02f4694f8c3733cb68cb.zip
Use toolchain-funcs rather gcc.
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/phylip/ChangeLog8
-rw-r--r--sci-biology/phylip/phylip-3.62.ebuild8
-rw-r--r--sci-biology/phylip/phylip-3.63.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/sci-biology/phylip/ChangeLog b/sci-biology/phylip/ChangeLog
index f29e55b70e13..b5e51cbdfe5f 100644
--- a/sci-biology/phylip/ChangeLog
+++ b/sci-biology/phylip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/phylip
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.2 2004/12/24 02:32:43 swegener Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/ChangeLog,v 1.3 2005/01/02 23:00:56 ribosome Exp $
+
+ 02 Jan 2005; Olivier Fisette <ribosome@gentoo.org> phylip-3.62.ebuild,
+ phylip-3.63.ebuild:
+ Use the toolchain-funcs rather than the gcc eclass.
*phylip-3.63 (23 Dec 2004)
diff --git a/sci-biology/phylip/phylip-3.62.ebuild b/sci-biology/phylip/phylip-3.62.ebuild
index 0244f23ba9a0..355f6132faaa 100644
--- a/sci-biology/phylip/phylip-3.62.ebuild
+++ b/sci-biology/phylip/phylip-3.62.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.62.ebuild,v 1.2 2005/01/02 15:03:40 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.62.ebuild,v 1.3 2005/01/02 23:00:56 ribosome Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
@@ -20,8 +20,8 @@ S=${WORKDIR}/${P}/src
src_compile() {
sed -i -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" Makefile
- sed -i -e "s/CC = cc/CC = $(gcc-getCC)/" Makefile
- sed -i -e "s/DC = cc/DC = $(gcc-getCC)/" Makefile
+ sed -i -e "s/CC = cc/CC = $(tc-getCC)/" Makefile
+ sed -i -e "s/DC = cc/DC = $(tc-getCC)/" Makefile
mkdir ../fonts
emake -j1 all put || die
mv ../exe/font* ../fonts
diff --git a/sci-biology/phylip/phylip-3.63.ebuild b/sci-biology/phylip/phylip-3.63.ebuild
index b3f82a5020e8..faed94c539e1 100644
--- a/sci-biology/phylip/phylip-3.63.ebuild
+++ b/sci-biology/phylip/phylip-3.63.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.63.ebuild,v 1.2 2005/01/02 15:03:40 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/phylip/phylip-3.63.ebuild,v 1.3 2005/01/02 23:00:56 ribosome Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="PHYLIP - The PHYLogeny Inference Package"
HOMEPAGE="http://evolution.genetics.washington.edu/phylip.html"
@@ -20,8 +20,8 @@ S=${WORKDIR}/${P}/src
src_compile() {
sed -i -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" Makefile
- sed -i -e "s/CC = cc/CC = $(gcc-getCC)/" Makefile
- sed -i -e "s/DC = cc/DC = $(gcc-getCC)/" Makefile
+ sed -i -e "s/CC = cc/CC = $(tc-getCC)/" Makefile
+ sed -i -e "s/DC = cc/DC = $(tc-getCC)/" Makefile
mkdir ../fonts
emake -j1 all put || die
mv ../exe/font* ../fonts