summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-03-09 19:57:28 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-03-09 19:57:28 +0000
commit6b8c5a26344874bc2877211e172a7f3241e07290 (patch)
tree59a23ee3f953a656cc41e6a3cad84a2d6a064a69 /sci-biology
parentSync kde4 eclasses with kde-testing (review by scarabeus and jmbsvicetto). (diff)
downloadgentoo-2-6b8c5a26344874bc2877211e172a7f3241e07290.tar.gz
gentoo-2-6b8c5a26344874bc2877211e172a7f3241e07290.tar.bz2
gentoo-2-6b8c5a26344874bc2877211e172a7f3241e07290.zip
QA fixes
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mummer/ChangeLog5
-rw-r--r--sci-biology/mummer/mummer-3.21.ebuild25
2 files changed, 15 insertions, 15 deletions
diff --git a/sci-biology/mummer/ChangeLog b/sci-biology/mummer/ChangeLog
index 2cd72219071e..67fd68b9c783 100644
--- a/sci-biology/mummer/ChangeLog
+++ b/sci-biology/mummer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/mummer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/ChangeLog,v 1.5 2009/03/09 15:55:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/ChangeLog,v 1.6 2009/03/09 19:57:28 weaver Exp $
+
+ 09 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> mummer-3.21.ebuild:
+ QA fixes
09 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> mummer-3.20.ebuild,
mummer-3.21.ebuild:
diff --git a/sci-biology/mummer/mummer-3.21.ebuild b/sci-biology/mummer/mummer-3.21.ebuild
index 51f1cf3895b4..9038b7ca1c9f 100644
--- a/sci-biology/mummer/mummer-3.21.ebuild
+++ b/sci-biology/mummer/mummer-3.21.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.3 2009/03/09 15:55:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.4 2009/03/09 19:57:28 weaver Exp $
inherit eutils
-MY_P="MUMmer${PV}"
DESCRIPTION="A rapid whole genome aligner"
HOMEPAGE="http://mummer.sourceforge.net/"
-SRC_URI="mirror://sourceforge/mummer/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/mummer/MUMmer${PV}.tar.gz"
LICENSE="Artistic"
SLOT="0"
@@ -17,17 +16,17 @@ KEYWORDS="~amd64 ~x86"
DEPEND=""
RDEPEND="app-shells/tcsh"
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/MUMmer${PV}"
src_unpack() {
unpack ${A}
- # Warning: package uses CPPFLAGS on c in addition to cpp, despite the name
+ # Warning: package uses CPPFLAGS on c as well as cpp, despite the name
sed -i -e 's/CPPFLAGS =/CPPFLAGS = ${CFLAGS} /' \
- -e 's/LDFLAGS =$//' "${S}/Makefile"
+ -e 's/LDFLAGS =$//' "${S}/Makefile" || die
}
src_compile() {
- emake || die "emake failed"
+ emake || die
sed -i -e 's|\($AUX_BIN_DIR = "\).*"|\1/usr/bin"|' \
-e 's|\($BIN_DIR = "\).*"|\1/usr/bin"|' \
@@ -35,18 +34,16 @@ src_compile() {
-e 's|\(set bindir = \).*|\1/usr/bin|' \
-e 's|\(set scriptdir = \).*|\1/usr/share/'${PN}'/scripts|' \
-e 's|\(use lib "\).*"|\1/usr/share/'${PN}'/lib"|' \
- scripts/* exact-tandems mapview mummerplot nucmer promer run-mummer{1,3} || die "Failed to replace paths"
- sed -i 's|$bindir/annotate|$bindir/mummer-annotate|' run-mummer1 scripts/run-mummer1.csh
+ scripts/* exact-tandems mapview mummerplot nucmer promer run-mummer{1,3} || die
+ mv annotate mummer-annotate || die
+ sed -i 's|$bindir/annotate|$bindir/mummer-annotate|' run-mummer1 scripts/run-mummer1.csh || die
}
src_install() {
- dobin nucmer2xfig show-coords mapview show-snps run-mummer{1,3} \
- exact-tandems promer repeat-match show-aligns gaps mummer \
- show-tiling mgaps nucmer mummerplot delta-filter combineMUMs aux_bin/* || die
- newbin annotate mummer-annotate || die
+ dobin $(find . -maxdepth 1 -type f -executable) aux_bin/* || die
insinto /usr/share/${PN}/scripts
- doins scripts/{*.awk,*.csh,*.pl}
+ doins scripts/{*.awk,*.csh,*.pl} || die
insinto /usr/share/${PN}/lib
doins scripts/Foundation.pm || die