summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 18:00:44 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 18:00:44 +0000
commit4f268731ccb9f6281dd7313ce0f79cdcf76bf64f (patch)
treead56c7b73c7a227f6ce996609a14cbc6dd1e5aa7 /sci-biology
parentstable ppc, bug #429226 (diff)
downloadgentoo-2-4f268731ccb9f6281dd7313ce0f79cdcf76bf64f.tar.gz
gentoo-2-4f268731ccb9f6281dd7313ce0f79cdcf76bf64f.tar.bz2
gentoo-2-4f268731ccb9f6281dd7313ce0f79cdcf76bf64f.zip
sci-biology/shrimp: Do not install elf in usr/share, #438652
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/shrimp/ChangeLog8
-rw-r--r--sci-biology/shrimp/shrimp-1.3.1.ebuild35
-rw-r--r--sci-biology/shrimp/shrimp-2.0.1.ebuild29
-rw-r--r--sci-biology/shrimp/shrimp-2.1.0.ebuild31
4 files changed, 37 insertions, 66 deletions
diff --git a/sci-biology/shrimp/ChangeLog b/sci-biology/shrimp/ChangeLog
index ece2fc2bd12a..4f57d4aba634 100644
--- a/sci-biology/shrimp/ChangeLog
+++ b/sci-biology/shrimp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/shrimp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.14 2011/03/07 15:33:02 tomka Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.15 2012/10/18 18:00:44 jlec Exp $
+
+ 18 Oct 2012; Justin Lecher <jlec@gentoo.org> -shrimp-1.3.1.ebuild,
+ shrimp-2.0.1.ebuild, shrimp-2.1.0.ebuild:
+ Do not install elf in usr/share, #438652
07 Mar 2011; Thomas Kahle <tomka@gentoo.org> shrimp-2.0.1.ebuild:
x86 stable per bug 353563
diff --git a/sci-biology/shrimp/shrimp-1.3.1.ebuild b/sci-biology/shrimp/shrimp-1.3.1.ebuild
deleted file mode 100644
index 5723168881ea..000000000000
--- a/sci-biology/shrimp/shrimp-1.3.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-1.3.1.ebuild,v 1.3 2010/01/03 14:19:01 pacho Exp $
-
-EAPI="2"
-
-MY_PV=${PV//./_}
-
-DESCRIPTION="SHort Read Mapping Package"
-HOMEPAGE="http://compbio.cs.toronto.edu/shrimp/"
-SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-IUSE=""
-KEYWORDS="amd64 x86"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/SHRiMP_${MY_PV}"
-
-src_prepare() {
- sed -i -e '1 a #include <stdint.h>' common/dag_glue.cpp || die
- sed -i -e '1 a CXXFLAGS+= -O3 -mmmx -msse -msse2' \
- -e 's/-static//' "${S}/Makefile" || die
-}
-
-src_install() {
- rm bin/README
- dobin bin/* || die
- insinto /usr/share/${PN}
- doins -r utils || die
- dodoc HISTORY README TODO MEMORY
-}
diff --git a/sci-biology/shrimp/shrimp-2.0.1.ebuild b/sci-biology/shrimp/shrimp-2.0.1.ebuild
index c8d8c0072874..81f1bb11185d 100644
--- a/sci-biology/shrimp/shrimp-2.0.1.ebuild
+++ b/sci-biology/shrimp/shrimp-2.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.0.1.ebuild,v 1.5 2011/03/07 15:33:02 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.0.1.ebuild,v 1.6 2012/10/18 18:00:44 jlec Exp $
-EAPI="2"
+EAPI=4
inherit flag-o-matic toolchain-funcs
@@ -14,20 +14,20 @@ SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.g
LICENSE="as-is"
SLOT="0"
-IUSE=""
KEYWORDS="amd64 x86"
-
-DEPEND=">=sys-devel/gcc-4.3[openmp]"
-RDEPEND="${DEPEND}" # -lgomp
+IUSE="custom-cflags"
S=${WORKDIR}/SHRiMP_${MY_PV}
pkg_setup() {
- tc-has-openmp || die "At least gcc-4.3 is required for openmp support."
+ if [[ ${CC} == *gcc* ]] && ! tc-has-openmp; then
+ elog "Please set CC to an OPENMP capable compiler (e.g. gcc[openmp] or icc"
+ die "C compiler lacks OPENMP support"
+ fi
}
src_prepare() {
- sed -i -e '1 a #include <stdint.h>' common/dag_glue.cpp || die #294811
+ sed -e '1 a #include <stdint.h>' -i common/dag_glue.cpp || die
# respect LDFLAGS wrt 331823
sed -i -e "s/LDFLAGS/LIBS/" -e "s/\$(LD)/& \$(LDFLAGS)/" \
-e 's/-static//' Makefile || die
@@ -35,14 +35,15 @@ src_prepare() {
src_compile() {
append-flags -fopenmp
+ use custom-cflags || append-flags -O3 # per instructions in BUILDING
tc-export CXX
- emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
- rm bin/README || die
- dobin bin/* || die
+ rm bin/README
+ dobin bin/*
insinto /usr/share/${PN}
- doins -r utils || die
- dodoc HISTORY README TODO SPLITTING_AND_MERGING || die
+ doins -r utils
+ dodoc HISTORY README TODO SPLITTING_AND_MERGING
}
diff --git a/sci-biology/shrimp/shrimp-2.1.0.ebuild b/sci-biology/shrimp/shrimp-2.1.0.ebuild
index b6e235263f49..17e3a7398a5f 100644
--- a/sci-biology/shrimp/shrimp-2.1.0.ebuild
+++ b/sci-biology/shrimp/shrimp-2.1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.1.0.ebuild,v 1.1 2011/02/03 00:13:49 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.1.0.ebuild,v 1.2 2012/10/18 18:00:44 jlec Exp $
-EAPI="2"
+EAPI=4
inherit flag-o-matic toolchain-funcs
@@ -14,34 +14,35 @@ SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.g
LICENSE="as-is"
SLOT="0"
-IUSE=""
KEYWORDS="~amd64 ~x86"
-
-DEPEND=">=sys-devel/gcc-4.3[openmp]"
-RDEPEND="${DEPEND}" # -lgomp
+IUSE="custom-cflags"
S=${WORKDIR}/SHRiMP_${MY_PV}
pkg_setup() {
- tc-has-openmp || die "At least gcc-4.3 is required for openmp support."
+ if [[ ${CC} == *gcc* ]] && ! tc-has-openmp; then
+ elog "Please set CC to an OPENMP capable compiler (e.g. gcc[openmp] or icc"
+ die "C compiler lacks OPENMP support"
+ fi
}
src_prepare() {
- sed -i -e '1 a #include <stdint.h>' common/dag_glue.cpp || die #294811
+ sed -e '1 a #include <stdint.h>' -i common/dag_glue.cpp || die
# respect LDFLAGS wrt 331823
sed -i -e "s/LDFLAGS/LIBS/" -e "s/\$(LD)/& \$(LDFLAGS)/" \
-e 's/-static//' Makefile || die
}
src_compile() {
- append-flags -fopenmp -O3 # per instructions in BUILDING
+ append-flags -fopenmp
+ use custom-cflags || append-flags -O3 # per instructions in BUILDING
tc-export CXX
- emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
- dobin bin/* || die
- insinto /usr/share/${PN}
- doins -r utils || die
- dodoc HISTORY README TODO SPLITTING_AND_MERGING || die
+ dobin bin/*
+ insinto /usr/libexec/${PN}
+ doins -r utils/*
+ dodoc HISTORY README TODO SPLITTING_AND_MERGING
}