summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-09-26 07:49:33 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-09-26 07:49:33 +0000
commit4acdc0b6a589b639f400b14165e7b9eb04287d47 (patch)
treeb6a0efc169970f807c14e8babd258bcd84cfcd29 /sci-biology
parentVersion bump (diff)
downloadgentoo-2-4acdc0b6a589b639f400b14165e7b9eb04287d47.tar.gz
gentoo-2-4acdc0b6a589b639f400b14165e7b9eb04287d47.tar.bz2
gentoo-2-4acdc0b6a589b639f400b14165e7b9eb04287d47.zip
Version bump, drop old
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/augustus/ChangeLog8
-rw-r--r--sci-biology/augustus/augustus-2.4.ebuild (renamed from sci-biology/augustus/augustus-2.1.ebuild)26
-rw-r--r--sci-biology/augustus/files/augustus-2.1-glibc-2.10.patch45
3 files changed, 19 insertions, 60 deletions
diff --git a/sci-biology/augustus/ChangeLog b/sci-biology/augustus/ChangeLog
index 7534aaf61375..f31a81fa96ea 100644
--- a/sci-biology/augustus/ChangeLog
+++ b/sci-biology/augustus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/augustus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/augustus/ChangeLog,v 1.9 2010/02/09 11:13:18 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/augustus/ChangeLog,v 1.10 2010/09/26 07:49:33 weaver Exp $
+
+*augustus-2.4 (26 Sep 2010)
+
+ 26 Sep 2010; Andrey Kislyuk <weaver@gentoo.org> -augustus-2.1.ebuild,
+ -files/augustus-2.1-glibc-2.10.patch, +augustus-2.4.ebuild:
+ Version bump, drop old
09 Feb 2010; Pacho Ramos <pacho@gentoo.org> augustus-2.3.1.ebuild:
amd64 stable, bug 298767
diff --git a/sci-biology/augustus/augustus-2.1.ebuild b/sci-biology/augustus/augustus-2.4.ebuild
index f25f60aeb667..e8f56e9346e9 100644
--- a/sci-biology/augustus/augustus-2.1.ebuild
+++ b/sci-biology/augustus/augustus-2.4.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/augustus/augustus-2.1.ebuild,v 1.3 2009/10/31 17:55:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/augustus/augustus-2.4.ebuild,v 1.1 2010/09/26 07:49:33 weaver Exp $
-EAPI="1"
-inherit eutils
+EAPI="2"
+
+inherit base eutils
DESCRIPTION="Eukaryotic gene predictor"
HOMEPAGE="http://augustus.gobics.de/"
@@ -12,15 +13,12 @@ SRC_URI="http://augustus.gobics.de/binaries/${PN}.${PV}.src.tar.gz"
LICENSE="Artistic"
SLOT="0"
IUSE=""
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
-S=${WORKDIR}/${PN}
+DEPEND=""
+RDEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
-}
+#S="${WORKDIR}/${PN}"
src_compile() {
emake -C src clean || die
@@ -28,10 +26,10 @@ src_compile() {
}
src_install() {
- dobin src/{augustus,etraining} || die
+ dobin src/{augustus,etraining,consensusFinder,curve2hints} || die
insinto /usr/share/${PN}
- doins -r config examples scripts || die
+ doins -r config examples scripts docs || die
echo "AUGUSTUS_CONFIG_PATH=\"/usr/share/${PN}/config\"" > "${S}/99${PN}"
doenvd "${S}/99${PN}" || die
- dodoc README.TXT HISTORY.TXT
+ dodoc README.TXT HISTORY.TXT docs/*
}
diff --git a/sci-biology/augustus/files/augustus-2.1-glibc-2.10.patch b/sci-biology/augustus/files/augustus-2.1-glibc-2.10.patch
deleted file mode 100644
index d3c163459801..000000000000
--- a/sci-biology/augustus/files/augustus-2.1-glibc-2.10.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ur augustus.orig/src/hints.cc augustus/src/hints.cc
---- augustus.orig/src/hints.cc 2008-11-17 14:41:15.000000000 +0200
-+++ augustus/src/hints.cc 2009-08-09 18:23:40.000000000 +0300
-@@ -137,11 +137,11 @@
- /*
- * find groupname of hint, specified in gff as: group=xxx; or grp=xxx;
- */
-- spos = strstr(feature.attributes.c_str(), "group=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "group="));
- if (spos)
- spos += 6;
- if (!spos) {
-- spos = strstr(feature.attributes.c_str(), "grp=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "grp="));
- if (spos)
- spos += 4;
- }
-@@ -159,11 +159,11 @@
- * find priority of hint, specified in gff as: priority=N; or pri=N;
- * higher number means higher priority
- */
-- spos = strstr(feature.attributes.c_str(), "priority=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "priority="));
- if (spos)
- spos += 9;
- if (!spos) {
-- spos = strstr(feature.attributes.c_str(), "pri=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "pri="));
- if (spos)
- spos += 4;
- }
-@@ -176,11 +176,11 @@
- /*
- * find source of extrinsic info, specified in gff as: source=X or src=X
- */
-- spos = strstr(feature.attributes.c_str(), "source=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "source="));
- if (spos)
- spos += 7;
- if (!spos) {
-- spos = strstr(feature.attributes.c_str(), "src=");
-+ spos = const_cast<char*> (strstr(feature.attributes.c_str(), "src="));
- if (spos)
- spos += 4;
- }