summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 20:58:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 20:58:42 +0000
commit453a57764709b7f724463e553e5f5c646ba76b4e (patch)
tree9599c4583d37e436e52da8b606906162a8532019 /sci-biology
parentVersion bump, init script fix (diff)
downloadgentoo-2-453a57764709b7f724463e553e5f5c646ba76b4e.tar.gz
gentoo-2-453a57764709b7f724463e553e5f5c646ba76b4e.tar.bz2
gentoo-2-453a57764709b7f724463e553e5f5c646ba76b4e.zip
Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay, keyworded as in overlay
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/emboss/ChangeLog11
-rw-r--r--sci-biology/emboss/emboss-6.1.0-r1.ebuild110
2 files changed, 119 insertions, 2 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 4ca45c3a1162..de2ba5b04b60 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/emboss
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.54 2009/09/01 21:57:55 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.55 2010/03/07 20:58:42 jlec Exp $
+
+*emboss-6.1.0-r1 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +emboss-6.1.0-r1.ebuild:
+ Moved to EAPI=3 for PREFIX support, imported prefix patches from overlay,
+ keyworded as in overlay
01 Sep 2009; Olivier Fisette <ribosome@gentoo.org> metadata.xml:
Giving up maintainership of this package.
diff --git a/sci-biology/emboss/emboss-6.1.0-r1.ebuild b/sci-biology/emboss/emboss-6.1.0-r1.ebuild
new file mode 100644
index 000000000000..485e5d25ddcd
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.1.0-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.1.0-r1.ebuild,v 1.1 2010/03/07 20:58:42 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="X png minimal"
+
+DEPEND="X? ( x11-libs/libXt )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )"
+
+RDEPEND="${DEPEND}"
+
+PDEPEND="!minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ >=sci-biology/rebase-707
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.0-as-needed.patch
+
+ local link_string="-lX11";
+ if use png; then
+ link_string="${link_string} -lgd -lpng"
+ fi
+ sed -e "s:PATCH_PLPLOT:${link_string}:" -i plplot/Makefile.in \
+ || die "Failed to patch ajax Makefile"
+}
+
+src_configure() {
+ EXTRA_CONF="--includedir=${ED}/usr/include/emboss"
+ ! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
+ ! use png && EXTRA_CONF="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${EXTRA_CONF} || die
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will eventually be available as a separate package.
+ sed -i -e "s/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/" \
+ Makefile || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS \
+ || die "Failed to install documentation."
+ newdoc "${FILESDIR}"/${PN}-README.Gentoo-1 README.Gentoo \
+ || die "Failed to install Gentoo readme file."
+
+ # Install env file for setting libplplot and acd files path.
+ cat <<- EOF > 22emboss
+ # plplot libs dir
+ PLPLOT_LIB="${EPREFIX}/usr/share/EMBOSS/"
+ # ACD files location
+ EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
+ EOF
+ doenvd 22emboss || die "Failed to install environment file."
+
+ # Symlink preinstalled docs to "/usr/share/doc".
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
+
+ # Remove frestdist documentation conflicting with the EMBASSY philypnew
+ # package.
+ rm "${ED}"/usr/share/EMBOSS/doc/programs/text/frestdist.txt || \
+ die "Failed to remove duplicated documentation."
+
+ # Remove useless dummy files from the image.
+ rm "${ED}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
+ || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${ED}"/usr/share/EMBOSS/data/CODONS \
+ "${ED}"/usr/share/EMBOSS/data/CODONS.orig || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This avoids file collisions with versions of rebase that install their
+ # own enzyme prototypes file (see bug #118832).
+ mv "${ED}"/usr/share/EMBOSS/data/embossre.equ \
+ "${ED}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ die "Failed to move enzyme equivalence file."
+}