summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-17 13:51:56 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-17 13:51:56 +0000
commit3df3511ed9be33256af7ab9cedad181de1ec50bb (patch)
treef011460c376b38287b245d160476bb768620b348 /sci-biology
parentStable for ppc64, wrt bug #524154 (diff)
downloadgentoo-2-3df3511ed9be33256af7ab9cedad181de1ec50bb.tar.gz
gentoo-2-3df3511ed9be33256af7ab9cedad181de1ec50bb.tar.bz2
gentoo-2-3df3511ed9be33256af7ab9cedad181de1ec50bb.zip
sci-biology/seqan: Version BUmp
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/seqan/ChangeLog10
-rw-r--r--sci-biology/seqan/files/seqan-1.4.2-include.patch16
-rw-r--r--sci-biology/seqan/files/seqan-1.4.2-shared.patch22
-rw-r--r--sci-biology/seqan/seqan-1.4.2.ebuild55
4 files changed, 101 insertions, 2 deletions
diff --git a/sci-biology/seqan/ChangeLog b/sci-biology/seqan/ChangeLog
index 02a4845e6eca..eaf19ac1f317 100644
--- a/sci-biology/seqan/ChangeLog
+++ b/sci-biology/seqan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/seqan
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.4 2013/07/17 07:09:45 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/ChangeLog,v 1.5 2014/10/17 13:51:56 jlec Exp $
+
+*seqan-1.4.2 (17 Oct 2014)
+
+ 17 Oct 2014; Justin Lecher <jlec@gentoo.org> +seqan-1.4.2.ebuild,
+ +files/seqan-1.4.2-include.patch, +files/seqan-1.4.2-shared.patch:
+ Version BUmp
17 Jul 2013; Justin Lecher <jlec@gentoo.org> seqan-1.3.1-r1.ebuild:
Add missing dep
diff --git a/sci-biology/seqan/files/seqan-1.4.2-include.patch b/sci-biology/seqan/files/seqan-1.4.2-include.patch
new file mode 100644
index 000000000000..5baee4d8ebc0
--- /dev/null
+++ b/sci-biology/seqan/files/seqan-1.4.2-include.patch
@@ -0,0 +1,16 @@
+ core/include/seqan/index/index_qgram_openaddressing.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/core/include/seqan/index/index_qgram_openaddressing.h b/core/include/seqan/index/index_qgram_openaddressing.h
+index 4a6c2e6..8cc9a42 100644
+--- a/core/include/seqan/index/index_qgram_openaddressing.h
++++ b/core/include/seqan/index/index_qgram_openaddressing.h
+@@ -35,6 +35,8 @@
+ #ifndef SEQAN_HEADER_INDEX_QGRAM_OPENADRESSING_H
+ #define SEQAN_HEADER_INDEX_QGRAM_OPENADRESSING_H
+
++#include <smmintrin.h>
++
+ namespace SEQAN_NAMESPACE_MAIN
+ {
+
diff --git a/sci-biology/seqan/files/seqan-1.4.2-shared.patch b/sci-biology/seqan/files/seqan-1.4.2-shared.patch
new file mode 100644
index 000000000000..0f438ff07bce
--- /dev/null
+++ b/sci-biology/seqan/files/seqan-1.4.2-shared.patch
@@ -0,0 +1,22 @@
+ util/cmake/SeqAnBuildSystem.cmake | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/util/cmake/SeqAnBuildSystem.cmake b/util/cmake/SeqAnBuildSystem.cmake
+index bcba2c0..d53cd01 100644
+--- a/util/cmake/SeqAnBuildSystem.cmake
++++ b/util/cmake/SeqAnBuildSystem.cmake
+@@ -144,10 +144,10 @@ macro (seqan_register_apps)
+ set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSEQAN_ENABLE_DEBUG=1")
+
+ # enable static linkage for seqan apps
+- if (CMAKE_COMPILER_IS_GNUCXX OR COMPILER_IS_CLANG AND NOT MINGW)
+- set(CMAKE_FIND_LIBRARY_SUFFIXES ".a")
+- set(CMAKE_EXE_LINKER_FLAGS "-static-libgcc -static-libstdc++")
+- endif ()
++# if (CMAKE_COMPILER_IS_GNUCXX OR COMPILER_IS_CLANG AND NOT MINGW)
++# set(CMAKE_FIND_LIBRARY_SUFFIXES ".a")
++# set(CMAKE_EXE_LINKER_FLAGS "-static-libgcc -static-libstdc++")
++# endif ()
+
+ # Get all direct entries of the current source directory into ENTRIES.
+ file (GLOB ENTRIES
diff --git a/sci-biology/seqan/seqan-1.4.2.ebuild b/sci-biology/seqan/seqan-1.4.2.ebuild
new file mode 100644
index 000000000000..f1e36479061b
--- /dev/null
+++ b/sci-biology/seqan/seqan-1.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seqan/seqan-1.4.2.ebuild,v 1.1 2014/10/17 13:51:56 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils flag-o-matic python-single-r1
+
+DESCRIPTION="C++ Sequence Analysis Library"
+HOMEPAGE="http://www.seqan.de/"
+SRC_URI="http://packages.${PN}.de/${PN}-src/${PN}-src-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ sci-biology/samtools"
+DEPEND="${RDEPEND}"
+
+#S="${WORKDIR}"/${P}/cmake
+
+PATCHES=(
+ "${FILESDIR}"/${P}-shared.patch
+ "${FILESDIR}"/${P}-include.patch
+)
+
+src_prepare() {
+ rm -f \
+ util/cmake/FindZLIB.cmake \
+ || die
+ touch extras/apps/seqan_flexbar/README || die
+ sed \
+ -e "s:share/doc:share/doc/${PF}:g" \
+ -i docs/CMakeLists.txt util/cmake/SeqAnBuildSystem.cmake || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DZLIB_INCLUDE_DIRS="${EPREFIX}"/usr/include
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ mkdir -p "${BUILD_DIR}"/docs/html || die
+ cmake-utils_src_install
+ chmod 755 "${ED}"/usr/bin/*sh || die
+}