summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-25 19:09:19 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-25 19:09:19 +0000
commit3810824a552076d3211308201d89185e0037fd5a (patch)
tree2bde2af07ca962022091eeb53f5b411b6292a62c /sci-biology
parentversion bump. note that version 6 is a rewrite, but can import your version 5... (diff)
downloadgentoo-2-3810824a552076d3211308201d89185e0037fd5a.tar.gz
gentoo-2-3810824a552076d3211308201d89185e0037fd5a.tar.bz2
gentoo-2-3810824a552076d3211308201d89185e0037fd5a.zip
sci-biology/vaal: Version Bump
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/vaal/ChangeLog7
-rw-r--r--sci-biology/vaal/vaal-42179.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sci-biology/vaal/ChangeLog b/sci-biology/vaal/ChangeLog
index aaf5089dc5ca..b7764f8287da 100644
--- a/sci-biology/vaal/ChangeLog
+++ b/sci-biology/vaal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/vaal
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.9 2012/06/25 18:50:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/ChangeLog,v 1.10 2012/06/25 19:09:19 jlec Exp $
+
+*vaal-42179 (25 Jun 2012)
+
+ 25 Jun 2012; Justin Lecher <jlec@gentoo.org> +vaal-42179.ebuild:
+ Version Bump
25 Jun 2012; Justin Lecher <jlec@gentoo.org> -vaal-1.2-r1.ebuild,
vaal-1.6.ebuild, files/vaal-1.6-respect-flags.patch:
diff --git a/sci-biology/vaal/vaal-42179.ebuild b/sci-biology/vaal/vaal-42179.ebuild
new file mode 100644
index 000000000000..5713307e05e9
--- /dev/null
+++ b/sci-biology/vaal/vaal-42179.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-42179.ebuild,v 1.1 2012/06/25 19:09:19 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="A variant ascertainment algorithm that can be used to detect SNPs, indels, and other polymorphisms"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd/"
+SRC_URI="
+ ftp://ftp.broad.mit.edu/pub/crd/VAAL/latest_source_code/${P}.tar.gz
+ ftp://ftp.broad.mit.edu/pub/crd/VAAL/VAAL_manual.doc"
+
+LICENSE="Whitehead-MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+DEPEND=">=dev-libs/boost-1.41.0-r3"
+RDEPEND="${DEPEND}"
+
+DOCS=( "${DISTDIR}/VAAL_manual.doc" )
+
+src_prepare() {
+ sed \
+ -e '/COPYING/d' \
+ -i src/Makefile.am || die
+
+ sed \
+ -e 's:-ggdb3::g' \
+ -e '/AC_OPENMP_CEHCK/d' \
+ -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure(){
+ local myeconfargs=( $(use_enable openmp) )
+ autotools-utils_src_configure
+}