summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-09-26 07:39:29 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-09-26 07:39:29 +0000
commit0c889ed9eca6bfc30469ec435a1266b689de19d9 (patch)
treef80930e99cf2951cc10c045535e80f53330e1f3f /sci-biology
parentVersion bump (diff)
downloadgentoo-2-0c889ed9eca6bfc30469ec435a1266b689de19d9.tar.gz
gentoo-2-0c889ed9eca6bfc30469ec435a1266b689de19d9.tar.bz2
gentoo-2-0c889ed9eca6bfc30469ec435a1266b689de19d9.zip
Version bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/ncbi-tools++/ChangeLog8
-rw-r--r--sci-biology/ncbi-tools++/ncbi-tools++-2010.06.15.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/sci-biology/ncbi-tools++/ChangeLog b/sci-biology/ncbi-tools++/ChangeLog
index 05f5be575736..672412b60197 100644
--- a/sci-biology/ncbi-tools++/ChangeLog
+++ b/sci-biology/ncbi-tools++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/ncbi-tools++
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ChangeLog,v 1.16 2010/06/26 11:04:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ChangeLog,v 1.17 2010/09/26 07:39:29 weaver Exp $
+
+*ncbi-tools++-2010.06.15 (26 Sep 2010)
+
+ 26 Sep 2010; Andrey Kislyuk <weaver@gentoo.org>
+ +ncbi-tools++-2010.06.15.ebuild:
+ Version bump
*ncbi-tools++-2009.05.15-r6 (26 Jun 2010)
diff --git a/sci-biology/ncbi-tools++/ncbi-tools++-2010.06.15.ebuild b/sci-biology/ncbi-tools++/ncbi-tools++-2010.06.15.ebuild
new file mode 100644
index 000000000000..85509db43671
--- /dev/null
+++ b/sci-biology/ncbi-tools++/ncbi-tools++-2010.06.15.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/ncbi-tools++/ncbi-tools++-2010.06.15.ebuild,v 1.1 2010/09/26 07:39:29 weaver Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+MY_TAG="Jun_15_2010"
+MY_Y="${MY_TAG/*_/}"
+MY_P="ncbi_cxx--${MY_TAG}"
+
+DESCRIPTION="NCBI C++ Toolkit, including NCBI BLAST+"
+HOMEPAGE="http://www.ncbi.nlm.nih.gov/books/bv.fcgi?rid=toolkit"
+SRC_URI="ftp://ftp.ncbi.nih.gov/toolbox/ncbi_tools++/${MY_Y}/${MY_TAG}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+IUSE="sqlite mysql"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="sqlite? ( dev-db/sqlite:3 )
+ mysql? ( virtual/mysql )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i -e 's/-print-file-name=libstdc++.a//' \
+ -e '/sed/ s/\([gO]\[0-9\]\)\*/\1\\+/' \
+ src/build-system/configure || die
+}
+
+src_configure() {
+ tc-export CXX CC
+
+ "${S}"/configure --without-debug \
+ --with-bin-release \
+ --with-bincopy \
+ --without-static \
+ --with-dll \
+ --with-mt \
+ --prefix="${ED}"/usr \
+ --libdir="${ED}"/usr/$(get_libdir)/${PN} \
+ || die
+}
+
+src_compile() {
+ emake all_r -C GCC*-Release*/build || die
+}
+
+src_install() {
+ emake install || die
+ # File collisions with sci-biology/ncbi-tools
+ rm -f "${ED}"/usr/bin/{asn2asn,rpsblast,test_regexp}
+
+ echo "LDPATH=${EPREFIX}/usr/$(get_libdir)/${PN}" > ${S}/99${PN}
+ doenvd "${S}/99${PN}"
+}
+
+pkg_postinst() {
+ einfo 'Please run "source /etc/profile" before using this package in the current shell.'
+}