summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-19 11:34:11 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-19 11:34:11 +0000
commit0c533eddb497d5b4044e8c43fe00776326de514a (patch)
tree2213b11de6ea52fa378ee2275eaa3704b9842214 /sci-biology
parentsci-libs/gamer: Fix relink problems of libtool, #421749 (diff)
downloadgentoo-2-0c533eddb497d5b4044e8c43fe00776326de514a.tar.gz
gentoo-2-0c533eddb497d5b4044e8c43fe00776326de514a.tar.bz2
gentoo-2-0c533eddb497d5b4044e8c43fe00776326de514a.zip
sci-biology/bowtie: Version Bump, Fix compilation with gcc-4.7, #421919
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/ChangeLog10
-rw-r--r--sci-biology/bowtie/bowtie-0.12.8.ebuild44
-rw-r--r--sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch45
3 files changed, 97 insertions, 2 deletions
diff --git a/sci-biology/bowtie/ChangeLog b/sci-biology/bowtie/ChangeLog
index 3dd84e690308..519ba8efed2f 100644
--- a/sci-biology/bowtie/ChangeLog
+++ b/sci-biology/bowtie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/bowtie
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/ChangeLog,v 1.13 2011/03/06 17:18:05 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/ChangeLog,v 1.14 2012/06/19 11:34:11 jlec Exp $
+
+*bowtie-0.12.8 (19 Jun 2012)
+
+ 19 Jun 2012; Justin Lecher <jlec@gentoo.org> +bowtie-0.12.8.ebuild,
+ +files/bowtie-0.12.8-gcc-47.patch:
+ Version Bump, Fix compilation with gcc-4.7, #421919
*bowtie-0.12.7 (06 Mar 2011)
diff --git a/sci-biology/bowtie/bowtie-0.12.8.ebuild b/sci-biology/bowtie/bowtie-0.12.8.ebuild
new file mode 100644
index 000000000000..eb6670183490
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-0.12.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/bowtie-0.12.8.ebuild,v 1.1 2012/06/19 11:34:11 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ultrafast memory-efficient short read aligner"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+# NB: Bundles code from Maq (http://maq.sf.net) and the SeqAn library (http://www.seqan.de)
+# TODO: properly report system CFLAGS in -DCOMPILE_OPTIONS
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-47.patch
+}
+
+src_compile() {
+ unset CFLAGS
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CXX="$(tc-getCXX)" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS=""
+}
+
+src_install() {
+ dobin bowtie bowtie-*
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ newman MANUAL bowtie.1
+ dodoc AUTHORS NEWS TUTORIAL
+}
diff --git a/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch b/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
new file mode 100644
index 000000000000..3c8a1e1d9ca4
--- /dev/null
+++ b/sci-biology/bowtie/files/bowtie-0.12.8-gcc-47.patch
@@ -0,0 +1,45 @@
+ alphabet.h | 24 ++++++++++++------------
+ 1 files changed, 12 insertions(+), 12 deletions(-)
+
+diff --git a/alphabet.h b/alphabet.h
+index b464ddf..08d0281 100644
+--- a/alphabet.h
++++ b/alphabet.h
+@@ -38,6 +38,18 @@ static inline TStr reverseComplement(const TStr& s, bool color) {
+ return s_rc;
+ }
+
++/// Reverse a string in-place
++template <typename TStr>
++static inline void reverseInPlace(TStr& s) {
++ typedef typename Value<TStr>::Type TVal;
++ size_t len = length(s);
++ for(size_t i = 0; i < (len>>1); i++) {
++ TVal tmp = s[i];
++ s[i] = s[len-i-1];
++ s[len-i-1] = tmp;
++ }
++}
++
+ /**
+ * Reverse-complement s in-place. Ns go to Ns.
+ */
+@@ -69,18 +81,6 @@ static inline void reverseComplementInPlace(TStr& s, bool color) {
+ }
+ }
+
+-/// Reverse a string in-place
+-template <typename TStr>
+-static inline void reverseInPlace(TStr& s) {
+- typedef typename Value<TStr>::Type TVal;
+- size_t len = length(s);
+- for(size_t i = 0; i < (len>>1); i++) {
+- TVal tmp = s[i];
+- s[i] = s[len-i-1];
+- s[len-i-1] = tmp;
+- }
+-}
+-
+ /**
+ * Return the reverse-complement of s.
+ */