summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-17 07:09:36 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-17 07:09:36 +0000
commit07b44a8d7051cf8bcdcf841a2fd3d2fa97861aeb (patch)
treed86f2f9dbb6c515b19a526468cde314cfb17416d /sci-biology
parentVersion bump. (diff)
downloadgentoo-2-07b44a8d7051cf8bcdcf841a2fd3d2fa97861aeb.tar.gz
gentoo-2-07b44a8d7051cf8bcdcf841a2fd3d2fa97861aeb.tar.bz2
gentoo-2-07b44a8d7051cf8bcdcf841a2fd3d2fa97861aeb.zip
sci-biology/bowtie: Version Bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bowtie/ChangeLog7
-rw-r--r--sci-biology/bowtie/bowtie-1.0.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sci-biology/bowtie/ChangeLog b/sci-biology/bowtie/ChangeLog
index b6687cb2229d..fc0badbf1e6c 100644
--- a/sci-biology/bowtie/ChangeLog
+++ b/sci-biology/bowtie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/bowtie
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/ChangeLog,v 1.15 2013/03/11 14:53:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/ChangeLog,v 1.16 2013/07/17 07:09:36 jlec Exp $
+
+*bowtie-1.0.0 (17 Jul 2013)
+
+ 17 Jul 2013; Justin Lecher <jlec@gentoo.org> +bowtie-1.0.0.ebuild:
+ Version Bump
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
diff --git a/sci-biology/bowtie/bowtie-1.0.0.ebuild b/sci-biology/bowtie/bowtie-1.0.0.ebuild
new file mode 100644
index 000000000000..d43ba58ccb85
--- /dev/null
+++ b/sci-biology/bowtie/bowtie-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bowtie/bowtie-1.0.0.ebuild,v 1.1 2013/07/17 07:09:36 jlec Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ultrafast memory-efficient short read aligner"
+HOMEPAGE="http://bowtie-bio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ unset CFLAGS
+ emake \
+ CC="$(tc-getCC)" \
+ CPP="$(tc-getCXX)" \
+ CXX="$(tc-getCXX)" \
+ EXTRA_FLAGS="${LDFLAGS}" \
+ RELEASE_FLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin bowtie bowtie-*
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+
+ insinto /usr/share/${PN}
+ doins -r genomes indexes
+
+ newman MANUAL bowtie.1
+ dodoc AUTHORS NEWS TUTORIAL doc/README
+ dohtml manual.html style.css
+}