summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-11-13 15:43:25 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-11-13 15:43:25 +0000
commit2c9945edc869cda4e02f0207d618ad0fd05cb1aa (patch)
treec7b7d2f2e91f44a85e30f4f5d7d972d375fc8c0a /sci-biology/vienna-rna
parentVersion bump (diff)
downloadgentoo-2-2c9945edc869cda4e02f0207d618ad0fd05cb1aa.tar.gz
gentoo-2-2c9945edc869cda4e02f0207d618ad0fd05cb1aa.tar.bz2
gentoo-2-2c9945edc869cda4e02f0207d618ad0fd05cb1aa.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/vienna-rna')
-rw-r--r--sci-biology/vienna-rna/ChangeLog7
-rw-r--r--sci-biology/vienna-rna/vienna-rna-1.8.4.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-biology/vienna-rna/ChangeLog b/sci-biology/vienna-rna/ChangeLog
index 76bce03e9438..e1cf06a99eca 100644
--- a/sci-biology/vienna-rna/ChangeLog
+++ b/sci-biology/vienna-rna/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/vienna-rna
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.24 2009/11/02 20:23:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/ChangeLog,v 1.25 2009/11/13 15:43:25 weaver Exp $
+
+*vienna-rna-1.8.4 (13 Nov 2009)
+
+ 13 Nov 2009; Andrey Kislyuk <weaver@gentoo.org> +vienna-rna-1.8.4.ebuild:
+ Version bump
02 Nov 2009; Markus Meier <maekke@gentoo.org> vienna-rna-1.8.3.ebuild:
amd64/x86 stable, bug #290926
diff --git a/sci-biology/vienna-rna/vienna-rna-1.8.4.ebuild b/sci-biology/vienna-rna/vienna-rna-1.8.4.ebuild
new file mode 100644
index 000000000000..9ebcc34416ba
--- /dev/null
+++ b/sci-biology/vienna-rna/vienna-rna-1.8.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vienna-rna/vienna-rna-1.8.4.ebuild,v 1.1 2009/11/13 15:43:25 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs multilib autotools perl-module
+
+DESCRIPTION="The Vienna RNA Package - RNA secondary structure prediction and comparison"
+LICENSE="vienna-rna"
+HOMEPAGE="http://www.tbi.univie.ac.at/~ivo/RNA"
+SRC_URI="http://www.tbi.univie.ac.at/~ivo/RNA/ViennaRNA-${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~ppc"
+
+DEPEND="dev-lang/perl
+ media-libs/gd"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/ViennaRNA-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.5-c-fixes.patch
+ "${FILESDIR}"/${PN}-1.7.2-LDFLAGS.patch
+ "${FILESDIR}"/${PN}-1.8.3-gcc4.3.patch
+ "${FILESDIR}"/${PN}-1.8.3-disable-gd.patch
+)
+
+src_prepare() {
+ base_src_prepare
+ sed -i 's/ getline/ v_getline/' Readseq/ureadseq.c || die
+ sed -i '1 i #include <cstdio>' RNAforester/src/rnafuncs.cpp || die
+
+ eautoreconf
+ (cd RNAforester; eautoreconf)
+}
+
+src_configure() {
+ econf --with-cluster || die "Configuration failed."
+ sed -e "s:LIBDIR = /usr/lib:LIBDIR = ${D}/usr/$(get_libdir):" \
+ -e "s:INCDIR = /usr/include:INCDIR = ${D}/usr/include:" \
+ -i RNAforester/g2-0.70/Makefile \
+ || die "Failed patching RNAForester build system."
+ sed -e "s:CC=cc:CC=$(tc-getCC):" -e "s:CFLAGS=:CFLAGS=${CFLAGS}:" \
+ -i Readseq/Makefile || die "Failed patching readseq Makefile."
+}
+
+src_compile() {
+ emake clean || die
+ emake || die "Compilation failed."
+ emake -C Readseq || die "Failed to compile readseq."
+ # TODO: Add (optional?) support for the NCBI toolkit.
+}
+
+src_test() {
+ cd "${S}"/Perl && emake check || die "Perl tests failed"
+ cd "${S}"/Readseq && emake test || die "Readseq tests failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Installation failed."
+ dodoc AUTHORS ChangeLog NEWS README THANKS \
+ || die "Failed to install documentation."
+ newbin Readseq/readseq readseq-vienna \
+ || die "Installing readseq failed."
+ dodoc Readseq/Readseq.help || die \
+ "Readseq Documentation installation failed."
+ newdoc Readseq/Readme README.readseq && \
+ newdoc Readseq/Formats Formats.readseq \
+ || die "Installing readseq Readme failed."
+
+ # remove perlocal.pod to avoid file collisions (see #240358)
+ fixlocalpod || die "Failed to remove perlocal.pod"
+}