summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-06 12:24:45 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-06 12:24:45 +0000
commit5f824af98c5992918b8611baa24a96114a1ab78a (patch)
tree599d8ecd7532f3f5593aa4a8774a15fe66c99a50 /sci-biology/rnaview
parentRemove old. (diff)
downloadgentoo-2-5f824af98c5992918b8611baa24a96114a1ab78a.tar.gz
gentoo-2-5f824af98c5992918b8611baa24a96114a1ab78a.tar.bz2
gentoo-2-5f824af98c5992918b8611baa24a96114a1ab78a.zip
Respect LDFLAGS wrt bug 336196. Thanks to Diego for the report. Fix install and implicit function declaration. Drop old.
(Portage version: 2.2_rc73/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/rnaview')
-rw-r--r--sci-biology/rnaview/ChangeLog13
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-implicit.patch13
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-makefile.patch67
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r1.ebuild43
-rw-r--r--sci-biology/rnaview/rnaview-20040713-r2.ebuild34
5 files changed, 125 insertions, 45 deletions
diff --git a/sci-biology/rnaview/ChangeLog b/sci-biology/rnaview/ChangeLog
index 7419dff16e9b..cf3cc33e592a 100644
--- a/sci-biology/rnaview/ChangeLog
+++ b/sci-biology/rnaview/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sci-biology/rnaview
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/ChangeLog,v 1.11 2008/08/26 18:08:55 ribosome Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/ChangeLog,v 1.12 2010/09/06 12:24:45 xarthisius Exp $
+
+*rnaview-20040713-r2 (06 Sep 2010)
+
+ 06 Sep 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ -rnaview-20040713-r1.ebuild, +rnaview-20040713-r2.ebuild,
+ +files/rnaview-20040713-implicit.patch,
+ +files/rnaview-20040713-makefile.patch:
+ Respect LDFLAGS wrt bug 336196. Thanks to Diego for the report. Fix
+ install and implicit function declaration. Drop old.
*rnaview-20040713-r1 (26 Aug 2008)
diff --git a/sci-biology/rnaview/files/rnaview-20040713-implicit.patch b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
new file mode 100644
index 000000000000..009f6e79ae86
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
@@ -0,0 +1,13 @@
+Fix implicit function declaration
+
+--- src/xml2ps.c
++++ src/xml2ps.c
+@@ -36,7 +36,7 @@
+ void read_sugar_syn(char *inpfile, long **sugar_syn);
+ void get_sugar_syn(FILE *inp, char *value_ch);
+ void get_chain_broken(long nres, double **a, double **b, long *chain_broken);
+-
++extern void get_BDIR(char *BDIR, char *filename);
+
+
+ FILE *psfile;
diff --git a/sci-biology/rnaview/files/rnaview-20040713-makefile.patch b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
new file mode 100644
index 000000000000..5d9ecd99cf25
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
@@ -0,0 +1,67 @@
+Fix install paths, respect LDFLAGS, CFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=336196
+
+--- rnaml2ps/Makefile
++++ rnaml2ps/Makefile
+@@ -5,16 +5,21 @@
+ RNADRAW = rnaml2ps
+ OBJS_RNADRAW = rnaml2ps.o nrutil.o
+
++all: $(RNADRAW)
++
+ $(RNADRAW): $(OBJS_RNADRAW)
+- $(CC) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
++ $(CC) $(LDFLAGS) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
+
+ nrutil.o : nrutil.c
+- cc -c nrutil.c
++ $(CC) $(CFLAGS) -c nrutil.c
+
+ rnaml2ps.o : rnaml2ps.c
+- cc -c rnaml2ps.c
++ $(CC) $(CFLAGS) -c rnaml2ps.c
+
+
+-.PHONY : clean
++.PHONY : clean all install
+ clean:
+- rm *.o
++ rm -f *.o
++
++install:
++ install -D -m 0755 $(RNADRAW) $(DESTDIR)/usr/bin/$(RNADRAW)
+--- Makefile
++++ Makefile
+@@ -56,9 +56,14 @@
+ $(OBJ)/multiple.o \
+ $(OBJ)/statistics.o
+
++.PHONY: clean all install
++
++SUBDIRS = rnaml2ps
++
+ all: $(RNAVIEW)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} all ) ; done
+
+-CFLAGS = $(LINCLUDES)
++CFLAGS += $(LINCLUDES)
+
+ $(RNAVIEW) : $(HFILES) $(OBJ_FILE)
+ $(CC) $(CFLAGS) -o $@ $(OBJ_FILE) $(LDFLAGS) -lm $(MALLOCLIB)
+@@ -111,6 +116,15 @@
+ clean:
+ @rm -f $(OBJ)/*.o
+ @rm -f $(ALLTARGETS)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} clean ) ; done
++
++install:
++ install -D -m 0755 bin/rnaview $(DESTDIR)/usr/bin/rnaview
++ mkdir -p $(DESTDIR)/usr/share/rnaview/BASEPARS
++ install -m 0644 BASEPARS/* $(DESTDIR)/usr/share/rnaview/BASEPARS
++ mkdir -p $(DESTDIR)/usr/share/rnaview/test
++ install -m 0644 test/* $(DESTDIR)/usr/share/rnaview/test
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} install ) ; done
+
+ export:
+ mkdir -p $(EXPORT_DIR)
diff --git a/sci-biology/rnaview/rnaview-20040713-r1.ebuild b/sci-biology/rnaview/rnaview-20040713-r1.ebuild
deleted file mode 100644
index 4bdf64dfd6c1..000000000000
--- a/sci-biology/rnaview/rnaview-20040713-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/rnaview-20040713-r1.ebuild,v 1.1 2008/08/26 18:08:55 ribosome Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
-HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="public-domain"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -e "s/CC = cc/CC = $(tc-getCC)/" \
- -e "s/CFLAGS =/CFLAGS = ${CFLAGS}/" \
- -i Makefile || die
-}
-
-src_compile() {
- make clean
- make || die "Failed to build programs."
- cd "${S}"/rnaml2ps
- make clean
- make || die "Failed to build rnaml2ps."
- cd "${S}"/test
- rm '.#t'
-}
-
-src_install() {
- dobin bin/rnaview rnaml2ps/rnaml2ps || die "Failed to install programs."
- dodoc README || die "Failed to install documentation."
- mkdir -p "${D}"/usr/share/${PN}
- cp -r BASEPARS test "${D}"/usr/share/${PN}
- cat <<- EOF > 22rnaview
- RNAVIEW="/usr/share/rnaview"
- EOF
- doenvd 22rnaview || die "Failed to install environment file."
-}
diff --git a/sci-biology/rnaview/rnaview-20040713-r2.ebuild b/sci-biology/rnaview/rnaview-20040713-r2.ebuild
new file mode 100644
index 000000000000..e2bdbf053f08
--- /dev/null
+++ b/sci-biology/rnaview/rnaview-20040713-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rnaview/rnaview-20040713-r2.ebuild,v 1.1 2010/09/06 12:24:45 xarthisius Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="public-domain"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-implicit.patch
+ cat <<- EOF > 22rnaview
+ RNAVIEW="/usr/share/${PN}"
+ EOF
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README || die
+ doenvd 22rnaview || die
+}