summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-01 06:38:00 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-01 06:38:00 +0000
commit9b7cbfb06de02dd6e63202f01f017dcf6872ba6c (patch)
treedb09a740912dbe97990c253837f04e7d3f50db96 /sci-biology/rebase
parentVersion bump. (diff)
downloadgentoo-2-9b7cbfb06de02dd6e63202f01f017dcf6872ba6c.tar.gz
gentoo-2-9b7cbfb06de02dd6e63202f01f017dcf6872ba6c.tar.bz2
gentoo-2-9b7cbfb06de02dd6e63202f01f017dcf6872ba6c.zip
Version Bump
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog7
-rw-r--r--sci-biology/rebase/rebase-1106.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index 8fbe8fab9318..bbf1bdb944ed 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.104 2011/04/30 11:00:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.105 2011/06/01 06:38:00 jlec Exp $
+
+*rebase-1106 (01 Jun 2011)
+
+ 01 Jun 2011; Justin Lecher <jlec@gentoo.org> +rebase-1106.ebuild:
+ Version Bump
*rebase-1105 (30 Apr 2011)
diff --git a/sci-biology/rebase/rebase-1106.ebuild b/sci-biology/rebase/rebase-1106.ebuild
new file mode 100644
index 000000000000..7a90c2eb8b59
--- /dev/null
+++ b/sci-biology/rebase/rebase-1106.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1106.ebuild,v 1.1 2011/06/01 06:38:00 jlec Exp $
+
+EAPI="3"
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="
+ mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ \
+ || die "Failed to install enzyme prototypes file."
+ fi
+}