summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2008-08-27 14:58:50 +0000
committerOlivier Fisette <ribosome@gentoo.org>2008-08-27 14:58:50 +0000
commit08522d327168e70f25d784cc66159084c7d2aa7a (patch)
tree65970d66c4475effff5b0ee3dddddf953b67507a /sci-biology/rebase
parentNew upstream version. (diff)
downloadgentoo-2-08522d327168e70f25d784cc66159084c7d2aa7a.tar.gz
gentoo-2-08522d327168e70f25d784cc66159084c7d2aa7a.tar.bz2
gentoo-2-08522d327168e70f25d784cc66159084c7d2aa7a.zip
New upstream version.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog9
-rw-r--r--sci-biology/rebase/rebase-808.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index d2f125044506..54edb86b2034 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.86 2007/08/20 17:25:03 ribosome Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.87 2008/08/27 14:58:50 ribosome Exp $
+
+*rebase-808 (27 Aug 2008)
+
+ 27 Aug 2008; Olivier Fisette <ribosome@gentoo.org> +rebase-808.ebuild:
+ New upstream version.
*rebase-708 (20 Aug 2007)
diff --git a/sci-biology/rebase/rebase-808.ebuild b/sci-biology/rebase/rebase-808.ebuild
new file mode 100644
index 000000000000..f0c9ca09d672
--- /dev/null
+++ b/sci-biology/rebase/rebase-808.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-808.ebuild,v 1.1 2008/08/27 14:58:50 ribosome Exp $
+
+DESCRIPTION="A restriction enzyme database"
+LICENSE="public-domain"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+SLOT="0"
+# Minimal build keeps only the indexed files (if applicable) and the
+# documentation. The non-indexed database is not installed.
+IUSE="emboss minimal"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${PV} \
+ -protofile proto.${PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${PV} proto.${PV} || die \
+ "Failed to install raw database."
+ fi
+ newdoc REBASE.DOC README || die "Failed to install documentation."
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup} || die \
+ "Failed to install EMBOSS data files."
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ \
+ || die "Failed to install enzyme prototypes file."
+ fi
+}