summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 16:04:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 16:04:00 +0000
commit0e8984b52d11f97f055adb0acf0579ca0be3503c (patch)
tree8f07a8a73667caa23e7bb74a3166406d68f79e46 /sci-biology/poa
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #337121 (diff)
downloadgentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.tar.gz
gentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.tar.bz2
gentoo-2-0e8984b52d11f97f055adb0acf0579ca0be3503c.zip
Respecting LDFLAGS, 337856
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/poa')
-rw-r--r--sci-biology/poa/ChangeLog10
-rw-r--r--sci-biology/poa/files/2-respect-flags.patch26
-rw-r--r--sci-biology/poa/poa-2-r1.ebuild45
3 files changed, 79 insertions, 2 deletions
diff --git a/sci-biology/poa/ChangeLog b/sci-biology/poa/ChangeLog
index 8ef0bf72d20d..fcc3307104e7 100644
--- a/sci-biology/poa/ChangeLog
+++ b/sci-biology/poa/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/poa
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/poa/ChangeLog,v 1.2 2008/09/07 11:36:01 markusle Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/poa/ChangeLog,v 1.3 2010/09/18 16:04:00 jlec Exp $
+
+*poa-2-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Justin Lecher <jlec@gentoo.org> +files/2-respect-flags.patch,
+ +poa-2-r1.ebuild:
+ Respecting LDFLAGS, 337856
07 Sep 2008; Markus Dittrich <markusle@gentoo.org> poa-2.ebuild:
Fix outdated HOMEPAGE and keyword amd64.
diff --git a/sci-biology/poa/files/2-respect-flags.patch b/sci-biology/poa/files/2-respect-flags.patch
new file mode 100644
index 000000000000..bdd638cf64b7
--- /dev/null
+++ b/sci-biology/poa/files/2-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index a65bed0..713a7ab 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,9 +26,10 @@ LIBOBJECTS= \
+ stringptr.o
+
+
+-CC = gcc
++CC ?= gcc
+ #CFLAGS= -g -ansi-strict -W -Wall -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+-CFLAGS= -g -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
++OPT_CFLAGS = -g
++CFLAGS= $(OPT_CFLAGS) -DUSE_WEIGHTED_LINKS -DUSE_PROJECT_HEADER -I.
+ # -I$(HOME)/lib/include
+ # -DREPORT_MAX_ALLOC
+
+@@ -44,7 +45,7 @@ liblpo.a: $(LIBOBJECTS)
+
+ # NB: LIBRARY MUST FOLLOW OBJECTS OR LINK FAILS WITH UNRESOLVED REFERENCES!!
+ poa: $(OBJECTS) liblpo.a
+- $(CC) -o $@ $(OBJECTS) -lm liblpo.a
++ $(CC) $(LDFLAGS) -o $@ $(OBJECTS) -lm liblpo.a
+
+ what:
+ @echo poa: partial-order based sequence alignment program
diff --git a/sci-biology/poa/poa-2-r1.ebuild b/sci-biology/poa/poa-2-r1.ebuild
new file mode 100644
index 000000000000..a44fe8e66a71
--- /dev/null
+++ b/sci-biology/poa/poa-2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/poa/poa-2-r1.ebuild,v 1.1 2010/09/18 16:04:00 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+MY_P="${PN}V${PV}"
+
+DESCRIPTION="Fast multiple sequence alignments using partial-order graphs"
+HOMEPAGE="http://bioinfo.mbi.ucla.edu/poa/"
+SRC_URI="mirror://sourceforge/poamsa/${MY_P}.tar.gz"
+
+# According to SF project page
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-respect-flags.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPT_CFLAGS="${CFLAGS}" \
+ poa || die "make failed"
+}
+
+src_install() {
+ dobin "${S}"/poa "${S}"/make_pscores.pl || die
+ dolib.a "${S}"/liblpo.a || die
+ dodoc "${S}"/README "${S}"/multidom.* || die
+ insinto /usr/share/poa
+ doins "${S}"/*.mat || die
+}
+
+pkg_postinst() {
+ elog "poa requires a score matrix as the first argument."
+ elog "This package installs two examples to ${EROOT}usr/share/poa/."
+}