summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-11-13 15:36:55 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-11-13 15:36:55 +0000
commit60df5a744f3292e4ceec7f78401cb90f758b6e76 (patch)
treedbe7d2cf3ec8aa8f2880559f7d7740ddb717ed0c /sci-biology/paml
parentVersion bump (bug #285327) and add myself to maintainers, patches from bugs #... (diff)
downloadgentoo-2-60df5a744f3292e4ceec7f78401cb90f758b6e76.tar.gz
gentoo-2-60df5a744f3292e4ceec7f78401cb90f758b6e76.tar.bz2
gentoo-2-60df5a744f3292e4ceec7f78401cb90f758b6e76.zip
Version bump
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/paml')
-rw-r--r--sci-biology/paml/ChangeLog7
-rw-r--r--sci-biology/paml/paml-4.3a.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sci-biology/paml/ChangeLog b/sci-biology/paml/ChangeLog
index 3798dc8cfb96..dd135aa374e8 100644
--- a/sci-biology/paml/ChangeLog
+++ b/sci-biology/paml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/paml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.6 2009/07/21 08:44:44 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/ChangeLog,v 1.7 2009/11/13 15:36:55 weaver Exp $
+
+*paml-4.3a (13 Nov 2009)
+
+ 13 Nov 2009; Andrey Kislyuk <weaver@gentoo.org> +paml-4.3a.ebuild:
+ Version bump
*paml-4.2b-r1 (21 Jul 2009)
diff --git a/sci-biology/paml/paml-4.3a.ebuild b/sci-biology/paml/paml-4.3a.ebuild
new file mode 100644
index 000000000000..fc0efd0b27bb
--- /dev/null
+++ b/sci-biology/paml/paml-4.3a.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/paml/paml-4.3a.ebuild,v 1.1 2009/11/13 15:36:55 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+MY_P="${PN}43"
+DESCRIPTION="Phylogenetic Analysis by Maximum Likelihood"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+SRC_URI="http://abacus.gene.ucl.ac.uk/software/${PN}${PV}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i 's/-static//' "${S}/src/Makefile.UNIX" || die
+}
+
+src_compile() {
+ cd src
+ emake \
+ -f Makefile.UNIX \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ pushd "${S}"/src
+ dobin baseml codeml basemlg mcmctree pamp evolver yn00 chi2 || die
+ popd
+ dodoc README.txt doc/*
+ insinto /usr/share/${PN}/control
+ doins *.ctl || die "Failed to install control files"
+ insinto /usr/share/${PN}/dat
+ doins stewart* *.dat dat/* || die "Failed to install data files"
+ insinto /usr/share/${PN}
+ doins -r examples/ || die "Failed to install examples"
+}