summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2008-05-24 04:10:30 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2008-05-24 04:10:30 +0000
commit55741d44266a6d1ee6bd07ca48720f0c1d35e2df (patch)
tree75de86f9acbd493d9184a456a9f38081bae34fce /sci-biology/mummer/mummer-3.20.ebuild
parentFix built_with_use check, bug 223183 (diff)
downloadgentoo-2-55741d44266a6d1ee6bd07ca48720f0c1d35e2df.tar.gz
gentoo-2-55741d44266a6d1ee6bd07ca48720f0c1d35e2df.tar.bz2
gentoo-2-55741d44266a6d1ee6bd07ca48720f0c1d35e2df.zip
New package from sunrise, bug 169793
(Portage version: 2.1.5.2)
Diffstat (limited to 'sci-biology/mummer/mummer-3.20.ebuild')
-rw-r--r--sci-biology/mummer/mummer-3.20.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/mummer/mummer-3.20.ebuild b/sci-biology/mummer/mummer-3.20.ebuild
new file mode 100644
index 000000000000..11cf40d66f48
--- /dev/null
+++ b/sci-biology/mummer/mummer-3.20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.20.ebuild,v 1.1 2008/05/24 04:10:30 weaver Exp $
+
+MY_P="MUMmer${PV}"
+DESCRIPTION="A rapid whole genome aligner"
+HOMEPAGE="http://mummer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mummer/${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake || die "emake failed"
+
+ sed -i -e 's|\($AUX_BIN_DIR = "\).*"|\1/usr/bin"|' \
+ -e 's|\($BIN_DIR = "\).*"|\1/usr/bin"|' \
+ -e 's|\($SCRIPT_DIR = "\).*"|\1/usr/share/'${PN}'/lib"|' \
+ -e 's|\(set bindir = \).*|\1/usr/bin|' \
+ -e 's|\(set scriptdir = \).*|\1/usr/share/'${PN}'/scripts|' \
+ -e 's|\(use lib "\).*"|\1/usr/share/'${PN}'/lib"|' \
+ scripts/* exact-tandems mapview mummerplot nucmer promer run-mummer{1,3} || die "Failed to replace paths"
+ sed -i 's|$bindir/annotate|$bindir/mummer-annotate|' run-mummer1 scripts/run-mummer1.csh
+}
+
+src_install() {
+ dobin nucmer2xfig show-coords mapview show-snps run-mummer{1,3} \
+ exact-tandems promer repeat-match show-aligns gaps mummer \
+ show-tiling mgaps nucmer mummerplot delta-filter combineMUMs aux_bin/*
+ newbin annotate mummer-annotate
+
+ insinto /usr/share/${PN}/scripts
+ doins scripts/{*.awk,*.csh,*.pl}
+ insinto /usr/share/${PN}/lib
+ doins scripts/Foundation.pm
+
+ dodoc ACKNOWLEDGEMENTS ChangeLog README
+ insinto /usr/share/doc/${PF}
+ use doc && doins -r docs
+}