summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-09-26 02:30:24 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-09-26 02:30:24 +0000
commit6016df202e131f87b650b1df16ba77b60eb1fc61 (patch)
tree3c309163a34b071c26beb923c9c178a2a2e77926 /sci-biology/mothur
parentAddress CVE-2010-3081 related changes, thanks Enrico Tagliavini <enrico.tagli... (diff)
downloadgentoo-2-6016df202e131f87b650b1df16ba77b60eb1fc61.tar.gz
gentoo-2-6016df202e131f87b650b1df16ba77b60eb1fc61.tar.bz2
gentoo-2-6016df202e131f87b650b1df16ba77b60eb1fc61.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/mothur')
-rw-r--r--sci-biology/mothur/ChangeLog7
-rw-r--r--sci-biology/mothur/mothur-1.13.0.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sci-biology/mothur/ChangeLog b/sci-biology/mothur/ChangeLog
index e7eb46ee2ec5..aa5507440a3a 100644
--- a/sci-biology/mothur/ChangeLog
+++ b/sci-biology/mothur/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/mothur
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.6 2010/08/27 09:28:47 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.7 2010/09/26 02:30:24 weaver Exp $
+
+*mothur-1.13.0 (26 Sep 2010)
+
+ 26 Sep 2010; Andrey Kislyuk <weaver@gentoo.org> +mothur-1.13.0.ebuild:
+ Version bump
*mothur-1.7.2-r1 (27 Aug 2010)
diff --git a/sci-biology/mothur/mothur-1.13.0.ebuild b/sci-biology/mothur/mothur-1.13.0.ebuild
new file mode 100644
index 000000000000..392961eb18b6
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.13.0.ebuild,v 1.1 2010/09/26 02:30:24 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://schloss.micro.umass.edu/wiki/Main_Page"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="mpi +readline"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip
+ mpi? ( virtual/mpi )"
+RDEPEND=""
+
+S="${WORKDIR}/Mothur.source"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i -e 's/CC_OPTIONS =/CC_OPTIONS = ${CXXFLAGS} /' \
+ -e '/USEMPI ?=/ d' -e '/USEREADLINE ?=/ d' \
+ -e 's|CC = g++|CC = '$(tc-getCXX)'|' "${S}/makefile" || die
+
+ use mpi && sed -i '1 a USEMPI = yes' "${S}/makefile"
+ use readline && sed -i '1 a USEREADLINE = yes' "${S}/makefile"
+}
+
+src_install() {
+ dobin mothur || die
+}