summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-28 21:32:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-28 21:32:20 +0000
commit505835dbae555f3aa68f2fd4c7d452afc5978dbc (patch)
treed4ff29b648fcfe0c2e18a046b0db8af3fa396088 /sci-biology/mira
parentMask package dev-haskell/filepath. (diff)
downloadgentoo-2-505835dbae555f3aa68f2fd4c7d452afc5978dbc.tar.gz
gentoo-2-505835dbae555f3aa68f2fd4c7d452afc5978dbc.tar.bz2
gentoo-2-505835dbae555f3aa68f2fd4c7d452afc5978dbc.zip
Prepared for prefix, #325929
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/mira')
-rw-r--r--sci-biology/mira/ChangeLog6
-rw-r--r--sci-biology/mira/mira-3.0.0.ebuild15
-rw-r--r--sci-biology/mira/mira-3.0.3.ebuild15
-rw-r--r--sci-biology/mira/mira-3.0.5.ebuild15
4 files changed, 38 insertions, 13 deletions
diff --git a/sci-biology/mira/ChangeLog b/sci-biology/mira/ChangeLog
index 294e9c88c85b..a66ffc03fb6e 100644
--- a/sci-biology/mira/ChangeLog
+++ b/sci-biology/mira/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/mira
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.8 2010/05/05 08:00:05 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/ChangeLog,v 1.9 2010/06/28 21:32:20 jlec Exp $
+
+ 28 Jun 2010; Justin Lecher <jlec@gentoo.org> mira-3.0.0.ebuild,
+ mira-3.0.3.ebuild, mira-3.0.5.ebuild:
+ Prepared for prefix, #325929
*mira-3.0.5 (05 May 2010)
diff --git a/sci-biology/mira/mira-3.0.0.ebuild b/sci-biology/mira/mira-3.0.0.ebuild
index d112bee41571..3e2c7b2a8e47 100644
--- a/sci-biology/mira/mira-3.0.0.ebuild
+++ b/sci-biology/mira/mira-3.0.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.0.ebuild,v 1.4 2010/02/25 19:00:05 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.0.ebuild,v 1.5 2010/06/28 21:32:20 jlec Exp $
-EAPI="2"
+EAPI="3"
MIRA_3RDPARTY_PV="31-01-2010"
-inherit base autotools
+inherit autotools base multilib
DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
HOMEPAGE="http://www.chevreux.org/projects_mira.html"
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
CDEPEND=">=dev-libs/boost-1.35.0"
DEPEND="${CDEPEND}
@@ -30,6 +30,13 @@ src_prepare() {
AT_M4DIR="config/m4" eautoreconf
}
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-thread=boost_thread-mt
+}
+
src_compile() {
base_src_compile
if use doc; then emake -C doc clean docs || die; fi
diff --git a/sci-biology/mira/mira-3.0.3.ebuild b/sci-biology/mira/mira-3.0.3.ebuild
index 3475a31e9764..e4c046f191e3 100644
--- a/sci-biology/mira/mira-3.0.3.ebuild
+++ b/sci-biology/mira/mira-3.0.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.3.ebuild,v 1.1 2010/03/18 15:32:24 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.3.ebuild,v 1.2 2010/06/28 21:32:20 jlec Exp $
-EAPI="2"
+EAPI="3"
MIRA_3RDPARTY_PV="06-03-2010"
-inherit base autotools
+inherit autotools base multilib
DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
HOMEPAGE="http://www.chevreux.org/projects_mira.html"
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
CDEPEND=">=dev-libs/boost-1.35.0"
DEPEND="${CDEPEND}
@@ -30,6 +30,13 @@ src_prepare() {
AT_M4DIR="config/m4" eautoreconf
}
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-thread=boost_thread-mt
+}
+
src_compile() {
base_src_compile
if use doc; then emake -C doc clean docs || die; fi
diff --git a/sci-biology/mira/mira-3.0.5.ebuild b/sci-biology/mira/mira-3.0.5.ebuild
index 00d6e0a564f6..b1219203ea53 100644
--- a/sci-biology/mira/mira-3.0.5.ebuild
+++ b/sci-biology/mira/mira-3.0.5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.5.ebuild,v 1.1 2010/05/05 08:00:05 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mira/mira-3.0.5.ebuild,v 1.2 2010/06/28 21:32:20 jlec Exp $
-EAPI="2"
+EAPI="3"
MIRA_3RDPARTY_PV="17-04-2010"
-inherit base autotools
+inherit autotools base multilib
DESCRIPTION="Whole Genome Shotgun and EST Sequence Assembler for Sanger, 454 and Solexa / Illumina"
HOMEPAGE="http://www.chevreux.org/projects_mira.html"
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/mira-assembler/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
IUSE="doc"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
CDEPEND=">=dev-libs/boost-1.35.0"
DEPEND="${CDEPEND}
@@ -30,6 +30,13 @@ src_prepare() {
AT_M4DIR="config/m4" eautoreconf
}
+src_configure() {
+ econf \
+ --with-boost="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-boost-thread=boost_thread-mt
+}
+
src_compile() {
base_src_compile
if use doc; then emake -C doc clean docs || die; fi