summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-14 07:46:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-14 07:46:28 +0000
commit5cf665f7c3077c38582ffeb02904ee9c9433f4c2 (patch)
treede74447615f793c1a51639f4a732a2a0105cc6f6 /sci-biology/maq/maq-0.7.1-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-5cf665f7c3077c38582ffeb02904ee9c9433f4c2.tar.gz
gentoo-2-5cf665f7c3077c38582ffeb02904ee9c9433f4c2.tar.bz2
gentoo-2-5cf665f7c3077c38582ffeb02904ee9c9433f4c2.zip
Fix for _FORTIFY_SOURCE indicates presence of overflow, #363537; Don't mix FLAGS
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/maq/maq-0.7.1-r1.ebuild')
-rw-r--r--sci-biology/maq/maq-0.7.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-biology/maq/maq-0.7.1-r1.ebuild b/sci-biology/maq/maq-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..dfcdfff7be40
--- /dev/null
+++ b/sci-biology/maq/maq-0.7.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/maq/maq-0.7.1-r1.ebuild,v 1.1 2011/04/14 07:46:27 jlec Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Mapping and Assembly with Qualities - mapping Solexa and SOLiD reads to reference sequences"
+HOMEPAGE="http://maq.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ mirror://sourceforge/${PN}/calib-36.dat.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-bfr-overfl.patch
+ eautoreconf
+}
+
+src_install() {
+ default
+ insinto /usr/share/maq
+ doins "${WORKDIR}"/*.dat || die
+ doman maq.1
+ dodoc ${PN}.pdf
+}