summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-10 18:01:44 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-10 18:01:44 +0000
commit67a126b0fca8d7f0623c152778a8fbf4f4e03a84 (patch)
tree66284862ab9706d2f6fbe6262ba2f2fcc4d33123 /sci-biology/last
parentTransferred Prefix keywords (diff)
downloadgentoo-2-67a126b0fca8d7f0623c152778a8fbf4f4e03a84.tar.gz
gentoo-2-67a126b0fca8d7f0623c152778a8fbf4f4e03a84.tar.bz2
gentoo-2-67a126b0fca8d7f0623c152778a8fbf4f4e03a84.zip
Version Bump, #402941
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/ChangeLog9
-rw-r--r--sci-biology/last/last-192.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 08cfc0dab6ad..7d4eba45ac70 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/last
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.18 2011/12/15 18:58:48 ago Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.19 2012/02/10 18:01:44 jlec Exp $
+
+*last-192 (10 Feb 2012)
+
+ 10 Feb 2012; Justin Lecher <jlec@gentoo.org> +last-192.ebuild:
+ Version Bump, #402941
15 Dec 2011; Agostino Sarubbo <ago@gentoo.org> last-162-r1.ebuild:
Stable for AMD64, wrt bug #391545
diff --git a/sci-biology/last/last-192.ebuild b/sci-biology/last/last-192.ebuild
new file mode 100644
index 000000000000..60f5af78032e
--- /dev/null
+++ b/sci-biology/last/last-192.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-192.ebuild,v 1.1 2012/02/10 18:01:44 jlec Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
+src_compile() {
+ emake -e -C src CXX="$(tc-getCXX)" \
+ STRICT="" || die
+}
+
+src_install() {
+ dobin src/last{al,db,ex}
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/*
+ dodoc doc/*.txt ChangeLog.txt README.txt
+}