summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-16 21:32:34 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-16 21:32:34 +0000
commitdf8c62f3e899e77632d31e73036e2116f03082f9 (patch)
tree5ad07eeede1859e83b489bf44388534b7d6d7c48 /sci-biology/foldingathome
parentadded FAH-EULA-2014 license to EULA group (diff)
downloadgentoo-2-df8c62f3e899e77632d31e73036e2116f03082f9.tar.gz
gentoo-2-df8c62f3e899e77632d31e73036e2116f03082f9.tar.bz2
gentoo-2-df8c62f3e899e77632d31e73036e2116f03082f9.zip
version bump; license changed, is slightly more lax now
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
Diffstat (limited to 'sci-biology/foldingathome')
-rw-r--r--sci-biology/foldingathome/ChangeLog10
-rw-r--r--sci-biology/foldingathome/foldingathome-7.4.4.ebuild82
2 files changed, 90 insertions, 2 deletions
diff --git a/sci-biology/foldingathome/ChangeLog b/sci-biology/foldingathome/ChangeLog
index 973004424b29..218546762f76 100644
--- a/sci-biology/foldingathome/ChangeLog
+++ b/sci-biology/foldingathome/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/foldingathome
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.42 2013/05/13 16:47:20 axs Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/ChangeLog,v 1.43 2014/07/16 21:32:34 axs Exp $
+
+*foldingathome-7.4.4 (16 Jul 2014)
+
+ 16 Jul 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +foldingathome-7.4.4.ebuild:
+ version bump; license changed, is slightly more lax now
13 May 2013; Ian Stakenvicius <axs@gentoo.org> foldingathome-7.3.6-r2.ebuild:
showing special permission during pkg_setup so that we 'display this notice.'
diff --git a/sci-biology/foldingathome/foldingathome-7.4.4.ebuild b/sci-biology/foldingathome/foldingathome-7.4.4.ebuild
new file mode 100644
index 000000000000..9b9881484362
--- /dev/null
+++ b/sci-biology/foldingathome/foldingathome-7.4.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/foldingathome/foldingathome-7.4.4.ebuild,v 1.1 2014/07/16 21:32:34 axs Exp $
+
+EAPI="4"
+
+inherit versionator user
+
+MY_BASEURI="https://fah.stanford.edu/file-releases/public/release/fahclient"
+MY_64B_URI="${MY_BASEURI}/centos-5.3-64bit/v$(get_version_component_range 1-2)/fahclient_${PV}-64bit-release.tar.bz2"
+MY_32B_URI="${MY_BASEURI}/centos-5.5-32bit/v$(get_version_component_range 1-2)/fahclient_${PV}-32bit-release.tar.bz2"
+
+DESCRIPTION="Folding@Home is a distributed computing project for protein folding."
+HOMEPAGE="http://folding.stanford.edu/FAQ-SMP.html"
+SRC_URI="x86? ( ${MY_32B_URI} )
+ amd64? ( ${MY_64B_URI} )"
+
+RESTRICT="mirror bindist strip"
+
+LICENSE="FAH-EULA-2014 FAH-special-permission"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Expressly listing all deps, as this is a binpkg and it is doubtful whether
+# i.e. uclibc or clang can provide what is necessary at runtime
+RDEPEND="app-arch/bzip2
+ sys-devel/gcc
+ sys-libs/glibc
+ sys-libs/zlib"
+
+S="${WORKDIR}"
+
+I="opt/foldingathome"
+
+QA_PREBUILT="${I}/*"
+
+pkg_setup() {
+ I="${EROOT}/${I}"
+ einfo ""
+ cat "${PORTDIR}"/licenses/FAH-special-permission
+ einfo ""
+}
+
+src_install() {
+ local myS="fahclient_${PV}-64bit-release"
+ use x86 && myS="${myS//64bit/32bit}"
+ exeinto "${I}"
+ doexe "${FILESDIR}"/7.3/initfolding
+ doexe "${myS}"/{FAHClient,FAHCoreWrapper}
+ newconfd "${FILESDIR}"/7.3/folding-conf.d foldingathome
+ newinitd "${FILESDIR}"/7.3/fah-init foldingathome
+}
+
+pkg_preinst() {
+ # the bash shell is important for "su -c" in init script
+ enewuser foldingathome -1 /bin/bash /opt/foldingathome
+}
+
+pkg_postinst() {
+ chown -R foldingathome:nogroup "${I}"
+ einfo "To run Folding@home in the background at boot (with openrc):"
+ einfo "\trc-update add foldingathome default"
+ einfo ""
+ if [ ! -e "${I}"/config.xml ]; then
+ elog "No configuration found -- please run ${I}/initfolding or"
+ elog "emerge --config ${P} to configure your client and edit"
+ elog "${EROOT}/etc/conf.d/foldingathome for options"
+ fi
+ einfo ""
+ einfo "The original author encourages you to acquire a username and join team 36480."
+ einfo "http://folding.stanford.edu/English/Download#ntoc2"
+ einfo ""
+}
+
+pkg_postrm() {
+ elog "Folding@home data files were not removed."
+ elog "Remove them manually from ${I}"
+}
+
+pkg_config() {
+ "${I}"/initfolding
+}