summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-19 10:36:45 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-19 10:36:45 +0000
commitd1c0c2184880eb3d4279799f9c279a1725d43175 (patch)
treeb87036103fcf09d927e2806856aafc3f745a5933 /sci-biology/emboss
parentPull in required virtual/glu and virtual/opengl. (diff)
downloadgentoo-2-d1c0c2184880eb3d4279799f9c279a1725d43175.tar.gz
gentoo-2-d1c0c2184880eb3d4279799f9c279a1725d43175.tar.bz2
gentoo-2-d1c0c2184880eb3d4279799f9c279a1725d43175.zip
sci-biology/emboss: Fix compilation problem with toplplot, #391669, thanks Juergen Rose for the patch
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog9
-rw-r--r--sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild117
-rw-r--r--sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch112
3 files changed, 237 insertions, 1 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index fd0dd9332695..c9d8129d2fa4 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/emboss
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.67 2012/04/26 16:35:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.68 2012/11/19 10:36:45 jlec Exp $
+
+*emboss-6.3.1_p4-r1 (19 Nov 2012)
+
+ 19 Nov 2012; Justin Lecher <jlec@gentoo.org> +emboss-6.3.1_p4-r1.ebuild,
+ +files/emboss-6.3.1_p4-r1_plcol.patch:
+ Fix compilation problem with toplplot, #391669, thanks Juergen Rose for the
+ patch
26 Apr 2012; Justin Lecher <jlec@gentoo.org> -emboss-6.1.0.ebuild:
Drop old
diff --git a/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild b/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild
new file mode 100644
index 000000000000..119009d24004
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.3.1_p4-r1.ebuild,v 1.1 2012/11/19 10:36:45 jlec Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+MY_PATCH="4"
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="
+ ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/EMBOSS-${PV/_p${MY_PATCH}}.tar.gz
+ ftp://${PN}.open-bio.org/pub/EMBOSS/old/${PV}/fixes/patches/patch-1-${MY_PATCH}.gz -> ${P}.patch.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc minimal mysql pdf png postgres static-libs X"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/libpcre:3
+ sci-libs/plplot
+ sys-libs/zlib
+ mysql? ( dev-db/mysql )
+ pdf? ( media-libs/libharu )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ media-libs/gd
+ )
+ postgres? ( dev-db/postgresql-base )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )
+ X? ( x11-libs/libXt )"
+RDEPEND="${DEPEND}
+ !sys-devel/cons"
+PDEPEND="
+ !minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ sci-biology/rebase
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV/_p${MY_PATCH}}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${P}.patch
+ epatch \
+ "${FILESDIR}"/${PV}-unbundle-libs.patch \
+ "${FILESDIR}/${PF}_plcol.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with X x) \
+ $(use_with png pngdriver "${EPREFIX}/usr") \
+ $(use_with doc docroot "${EPREFIX}/usr") \
+ $(use_with pdf hpdf "${EPREFIX}/usr") \
+ $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config") \
+ $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config") \
+ $(use_enable amd64 64) \
+ $(use_enable static-libs static) \
+ --without-java \
+ --enable-large \
+ --enable-systemlibs \
+ --includedir="${ED}/usr/include/emboss"
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS
+ sed "s:EPREFIX:${EPREFIX}:g" "${FILESDIR}"/${PN}-README.Gentoo-2 > README.Gentoo && \
+ dodoc README.Gentoo
+
+ # Install env file for setting libplplot and acd files path.
+ cat <<- EOF > 22emboss
+ # plplot libs dir
+ PLPLOT_LIB="${EPREFIX}/usr/share/EMBOSS/"
+ # ACD files location
+ EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
+ EOF
+ doenvd 22emboss
+
+ # Symlink preinstalled docs to "/usr/share/doc".
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html
+
+ # Clashes #330507
+ mv "${ED}"/usr/bin/{digest,pepdigest} || die
+
+ # Remove useless dummy files from the image.
+ find emboss/data -name dummyfile -delete || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This avoids file collisions with versions of rebase that install their
+ # own enzyme prototypes file (see bug #118832).
+ mv "${ED}"/usr/share/EMBOSS/data/embossre.equ{,.orig} || \
+ die "Failed to move enzyme equivalence file."
+}
diff --git a/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch b/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch
new file mode 100644
index 000000000000..0f5e592b77f1
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.3.1_p4-r1_plcol.patch
@@ -0,0 +1,112 @@
+--- EMBOSS-6.3.1/ajax/graphics/ajgraph.c 2012-07-19 23:29:05.000000000 +0200
++++ /tmp/ajgraph.c 2012-07-19 23:25:00.000000000 +0200
+@@ -1645,14 +1645,14 @@
+ ** @return [void]
+ ** @@
+ ******************************************************************************/
+
+ static void GraphSetPen(ajint colour)
+ {
+- ajDebug("=g= plcol(%d '%s') [colour]\n", colour, graphColourName[colour]);
+- plcol((PLINT)colour);
++ ajDebug("=g= plcol0(%d '%s') [colour]\n", colour, graphColourName[colour]);
++ plcol0((PLINT)colour);
+
+ return;
+ }
+
+
+
+--- EMBOSS-6.3.1/plplot/plcore.c 2007-10-24 15:14:43.000000000 +0200
++++ /tmp/plcore.c 2012-07-19 23:25:00.000000000 +0200
+@@ -1709,13 +1709,13 @@
+ if (plsc->zdigmax == 0)
+ plsc->zdigmax = 3;
+
+ /* Switch to graphics mode and set color and arrow style*/
+
+ plgra();
+- plcol(1);
++ plcol0(1);
+
+ plstyl(0, &mk, &sp);
+ plpat(1, &inc, &del);
+
+ plsvect(def_arrow_x, def_arrow_y, 6, 0);
+
+--- EMBOSS-6.3.1/plplot/plstripc.c 2007-05-08 11:09:37.000000000 +0200
++++ /tmp/plstripc.c 2012-07-19 23:25:00.000000000 +0200
+@@ -153,17 +153,17 @@
+
+ plgchr(&sc, &dy);
+ sc = dy = dy/100;
+ plwind(-0.01, 1.01, -0.01, 1.01);
+ for (i=0; i<PEN; i++) {
+ if (mystripc->npts[i] || first) {
+- plcol(mystripc->colline[i]);
++ plcol0(mystripc->colline[i]);
+ pllsty(mystripc->styline[i]);
+ pljoin(mystripc->xlpos, mystripc->ylpos - sc,
+ mystripc->xlpos + 0.1, mystripc->ylpos - sc);
+- plcol(mystripc->collab);
++ plcol0(mystripc->collab);
+ plptex(mystripc->xlpos + 0.11, mystripc->ylpos - sc,
+ 0., 0., 0, mystripc->legline[i]);
+ sc += dy;
+ }
+ }
+ plwind(mystripc->xmin, mystripc->xmax, mystripc->ymin, mystripc->ymax);
+@@ -184,34 +184,34 @@
+ PLFLT x[]={0.,1.,1.,0.}, y[]={0.,0.,1.,1.};
+
+ /* Set up window */
+
+ plvpor(0,1,0,1);
+ plwind(0,1,0,1);
+- plcol(0);plpsty(0);
++ plcol0(0);plpsty(0);
+ plfill(4, &x[0], &y[0]);
+ plvsta();
+
+ /* Draw box and same window dimensions */
+ mystrip->wxmin=mystrip->xmin;
+ mystrip->wxmax=mystrip->xmax;
+ mystrip->wymin=mystrip->ymin;
+ mystrip->wymax=mystrip->ymax; /* FIXME - can exist some redundancy here */
+
+ plwind(mystrip->xmin, mystrip->xmax, mystrip->ymin, mystrip->ymax);
+
+ pllsty(1);
+- plcol(mystrip->colbox);
++ plcol0(mystrip->colbox);
+ plbox(mystrip->xspec, 0.0, 0, mystrip->yspec, 0.0, 0);
+
+- plcol(mystrip->collab);
++ plcol0(mystrip->collab);
+ pllab(mystrip->labx, mystrip->laby, mystrip->labtop);
+
+ for (i=0; i<PEN; i++) {
+ if (mystrip->npts[i] > 0) {
+- plcol(mystrip->colline[i]);pllsty(mystrip->styline[i]);
++ plcol0(mystrip->colline[i]);pllsty(mystrip->styline[i]);
+ plline(mystrip->npts[i], mystrip->x[i], mystrip->y[i]);
+ }
+ }
+
+ plstrip_legend(mystrip,0);
+ }
+@@ -269,13 +269,13 @@
+ if (stripc->xmax - stripc->xmin < stripc->xlen) {
+ if( yasc == 0) {
+
+ /* If user has changed subwindow, make shure we have the correct one */
+ plvsta();
+ plwind(stripc->wxmin, stripc->wxmax, stripc->wymin, stripc->wymax); /* FIXME - can exist some redundancy here */
+- plcol(stripc->colline[p]); pllsty(stripc->styline[p]);
++ plcol0(stripc->colline[p]); pllsty(stripc->styline[p]);
+ if ((stripc->npts[p]-2) < 0)
+ plP_movwor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
+ else
+ plP_movwor(stripc->x[p][stripc->npts[p]-2], stripc->y[p][stripc->npts[p]-2]);
+ plP_drawor(stripc->x[p][stripc->npts[p]-1], stripc->y[p][stripc->npts[p]-1]);
+ plflush();